Jump to content

Stupid Windows 7 Networking Bug


eovnu87435ds
 Share

Recommended Posts

It's been 3 days now that I cannot access my samba shares on my network drives, and it's all because I accidentally entered a wrong password...

I have 2 Win7 boxes on my network. My epic computer which just got a fresh reinstall, and an old p4 based comp with all my spare hard drives in it. Both are ultimate edition, but my epic computer is x64 and the p4 is x86. All of the drives in the p4 computer are shared with my workgroup(I don't use that home sharing crap because I have older windows machines as well as non-windows machines that connect as well) All worked fine with my 4 shares that I had mapped in My Computer. Today, I went to go add the USB printer I shared on it to my epic computer, it asked for the User/Pass of the p4 machine, when I accidentally typed it wrong. I got this error, which is quite normal.

\\DELLPRECISION is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Logon failure: user account restriction. Possible reasons are blank passwords are not allowed, logon hour restrictions, or a policy restriction has been enforced.

After getting this, I think to myself that I will just re enter the correct password. WRONG! instead, I can no longer get the User/Pass dialog to show up! Every time I click on a share, on that computer in the network, try to add a printer, click it in the browse network dialog, etc. that same pop up appears, and I have no opportunity to enter a new password! This is driving me absolutely insane! Can someone please help me before I destroy something? This is the most irritating bug have ever seen!

On a side note, even though I've been using 7 since the release candidate was out, I still wish windows had an option to make everything like it was in XP/2000, but still have aero and DX11.

Link to comment
Share on other sites

What you need to look out for is the NTFS permissions on the folder itself. Right click on the share, go to properties and then go to the security tab. Under the security tab, in the Groups or user names, there should be a group called Everyone, if you can't find that group you will need to add it. Also make sure that group, has full or write permissions and give it a go again.

Link to comment
Share on other sites

What you need to look out for is the NTFS permissions on the folder itself. Right click on the share, go to properties and then go to the security tab. Under the security tab, in the Groups or user names, there should be a group called Everyone, if you can't find that group you will need to add it. Also make sure that group, has full or write permissions and give it a go again.

Yeah, when I shared my folders, I did it via "Advanced Sharing Options," and I did give full permission to Everyone. It all worked until I put in the wrong password for connecting to the shared printer, and bam. I cant connect, nor can I change the password. it may possibly be because the Everyone group does not allow Anonymous users, but I am not sure...

Link to comment
Share on other sites

May sound stupid, but see if you can add that user to the other system, or if it exists on the other box, if the password needs to be reset for failed login attempts. If all else fails, assign it specific user(s). Is this part of a domain or just using the normal MSFT Windows Sharing through home networking?

The other thing to do is see if the drive is mapped still, remove it, and re-add it if possible. All else fails, unshare everything, reboot all machines, then reshare and see if that fixes it.

Link to comment
Share on other sites

May sound stupid, but see if you can add that user to the other system, or if it exists on the other box, if the password needs to be reset for failed login attempts. If all else fails, assign it specific user(s). Is this part of a domain or just using the normal MSFT Windows Sharing through home networking?

The other thing to do is see if the drive is mapped still, remove it, and re-add it if possible. All else fails, unshare everything, reboot all machines, then reshare and see if that fixes it.

I tried removing and remapping, and thats where I get the error shown in the OP. I have yet to un share everything since it is in the attic, but I should try that. This sharing is home sharing, using the MS workgroup crap instead of a domain since it works just fine for half a dozen computers. I'll let you know the results of un/re-sharing as soon as I can do it.

Link to comment
Share on other sites

That's what I normally do. When mapping a drive or a printer, I use different credentials and log in with thep4's local account. Now when I click map, instead of prompting me for a user and pass, that error pops up

EDIT: here's a video recording of the issue. it's a bit choppy because it was done through remote desktop, and my internet connection is not the greatest...

http://ge.tt/5J8kpZr

Edited by eovnu87435ds
Link to comment
Share on other sites

Same thing happens to me when I try to access my laptop from my desktop (both Win7). Works fine the other way around or accessing the WinXP box on the LAN but for some reason just can't get on my laptop.

Are they both set to the Home Group, Work or Private networks? One requires passwords to share, the other doesn't and one I think disallows accessing shares.

Control Panel\Network and Internet\Network and Sharing Center and check the "choose homegroup and sharing options". Also there is the "Change Advanced Sharing Options" under "Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings" with selections for home and private access to printers and such.

Another thought. there are a few services that need to be started. If "Server" and "Workstation" services are started but not "Computer browser", you can share, but not access remote shares. There are some other services that help as well, such as the Netbios stuff, but mainly those three need to be up. Check your nic settings allow printer and file sharing as well as Client for Microsoft networks are checked.

Edited by digip
Link to comment
Share on other sites

The other day I had to share my external hard drive so my brother could connect to it. I simply created another user account on my computer, make sure the account is part of a administrator's group.

Another thing you should also check, is whether "file and printer sharing" option is turned on. In Windows 7, go to control panel -> Network and Sharing Center -> click on the change advanced sharing settings link, situated on the upper left conner.

So make sure that option is turned on and then try mapping the share again, that should work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...