Jump to content

Http Sever On Dd-wrt


Jamo
 Share

Recommended Posts

SOLVED

I just had to forward web servers port to localhost, an stunnels port to localhost.

This topic can be removed.

Hi. I have Asus RT-N16.

I have installed php-thttpd http server. which configuration is following

root@DD-WRT:~# cat /opt/etc/thttpd.conf 
dir=/opt/share/www
port=8080
user=nobody
nochroot
nosymlink
novhost
logfile=/opt/var/log/thttpd.log
# Please do not edit pidfile path at it is use to kill thttpd process during init
pidfile=/opt/var/run/thttpd.pid

and for ssl I have installed and configures stunnel

root@DD-WRT:~# cat /opt/etc/stunnel/stunnel.conf 
; Sample stunnel configuration file by Michal Trojnara 2002-2005
; Some options used here may not be adequate for your particular configuration
; Please make sure you understand them (especially the effect of chroot jail)

; Certificate/key is needed in server mode and optional in client mode
cert = /opt/etc/stunnel/stunnel.pem
;key = /opt/etc/stunnel/stunnel.pem

; Some security enhancements for UNIX systems - comment them out on Win32
chroot = /opt/var/stunnel/
setuid = nobody
setgid = nobody
; PID is created inside chroot jail
pid = /stunnel.pid

; Some performance tunings
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
;compression = rle

; Workaround for Eudora bug
;options = DONT_INSERT_EMPTY_FRAGMENTS

; Authentication stuff
;verify = 2
; Don't forget to c_rehash CApath;  CApath is located inside chroot jail:
;CApath = /certs
; It's often easier to use CAfile:
;CAfile = /opt/etc/stunnel/certs.pem
; Don't forget to c_rehash CRLpath;  CRLpath is located inside chroot jail:
;CRLpath = /crls
; Alternatively you can use CRLfile:
;CRLfile = /opt/etc/stunnel/crls.pem

; Some debugging stuff useful for troubleshooting
;debug = 7
;output = stunnel.log

; Use it for client mode
;client = yes

; Service-level configuration


[https]
accept  = 444 (I have also used 443, while testing.)
connect = 8080
TIMEOUTclose = 9000

; vim:ft=dosini

All works well, when Im in lan, but when Im trying to connect outside my home network it doesn't work.

I have tried to forward ports to my router (192.168.1.1 and 127.0.0.1)

I have also successfully installed optware.

I have installed apache2 on my laptop. When i forward port 443 to it. it works from wan.

It seems that my ISP arent blocking ports 21, 22, 443, 444 and 8888 actually most of ports seems to be open.

Issue seems to be that my router just doesn't want to open those ports from wan to router. Wan to other ip is ok.

Edited by Jarmo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...