Jump to content

Feeding The Pineapple Wireless Internet


yesman
 Share

Recommended Posts

Unfortunately it doesn't. I used the alfa, compile a usbreset program to renitialize the hardware.. went through lsusb out put.. used a Netgear WG11v2 and a TP-Link all with compatible chipsets. None of the decide to show up in any of the config options, nor do they show up as a device under /dev.

I will probably go to 2.5 if that's what it will take. I mean, they said wifi relay and I want my relay darnit! :o

Thank you very much for you input! If you find anything else please don't hesitate.

here is what I came up with for my issue http://forums.hak5.org/index.php?/topic/27303-mk4-firmware-261-release/page__st__20#entry208364

Link to comment
Share on other sites

so, this might be off topic, and im sorry for bumping an old post, but can i connect an alfa to my mk4 (2.6.0) and set up internet pass-through through the 2 antenna's?

ie iwconfig wlan1 essid "NETWRORK_ID" key "NETWORK_KEY"

ifconfig wlan1 up

and have karma running on the onboard wifi antenna? this way i can have it passing internet without me being connected, thus allowing it to sit remotely for a bit, and i dont want to have to purchase a 3g because i cannot justify the cost/bill-per-month to the boss (read:wife)

Link to comment
Share on other sites

Good question. I have one.. did you read all the posts? The answer is only a few posts above yours. I totally sympathize with your current quandary. But I would feel it redundant and a disservice to you if you don't read through the knowledge already presented.

I will give you one hint. You need to bridge the wlan0 to wlan1, and the tool for that would be to use Iptables to route out-bound traffic to your internet accessible wifi.

Link to comment
Share on other sites

Good question. I have one.. did you read all the posts? The answer is only a few posts above yours. I totally sympathize with your current quandary. But I would feel it redundant and a disservice to you if you don't read through the knowledge already presented.

I will give you one hint. You need to bridge the wlan0 to wlan1, and the tool for that would be to use Iptables to route out-bound traffic to your internet accessible wifi.

I would bridge wlan1 to br-lan since most of the tools on the pineapple are sniffing br-lan, use WM's module networkmanager for all this
Link to comment
Share on other sites

Good question. I have one.. did you read all the posts? The answer is only a few posts above yours. I totally sympathize with your current quandary. But I would feel it redundant and a disservice to you if you don't read through the knowledge already presented.

I will give you one hint. You need to bridge the wlan0 to wlan1, and the tool for that would be to use Iptables to route out-bound traffic to your internet accessible wifi.

i understand bridging the connections, but as i stated, connecting the antenna alone has been a problem, as iwconfig is not a cmd subset within the pineapple. i can pass the connection through easily if i can get my alfa to connect to an existing access point first. i thought there was an existing limitation that i was unaware of....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...