Jump to content

Meterpreter Help


P@c_M@n
 Share

Recommended Posts

Hey guys, i was recently messing around with metasploit and i noticed something funny when i get a meterpreter shell. I am using a Backtrack 4 R2 Virtual Machine in Virtual Box and I am attacking my host OS which is Windows 7. I have also tried attacking Windows Vista with the same errors.

So, first i used the "migrate" command to migrate to explorer.exe.

So far so good. Okay, well then i tried the "getsystem" command to see if i could somehow elevate my privileges. But i got this error message:

[-] priv_elevate_getsystem: Operation failed: Access is denied.

And if i try to "run hashdump" i get this message:

[*] Obtaining the boot key...
[*] Calculating the hboot key using SYSKEY 1be5f252dcedd5d487c5644a3b497236...
[-] Meterpreter Exception: Rex::Post::Meterpreter::RequestError stdapi_registry_create_key: Operation failed: Access is denied.
[-] This script requires the use of a SYSTEM user context (hint: migrate into service process)

Is something wrong with metasploit or did I miss something?

Edited by Ghost_System
Link to comment
Share on other sites

Is the victims machine fully patched?

Also make sure that, UAC is not being used in Vista or Windows7, as it could be blocking the attacks.

And resulting in the erros you are receiving.

I also did a big of Googling and found this

http://www.backtrack-linux.org/forums/beginners-forum/32848-unable-dump-hashes-win7-meterpreter.html

Link to comment
Share on other sites

I will head to my virtual lab and see if I get the same results, if I don't I will let you know.

Link to comment
Share on other sites

Thanks Infiltrator. I tried the hashdump and getsystem commands on a virtual windows XP machine and they worked with no problems whatsoever. Guess it was the UAC after all. Tell me if you get any different results.

Edited by Ghost_System
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...