Jump to content

Nomachine Nx Setup (need Help)


ParMan
 Share

Recommended Posts

im trying to setup a nxserver but i cant seem to get it to work maybe im missing something. im trying to install this on backtrack 4 r2 it wont let me create user (trying to create root) i did change the default port from 22 to 866 but it seems i cant get any of it to work. so if anyone know anything about it and can help me out or just point me in the right direction to a good tutorial that would be great. thanks.

Link to comment
Share on other sites

Are you logged in as root or regular user? Have you tried sudo in front of your commands if not logged in as root?

I had done this under uBuntu a while back following a tutorial on the uBuntu forums, but I'm not sure it will apply in this case because of the fact that its BT and not uBuntu at its core. See here: https://help.ubuntu.com/community/FreeNX

Also, you need to understand that the BT4 kernel might not be able to do it if certain requirements aren't met by the needs of the software you are trying to install. You have to remember, BT uses a custom kernel and configuration. Its not standard Debian or uBuntu, and thus a lot of software doesn't work the same way out of the box because of dependencies and repositories. The Repositories aren't the same for everyday programs either and don't point to the same places as other distros might to do installs. BT keeps its own repositories to maintain customizations for the software installed in BT to be compatible with its custom kernel and internal settings.

Something to think about and another reason I always tell people, BT is NOT uBuntu and uBuntu is NOT BT.

Edited by digip
Link to comment
Share on other sites

yeah i was running as root. i think the problem is i missed one of the changes of the port since one was still trying to connect on port 22. but i forgot my laptop and home so i can mess with it till tomorrow.

i know backtrack is not Ubuntu. i dont expect it to work the same.

Link to comment
Share on other sites

yeah i was running as root. i think the problem is i missed one of the changes of the port since one was still trying to connect on port 22. but i forgot my laptop and home so i can mess with it till tomorrow.

i know backtrack is not Ubuntu. i dont expect it to work the same.

Modify /usr/NX/etc/server.cfg:

EnableAdministratorLogin = "1"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...