Jump to content

Ssh 2k3 Access Denied


G-Stress
 Share

Recommended Posts

Having major problems trying to get any SSH Server working in 2k3. I've tried OpenSSH, FreeSSHd and copSSH currently. OpenSSH I tried using the following config from this thread:

http://www.hak5.org/forums/index.php?showtopic=7118&hl=

I had that working along time ago on XP just fine. When I tried in this 2k3 VM executing the following 2 lines

mkgroup -l > ..etcgroup

mkpasswd -l > ..etcpasswd

it just hung in the prompt and done nothing. So I tried freeSSHd which I actually like, but everytime I went to connect using Putty, putty just came to a hault and freeSSHd would crash in the VM.

Now with copSSH I used this link to install

http://blogs.windowsnetworking.com/wnadmin...3-using-copssh/

but no matter what every user I activate when trying to connect using putty I get access denied. What have you guys used and recommend for ssh tunneling in 2k3?

Link to comment
Share on other sites

At your 2K3 machine is there any firewall active? Can you ping the 2K3 from any other machine on the network?

At one stage during, my SSH Server configuration, I had to generate certificates, have you done it at all?

Make sure you have the correct permissions on the user account in order to access the SSH server, if not that could be reason you are receiving Access is Denied.

Edited by Infiltrator
Link to comment
Share on other sites

@ Infiltrator,

Yea I can definitely ping the DC VM I also use it as a VPN Tunnel. As far as I know the correct permissions are set for the ssh server. Using copssh it said once I activated each user that it can now access the ssh server. I have not generated certificates yet for it. I may try that.

@ Bit Hunter,

Yea as soon as I posted this thread I discovered winSSHd. It was my first time hearing about that one and I installed it in an XP VM and it worked just fine. So I think I'm gonna try it now in the 2k3 DC VM.

Link to comment
Share on other sites

Hi G-Stress,

If your problem gets resolved, could you please post the solution in here, thanks.

Link to comment
Share on other sites

Will definitely do. I tried WinSSHd and still the same thing. Access denied so I'm positive now it is a permission setting somewhere in 2k3.

Make sure the installation directory and its sub directories have the proper permissions set.

Link to comment
Share on other sites

Does the user have access to CMD.exe. Have you tried to SFTP to the server. Have you tried with a local user or a virtual user in WinSSHd.

I am running WinSSHd on Windows 2003 Standard (without DC), don't have any problems.

Edited by Bit Hunter
Link to comment
Share on other sites

Hmmm, well I'm running enterprise edition as a DC I'll check the permission settings on the directory's. All user's whom is going to be using ssh does have access to cmd.exe and they are all local user's. I haven't tried SFTP yet I'll give that a go too then I'll definitely post back results.

Link to comment
Share on other sites

Got it figured out guys. I was getting and error indicated in this link and resolved it with the solution provided:

http://technet.microsoft.com/en-us/library...593(WS.10).aspx

I then had to add permissions to the installation directories as mentioned by Infiltrator. I was using Putty and Tunnlier as the clients. With putty I log in just by typing the username. With Tunnlier I had to type DOMAIN\USER.

I was using winSSHd, but had to switch back to copSSHd, because winSSHd personal use license doesn't support domains.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...