Jump to content

No Ip From Fon

Recommended Posts

When I connect to the fon by wifi, I get no IP,

When I connect the fon to my router and then I connect to my fon via wifi then I get an IP

Here's my config/dhcp file

the DHCP program is running

here are my proceses

and my ifconfig

Please have a look


  290 root      1960 S    logger -s -p 6 -t  
  291 root      1960 S    init       
  300 root      1972 S    /sbin/syslogd -C16 -S 
  302 root      1952 S    /sbin/klogd 
  311 root      1972 S    syslogd -C16 
  313 root      1952 S    klogd 
  325 root      1136 S    /sbin/hotplug2 --override --persistent --max-children
  718 root      1940 S    /usr/sbin/dropbear -p 22 
  723 root      1960 S    /usr/sbin/httpd -p 80 -h /www -r OpenWrt 
  733 root      1960 S    httpd -p 1471 -h /karma/www -r karma -c /karma/etc/ht
  735 root      1968 S    logread -f 
  736 root      1964 S    awk {if ($0 ~ /(KARMA: |DHCPACK|DHCPDISCOVER|DHCPOFFE
  737 root      1960 S    tail -f /tmp/status.log 
  738 root      1964 S    /bin/sh /karma/bin/logwatch 
  751 nobody    1276 S    /usr/sbin/dnsmasq -K -D -y -Z -b -E -s lan -S /lan/ -
  772 root      1952 S    watchdog -t 5 /dev/watchdog 
  827 root      1976 S    udhcpc -t 0 -i br-lan -r -b -p /var/run
  828 root      1996 R    /usr/sbin/dropbear -p 22 
  829 root      1968 S    -ash 
  844 root      1952 S    klogd

root@OpenWrt:/sbin# cat /etc/config/dhcp

config 'dnsmasq'
    option 'domainneeded' '1'
    option 'boguspriv' '1'
    option 'filterwin2k' '0'
    option 'localise_queries' '1'
    option 'local' '/lan/'
    option 'domain' 'lan'
    option 'expandhosts' '1'
    option 'nonegcache' '0'
    option 'authoritative' '1'
    option 'readethers' '1'
    option 'leasefile' '/tmp/dhcp.leases'
    option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
    option 'interface' 'lan'
    option 'start' '100'
    option 'limit' '150'
    option 'leasetime' '720m'
    option 'ignore' '0'

config 'dhcp' 'wan'
    option 'interface' 'wan'
    option 'ignore' '1'
    option 'start' ''
    option 'limit' ''
    option 'leasetime' ''

root@OpenWrt:/sbin# ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:12:CF:A5:3C:BF  
          RX packets:652 errors:0 dropped:330 overruns:0 frame:0
          TX packets:503 errors:0 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:49816 (48.6 KiB)  TX bytes:88440 (86.3 KiB)

br-lan    Link encap:Ethernet  HWaddr 00:12:CF:A5:3C:BE  
          inet addr:  Bcast:  Mask:
          RX packets:1047 errors:0 dropped:0 overruns:0 frame:0
          TX packets:444 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:83378 (81.4 KiB)  TX bytes:82635 (80.6 KiB)

eth0      Link encap:Ethernet  HWaddr 00:12:CF:A5:3C:BE  
          RX packets:961 errors:0 dropped:0 overruns:0 frame:0
          TX packets:663 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:95888 (93.6 KiB)  TX bytes:109408 (106.8 KiB)
          Interrupt:4 Base address:0x1000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:402 (402.0 B)  TX bytes:402 (402.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-12-CF-A5-3C-BF-00-00-00-00-00-00-00-00-00-00  
          RX packets:960 errors:0 dropped:0 overruns:0 frame:94
          TX packets:759 errors:18 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:195 
          RX bytes:90595 (88.4 KiB)  TX bytes:126088 (123.1 KiB)
          Interrupt:3 Memory:b0000000-b00ffffc

Link to comment
Share on other sites

This is because DCHP is ignore set to 1 on your fon. You get an IP from your router's DHCP server.

Typically mysetup with the fon/jasager is i have it teathered to my laptop and my laptop forwards all traffic. Although i think i have DHCP enabled. But if i didn't it should forward to the actual internet my laptop has.

I think there are other posts about setting up DHCP on the fon/jasager.

Edited by Mr-Protocol
Link to comment
Share on other sites

Thanks Mr-Protocol

I thought the fon should give an IP address to all the victums who are connecting to the jasager,

Is that not so?

I thought the laptop should only act as a gateway only to the internet, via f.i. a mobile cart connection.

So the fon/jasager makes the connection, assigns an IP with a gateway from my laptop, right?

Link to comment
Share on other sites

The fon in my case assigns IP's from it. But gateways through my laptop for internet.

I give my fon a static IP and my laptop lan card a static IP so i know i can talk to my jasager interface. The fon gives out IP's to clients and the fon gateway is my lan card IP (static) which i have setup to forward through my wifi card to actual internet.

Edited by Mr-Protocol
Link to comment
Share on other sites

Not sure why changing mac address would do that. But ok lol.

Some issue with my laptop ethernet interface and the foneras hardware or the openwrt firmware, either way i have to change my mac every time i want to connect via ethernet ... true story

Link to comment
Share on other sites

  • 3 weeks later...
Typically mysetup with the fon/jasager is i have it teathered to my laptop and my laptop forwards all traffic. Although i think i have DHCP enabled. But if i didn't it should forward to the actual internet my laptop has.

Mr. Proto... this is the setup I am trying to get up and running with my Win7 Laptop as I type... but no luck giving out IP's.. I can see through the Jasager Log (via the web interface) a client trying to associate with the Karma (open mesh) but its not able to get an IP.. and Ideas? I am not sure if the Xwrt portion of the interface is supposed to handle the DHCP and that should be setup..or if the Interface and the laptop is but a pass through and the DHCP rounter on the Gateway end would give out the needed IP addresses to the clients... ?

How do you map the traffic from the Ethernet/Jasager to the WLAN traffic on a windows box? I tried on a Backtrack laptop but I will save that for another mountain to climb..! Thanks for your time..

R (from PA)

Link to comment
Share on other sites

My setup is with BackTrack on my laptop. My Fon/Jasager gives out the IP's to clients. Then all traffic is forwarded through my laptop's LAN (wired) card to whatever wireless my laptop is connected to.

I never tried to do it with windows as the middle-man for a few reasons.

1) I have an old laptop with WinXP on it.

2) There are really no fun tools with Windows OS

3) Linux (More specifically BackTrack 4), has all the fun tools and no limits.

Edited by Mr-Protocol
Link to comment
Share on other sites

Ok.. So in BT4.. I have the Karma/Jasager running with LAN/WAN DHCP enabled .. So what it does is, like a good little DHCP server, hand out an IP to my ETH0 looking for one. But now I cannot get to the web interface (or any other for that matter) pings..nada.. It gave out an IP from ..but no real info from the IFUP when I configured the ETH0. Hmm..

I think I messed up my Interface config a bit earlier and have to edit that to NOT be DHCP..may set that at a Static..??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...