Jump to content

Cannot Connect To The Internet With Fon+

Recommended Posts

I've followed all of the directions noted here http://www.hak5.org/forums/index.php?showtopic=15269.

Up the the point of getting the fonera to connect to the internet.

echo 1 | sudo tee /proc/sys/net/ipv4/ip_forward
sudo iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

wlan0 because that is the device that is actually accessing my internet connection.

Im using a old eepc 900a running ubuntu.

Does anyone have any insight on this?

I would love help.


Link to comment
Share on other sites

echo 1 > /proc/sys/net/ipv4/ip_forward

sudo iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

Thats the command I use in BT4. I have the Fon/Jasager connected to my laptop ethernet port w/ crossover cable. I also modified the Fon to use my laptop's static IP on the LAN card as the gateway.

Doublecheck these settings:

Edit /etc/config/dhcp

list 'dhcp_option' '3,' **Sets Gateway to Laptop LAN card

list 'dhcp_option' '6,' **Sets DNS to GoogleDNS

Edit /karma/www/cgi-bin/functions.rb

under "def create_interface()" add the following:

system("sleep 1")

system("brctl addif br-lan ath0 2>&1 > /dev/null")

Login webif, Network tab, DHCP subtab, Disable Bogus Private Reverse Lookups, Disable filterwin2k, Disable Localise Queries ---Save settings and apply

Login Webif, Network Tab, Networks subtab, Set IP address with netmask ---Save settings and apply

Edited by Mr-Protocol
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...