Jump to content

Esxi Preformance Issues


Luca662
 Share

Recommended Posts

Hey hak5, I recently saw the esxi episodes and decided to give it a shot. I installed it onto a flashdrive and gave it a boot. Installed my favorite linux distro ubuntu and I made a samba server. I started transferring files over and noticed a major problem. My transfer speed was 2.78 megabytes per second! Thats absolutely terrible! When I was running ubuntu samba without vm I would get speeds close to 60 megabytes per second. I have 2gbs of ram, a 2.6 ghz processor and ubuntu was the only operatng system on and running. Is the free version of esxi capped in network speeds or is it a hardware issue?

Thank you for any input

-Luca

Link to comment
Share on other sites

I'm having similar issues as Luca, except my transfer speeds are @4MB per second.

Total RAM: 8GB

Processor: P4 3GHz

File System: VMFS 3.31

Block Size: 1 MB

Network Adapter: 1000 Full

VMWare Tools: Installed

Could there be something related to the environmental variables? I believe I've stumbled upon a huge list of various variables. Could one of them be limiting data transfer speeds?

Link to comment
Share on other sites

I'm not sure what Luca's setup is, but I was transferring between a physical box (FreeNAS) and a virtual machine (on the ESXi).

Both machines have 10/100/1000 NICs and are connected to each other via a 10/100/1000 switch.

Link to comment
Share on other sites

Question: When you say "P4 3GHz", are we actually talking about the old netburst Intel chips? On standard desktop kit? (I've only used ESXi on server hardware and 1 dell optiplex, which worked as expected) Have you tried the VMX net adaptors or are your VM's using E1000 adaptors? If you look at the resource usage, do the VM's show any spikes on any of the metrics?

Link to comment
Share on other sites

Yup. It's a Pentium 4 chip on an old server board.

When you are referring to the E1000 adapters, do you mean network adapters that are defined in the VM configuration? All my VMs (I have 4 that are running together), have default configuration for the Network.

Under resource usage, when I looked at the network usage of the VM during file copy (I was copying 1.5 GB file for testing), I saw a spike in the beginning and then it leveled off...

Let me also research some more what other VMX net adapters there are and see if that will make a difference...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...