Jump to content

Issue Grub2 Multipass


gix
 Share

Recommended Posts

Hi all,

I have wrote a script to setup a usb key as a multipass with grub2 and it works great but when i boot off it , half way though it say :-

NTFS volume version 3.1.

NTFS volume version 3.1.

EXT3-FS: sda5: coudln't mount because of unsupported optional features (240).

loads of time then stops to BusyBox and prompt (initramfs)

i used the mkfs.vfat -n bootkey /dev/sdd as darren said in the grub2 episode but it doesnt seem to work

any ideas way this is happening

many thanks

Link to comment
Share on other sites

Ok i can see there was a few views but no replies, i guess thats my bad has i didnt give much information in the first place

Well the distro in person is backtrack 4 final and i copied the backtrack part of the menu.lst file from the episode of the original mulitpass which darren did. I tried this version with the grub4dos 0.4.4 and the same error appeared. Well as i am using a 2gb thumb drive i used the command that i mentioned in my first post ie mkfs.vfat but i tried my 8gb thumb drive i have and where that is formatting in fat32 the error i was getting before was gone and a new error acured. The error now is "unable to find a medium containing a live file system" which i get when i get to the initramfs prompt i type cat casper.log which view this error. I cant understand why the first error was solved by formatting the 2gb thumb drive with fat32 when fat should work as darren said in that episode also this was the same when using unetbootin it worked fast32 but not fat on the 2gb thumb drive. So as i just said when formatted fat32 and using unetbootin it runs fine but trying to get grub4dos or the grub2 its a mission. I rename the /boot folder in bt to bootbt4 and left the files untouched, also tried leaving the casper folder at / of the thumb drive which creates the second error. After playing around with the structure with the unetbootin version that works i rename the casper folder to bcasper for example and it come up with the same error so i guess its something to do with the casper folder not being found but the only location in the menu.lst file it the kernel and initrd and i have tried putting the casper folder in every way i can think of and the same error acures

if anyone can help with this issue it will be great

many thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...