Jump to content

Not About To Connect To Pineapple Anymore


Recommended Posts

Hi I just received my pineapple from Darren today. I was about to get into the jasager interface at 192.168.1.1:1471 and the x-wrt interface at 192.168.1.1. Until I was following this guild http://www.hak5.org/w/index.php/Internet_C...mit_Der_Jasager. I got to the part where you change the router's ip address then hit save then apply. I was disconnected from the router after I hit apply and since then i am not about to log into the pineapple anymore. I'm using windows xp and whenever I connect now it would show that i'm connected but limited or no connectivity and i'm not able to get into the jasager or x-wrt interface anymore. If anyone can help me figure out what happen and how to fix it, that would be great.

Just noticed. I meant not able to and not "about" in the post title.

Edited by nMotion96
Link to comment
Share on other sites

That's because the instructions are flawed, you need to leave it as Static IP.

In the guide it states

Change the drop down box next to “Connection Type” from whatever it is set to, to something like Static IP and then back to DHCP. Do this a couple of times. For some reason, in my webif interface, when I change to DHCP, not all settings are available until I do this. In any case, you’ll want to see these options:

Have you done it a couple of times?

Anyway, hope this work for you.

Does anyone know how to do this in Backtrack 4?

It seams that all those connecting is not getting any internett accsess.

Link to comment
Share on other sites

Yeah I did that part a couple time just like how it states. I got to this part

(Change the IP address to something on the same subnet as your non-Internet Connection Shared NIC (that’s “Atheros”on eniac). I changed the IP in the webif interface to 192.168.0.250.

Set the Netmask to the default class C address (255.255.255.0).

Save your configuration twice. Once using the “Save Changes” button and then again using the “Apply Changes” button. )

After hitting save changes the apply changes. I got a page the in the browser that said this page cannon be displayed. Then ever since I was not able to log into the pineapple, and in xp when I connect to it. It would say limited or no connectivity.

Link to comment
Share on other sites

Ok i'll try that. But my problem right now is that I can not login into the web interface or jasager interface to change any setting. Also in windows xp it show that i'm connected with limited or no connectivity. I tried connecting from different computers and still the same thing.

Link to comment
Share on other sites

Ok i'll try that. But my problem right now is that I can not login into the web interface or jasager interface to change any setting. Also in windows xp it show that i'm connected with limited or no connectivity. I tried connecting from different computers and still the same thing.

You need to set your lan card to a different IP than 192.168.1.1 e.g 192.168.1.22 or 254

This way when you ping 192.168.1.1 you get response from the Jasager.

To do this, go to networks adapter, right click and choos properties, then select TCP/IP and properties again.

Set manually IP 192.168.1.22 and netmask 255.255.255.0, default gateway should be 192.168.1.1

hope that work and you will be able to ping the Jasager again.

Link to comment
Share on other sites

wow thanks that did something. It now shows that i'm connect not limited like before. But I tried to ping 192.168.1.1 and got nothing. In the guild (http://www.hak5.org/w/index.php/Internet_Connection_Sharing_mit_Der_Jasager) I was up to the step that you were to change the router's ip address which said to do this

(Change the IP address to something on the same subnet as your non-Internet Connection Shared NIC (that’s “Atheros”on eniac). I changed the IP in the webif interface to 192.168.0.250.

Set the Netmask to the default class C address (255.255.255.0).

Save your configuration twice. Once using the “Save Changes” button and then again using the “Apply Changes” button.

http://i364.photobucket.com/albums/oo88/ji...f_dhcp_save.png

I saved the changes this way, just to be safe. Now, remove power from the Fonera that’s running Der Jasager. Re-associate the ICS’ed NIC to its original access point. In my case, I re-associated “Alfa” to “WRT54G”. Wait a minute, and reapply power to the La Fonera. Then wait a while for the Fonera to boot and the non-ICS’ed NIC (“Atheros” in my case) to associate to “OpenWrt”. )

He said that he changed it to 192.168.0.250 I changed it to 192.168.1.230. I tried to ping that ip also but got nothing still.

Link to comment
Share on other sites

I think you are on the right track..

The idea is that two routers or AP does not be in conflict with each other, if both have the 192.168.1.1 you see that they would argue right?

Anyway, did you set your private ap router (the one connected to internet) to 192.168.1.230 or was this via the Jasager interface under network?

Have you checked that your AP and Jasager does not operate on 192.168.1.1 ?

If your computer has 192.168.1.230 and your Jasager have the same, there will be turly a conflict I would imagine.

Hope this help somehow..

Link to comment
Share on other sites

I think you are on the right track..

The idea is that two routers or AP does not be in conflict with each other, if both have the 192.168.1.1 you see that they would argue right?

Anyway, did you set your private ap router (the one connected to internet) to 192.168.1.230 or was this via the Jasager interface under network?

Have you checked that your AP and Jasager does not operate on 192.168.1.1 ?

If your computer has 192.168.1.230 and your Jasager have the same, there will be turly a conflict I would imagine.

Hope this help somehow..

I set it in the openwrt interface following the directions in the guild. Yes since my internet AP router is 192.168.1.1. I changed the openwrt to 192.168.1.230. Then i saved and apply, power down the pineapple like in the directions but now I can not login to openwrt or jasager using 192.168.1.1 or 192.168.1.230. I disable my wireless and currently directly connected to the pineapple.

Edited by nMotion96
Link to comment
Share on other sites

I set it in the openwrt interface following the directions in the guild. Yes since my internet AP router is 192.168.1.1. I changed the openwrt to 192.168.1.230. Then i saved and apply, power down the pineapple like in the directions but now I can not login to openwrt or jasager using 192.168.1.1 or 192.168.1.230. I disable my wireless and currently directly connected to the pineapple.

Try setting your private AP to 192.168.0.1 and your Jasager to 192.168.1.1

Set then your computers Internet card to 192.168.1.230 and your Internet sharing to 192.168.1.250

Try then to ping 192.168.1.1 and 192.168.1.1:1471

Keep in min that the openwrt is 192.168.1.1 and Fon is 191.168.1.1:1471

If you get the ping running, you can login via the browser

Link to comment
Share on other sites

Try setting your private AP to 192.168.0.1 and your Jasager to 192.168.1.1

Set then your computers Internet card to 192.168.1.230 and your Internet sharing to 192.168.1.250

Try then to ping 192.168.1.1 and 192.168.1.1:1471

Keep in min that the openwrt is 192.168.1.1 and Fon is 191.168.1.1:1471

If you get the ping running, you can login via the browser

I currently don't have internet sharing on or connected to my private ap. I have it directly connected. Yes i see in the paper that came with it that openwrt is 192.168.1.1 and fon is 191.168.1.1:1471. I got up to the point in the guild that you go into openwrt to change the ip. So mine wouldn't be 192.168.1.1 anymore correct? it would be 192.168.1.230 that i changed to. but still no luck. Is there anyway to reset and start over?

Link to comment
Share on other sites

I currently don't have internet sharing on or connected to my private ap. I have it directly connected. Yes i see in the paper that came with it that openwrt is 192.168.1.1 and fon is 191.168.1.1:1471. I got up to the point in the guild that you go into openwrt to change the ip. So mine wouldn't be 192.168.1.1 anymore correct? it would be 192.168.1.230 that i changed to. but still no luck. Is there anyway to reset and start over?

This I am not sure about, hopefully Digininja can answer this with more well described answers..

I might want to try and set if able the openwrt back to 192.168.1.1 and your connected computer to 192.168.1.22

then ping 192.168.1.1

I am not sure how you can reset the openwrt if you are not able to connect to it, on other routers such as e.g Netgear you have a reset button.

Purhaps flashing and the re-configure would help..

Anyway, I truly hope you get this working and that digininja can assist you further.

Good luck

Link to comment
Share on other sites

This I am not sure about, hopefully Digininja can answer this with more well described answers..

I might want to try and set if able the openwrt back to 192.168.1.1 and your connected computer to 192.168.1.22

then ping 192.168.1.1

I am not sure how you can reset the openwrt if you are not able to connect to it, on other routers such as e.g Netgear you have a reset button.

Purhaps flashing and the re-configure would help..

Anyway, I truly hope you get this working and that digininja can assist you further.

Good luck

yeah i see my problem. In order to set openwrt bak to 192.168.1.1 I would have to be able to connect to it. But I currently can not log into openwrt. Thanks for your help.

Link to comment
Share on other sites

couple of quick things to try, on your wired machine start up Wireshark and then power on your Fon. Watch Wireshark for any DHCP requests, just in case you accidentally turned on.

If you don't see any then fire up nmap and do a port scan of 192.168.1.0/24. I'd also be tempted to scan similar ranges, .0.0 and .2.0 just in case you made a typo when setting the IP address.

Link to comment
Share on other sites

couple of quick things to try, on your wired machine start up Wireshark and then power on your Fon. Watch Wireshark for any DHCP requests, just in case you accidentally turned on.

If you don't see any then fire up nmap and do a port scan of 192.168.1.0/24. I'd also be tempted to scan similar ranges, .0.0 and .2.0 just in case you made a typo when setting the IP address.

Ok I started wireshark then power on the fon. I waited about a minute and this is what wireshark got.

1.rar

Link to comment
Share on other sites

Look at the bottom of what you sent, you'll see dhcp discovery messages. Assuming you were running this on the interface that Jasager is plugged into you've set it to get its IP through dhcp. You'll need to start a dhcp server on your machine to give it an IP so you can get back into it.

Link to comment
Share on other sites

If you are going to do that then you need to make sure to put your machine on the right subnet. As you would have had to do with my subnet scanning idea, forgot to point that out.

Its is just easier to start a dhcp server I reckon.

Link to comment
Share on other sites

Look at the bottom of what you sent, you'll see dhcp discovery messages. Assuming you were running this on the interface that Jasager is plugged into you've set it to get its IP through dhcp. You'll need to start a dhcp server on your machine to give it an IP so you can get back into it.

I search around on how to start a dhcp server so I download this program called tiny dhcp server (http://www.softcab.com/dhcp-server/index.php) but I have no clue on how to use it. Is there a good place to go read on how to for it?

Link to comment
Share on other sites

Ok thanks for the help. I figured it out now. What I did was took the fon and plugged it into my router. I then logged into my router and from there looked for the fon and got the ip address and logged in.

Last question for now is that in the guild in the network setting on the fon it said to use dhcp but instead I'm suppose to use a static ip right?

Link to comment
Share on other sites

  • 1 year later...

That's because the instructions are flawed, you need to leave it as Static IP.

that is the reason alot of people are flashing and re-flashing theirs fons. is this true . this needs to be addressed i think as people are messing up things trying to change .including me lol.

is this the case ? how do devices joining the network get addressed then ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...