Jump to content

Setting Up The Fon With Bridged Internet


Recommended Posts

hi

finally i got my fon working and karma works

but now i try to bridge my wifi connection to my nic

so that the fon has internet and i'm in the middle

but every time i try this ( with bridge connection or ICS ) in windows

my internet connection fails, i'm connected but no internet access

how should i handle this( i have a HP pavilion dv7 3090-ED)

run windows and i have Sun VirtualBox

ty for the help

Link to comment
Share on other sites

Now you need to edit the /etc/config/dhcp Configuration file. Change the IP address to ones that are appropriate for your setup. Read the comments in there...

config 'dnsmasq'
    option 'domainneeded' '1'
    option 'boguspriv' '1'
    option 'filterwin2k' '0'
    option 'localise_queries' '1'
    option 'local' '/lan/'
    option 'domain' 'lan'
    option 'expandhosts' '1'
    option 'nonegcache' '0'
    option 'authoritative' '1'
    option 'readethers' '1'
    option 'leasefile' '/tmp/dhcp.leases'
    option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
    option 'interface' 'lan'
    option 'start' '100'
    option 'limit' '150'
    option 'leasetime' '720m'
    option 'ignore' '0'
    list 'dhcp_option' '3,10.110.0.1' # This is the IP address of . .
     #.  . The Host Laptop's Net-Interface acting as GW
    list 'dhcp_option' '6,10.110.0.2,8.8.8.8' # This is Option 6 define the DNS server, . .
     # .  . Then IP of Pineapple, Then Googles DNS IP

config 'dhcp' 'wan'
    option 'interface' 'wan'
    option 'ignore' '1'
    option 'start' '100'
    option 'limit' '150'
    option 'leasetime' '720m'

! Don't Reboot Yet !

Now, Navigate to the Webif Admin Web Page of Network/Networks i.e.

http://<IP ADDRESS OF YOUR PINEAPPLE AT THIS TIME>/cgi-bin/webif/network.sh

OK Now, Fill in the input fields with this information. . .Agin change the IP address to ones that make sens for your setup.

Connection Type = Static IP
Type = Bridged
IP Address = 10.110.0.2
Netmask = 255.255.255.0
Default Gateway = 10.110.0.1

Lan DNS servers = MAKE SURE THERE ARE NONE SET HERE... or make it 8.8.8.8

Now, hit the "Save Changes" Button then Apply Changes at the bottom.

It probably will not reconnect so just let it sit for like 5min's then Power Cycle

----------------

If your losing Internet connection on the Windows Laptop then you need to reset the Default GW on your Laptop. You can do this with the ROUTE command. Like so....

If your real GW is say... 192.168.1.1 then do this...

route delete 0.0.0.0 netmast 0.0.0.0

route add 0.0.0.0 netmask 0.0.0.0 192.168.1.1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...