Jump to content

Error Using Backtrack4


stlsaint
 Share

Recommended Posts

I have backtrack4 on usb and this entry on grub:

title BackTrack 4

root (hd0,0)

kernel /multiboot/backtrack/bootbt4/vmlinuz boot=casper ramdisk_size=6666 root=/dev/ram0 rw quiet

initrd=/multiboot/backtrack/bootbt4/initrd.gz

boot

But everytime i boot into it i get a repeating error saying:

EXT3-fs:Couldnt mount because of unsupported optional features (240).

This error continues to repeat until i reboot my system. It literally just repeats itself filling up my screen. Any ideas?

Link to comment
Share on other sites

  • 2 months later...

Curiously I have encountered the same problem, only with BT4 final and BT4 Pre, it works fine with BT4 Beta although I do get an error which is similar to the EXT3-fs one noted by stlsaint during the mounting of local filesystems

It seems to be caused by having an EXT4+ file system, its strange that it seems to boot fine in older versions, by just ignoring the partitions it doesn't understand

Does anyone know of any boot options that would tell BT4 to not mount any other drives?

Link to comment
Share on other sites

I can confirm it's a problem related to other partitions, I took the hard drive out of my Samsung NC10 and BT4 Final booted fine.

On the drive I have Ubuntu 10.04 (Upgraded from 9.10) so I think its on the EXT4-FS

As well as Windows 7 & Memtest, I can't see those guys causing the problem though

Going to have a look in GParted to see if there is anything unusual about Ubuntu's filesystem

If only my BIOS had the option to disable the HDD (Removing from boot order doesn't change anything)

Link to comment
Share on other sites

With my current setup I have

/dev/sda1 (ntfs) System Reserved (Windows 7 boot files by the looks of things)

/dev/sda2 (ntfs) No tags, just the normal data files for Windows 7

/dev/sda3 (Extended)

/dev/sda5 (ext4) Ubuntu 10.04 root

/dev/sda6 (linux-swap) Ubuntu swap

My error is exactally

EXT-fs: sda5: couldn't mount because of unsupported optional features (240)...

wait a minute...

Leave it long enough and it seems to boot anyway

Wow I feel silly right now!

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...