Jump to content

Zipit - no % sign? and new userland


_GRUB_
 Share

Recommended Posts

Hey guys,

I've had my zipit running the image from the first 'zipit' episode and I want to change it to the new image. Can anyone tell me what I need to do to just change to the new userland using linux? I don't want to lose my wireless drivers accidentally, so I figured I'd ask if anyone else has done it yet.

Also, is there a way to type a % symbol on the zipit?

Thanks!

Link to comment
Share on other sites

Found solution to my question on how to change to new image:

(from http://hunterdavis.com/archives/440)

As root do the following:

(assuming you are in ubuntu do a sudo bash)

Partition SDCARD

#1=ext3

#2=swap

mkfs.ext3 /dev/sdcardparttion#1

mkswap /dev/sdcard/partion#2

tune2fs -c 0 /dev/sdcardpartition#1

Mount SDCARD

mount /dev/sdcardpartition1 /directory/to/mount/to

tar xvjf rootnexus-rootfs.tar.bz2 /directory/sdcard/is/mounted/to

umount /directory/sdcard/is/mounted/to

boot z2

___

I could only find the rootnexus-rc1-pre01.tar.bz2 file so I guess this is the newest image available

Link to comment
Share on other sites

so the only way I could get all the files onto the micro sd card was to extract the tar.bz2 file to it's own directory, and then copy the contents of that directory to the micro sd card using this command:

cp -a /home/name/Documents/Zipit/. /media/Zipit

This placed the filesystem onto my card, and the zipit boots up into the new userland, but I cannot get the mouse or any keys to work at all. I tried doing what Snubs said and pressed the 'option' button to give control to the d-pad, but nothing happens. Any help would be greatly appreciated. Also, when I do get the mouse working, I still have the problem of not being able to type a % sign and need to figure out how to be able to do that.

Link to comment
Share on other sites

Ok, do not do the method I said I did. That way does not preserve file permissions and links. here is a page with instructions on how to do it.

http://zipit.rootnexus.org/files/Z2-USERLAND/Hurricane-RC0/

And here is the link to the actual filesystem to download

http://zipit.rootnexus.org/files/Z2-USERLAND/RC1-PRE0/

This should solve the mouse problem I was having. I'm copying the files over right now. Still have the problem with the % sign though.

PS. thanks to @azend for helping me with the zipit userland

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...