Jump to content

no ics and webif bricks fon


Recommended Posts

Ok I had Jasager and webif installed great on my fon+. All worked well except that connected jasager clients could not access the net through my laptop running winxp connected to a wireless AP (my home router). Time to enable ICS in windows to allow this...or so I thought. So after a lot of reading I decided to follow this tut: http://wiki.hak5.org/wiki/Internet_Connect...mit_Der_Jasager 1 point that failed to make sense was "You want to associate your ICS’ed NIC to “OpenWrt” at this point. I presume that was to try to connect my main wireless ics nic to an ap of "Open Wrt",the default essid showing in the webif interface. However this did not show in my wireless connections even after refreshing the list...???? Tried proceeding anyway but when I saved and applied the settings in webif for dhcp and ip the process paused and the fon becomes bricked (no access to it at all). Been at this for many hours now and seem to be going round in circles with no reward. No doubt it is something I have missed or done wrong. Be grateful of a little help please :mellow:

Don't know if this would be the cause.......

fon+

local ip: 192.168.1.1

local ip mask:255.255.255.0

default server ip:192.168.1.254

my wireless router set up

lan ip address: 192.168.1.1

sub mask: 255.255.255.0

router set as DHCP server

start ip: 192.168.1.2

end ip:192.168.1.51

don't know if they should be similar or not.

all firewalls are turned off just in case one is blocking access.

Tried enabling wireless on jasager control panel and setting up....still can't see "OpenWrt" ap

Link to comment
Share on other sites

I'm not up on the windows ICS so can't help with that but if you ssh in and then enable wifi through the Jasager interface you won't get any ESSID being broadcast, you only get openwrt if you have openwrt setup the wifi for you and you use its default settings.

Link to comment
Share on other sites

Thank you both for your replies and advice...... appreciated :)

so I ssh into my fon and found the following......

root@OpenWrt:~# vi /etc/config/wireless

config wifi-device wifi0

option type atheros

option channel auto

#REMOVE THIS LINE TO ENABLE WIFI:

option disabled 1

config wifi-iface

option device wifi0

option network lan

option mode ap

option ssid OpenWrt

option encryption none

You will have to excuse my Linux but I do try...... Clearly my wifi is disabled and that is why I can not see an "OpenWrt" on my wireless networks.

running this: uci set wireless.wifi0.disabled=0 && and uci commit wireless && wifi will enable it

(option disabled 1 changing to disabled=0 from one of those commands)

Does my wifi being disabled in this way account for my webif bricking the fon when I try to change the settings for DHCP and IP using the webif gui ?

Just need to know as I have bricked my fon 4 times trying to change these settings to enable ICS in win xp and although it is good practice for unbricking....I am a little concerned that I may brick it for good. :unsure:

Link to comment
Share on other sites

webif wouldn't brick your fon like that - what happens (most likely, it did for me) is that your Fon gets an IP from your ICS machine, and you're trying to connect to an IP which does not exist. Use NMap to see what IP your fon got, or just follow my guide here to get dnsmasq on the Fon set up.

You also have another problem - your Fon and victim IP range is the same as that of your home network. Change one of them.

Link to comment
Share on other sites

Thank you for your patience and help Psychosis B)

I have drawn a few conclusions from your advice and rather than ask a lot of questions I have set out below what I think went wrong and what needs to be done to fix it. I would be grateful if you could point out any errors or wrong assumptions that I have made.

When I used webif it assigned a "mystery ip" to my fon and this is why I could not connect to it afterwards as I was using the wrong ip to ssh in? (not bricked then, someone had changed the lock...lol) :rolleyes:

These IP settings can not be the same either (conflicting) so fon needs a new ip range:

fon+

local ip: 192.168.1.1

local ip mask:255.255.255.0

default server ip:192.168.1.254

my wireless router set up

lan ip address: 192.168.1.1

sub mask: 255.255.255.0

router set as DHCP server

start ip: 192.168.1.2

end ip:192.168.1.51

ssh into fon and execute these cmds I will solve this problem:

uci set network.lan.ipaddr=172.20.0.2 < example ip

uci set network.lan.gateway=172.20.0.1 < example ip

uci set network.lan.dns=192.168.1.1

uci commit network

(192.168.1.1 home router) (fons ip now 172.20.0.2)

then In /etc/config/dhcp, under the section config dhcp lan, add:

list 'dhcp_option' '3,172.20.0.1' < example ip

list 'dhcp_option' '6,192.168.1.1'

reboot

Change my ethernet IP to be on the Fon’s range?? help!! :unsure: lol , then SSH into its new IP address (mine is now 172.20.0.2). Accept the host key,log in and exit.

then enable ICS ,as I am using win xp.

Thanks again for your assistance :)

Link to comment
Share on other sites

Yep, that's what you would do. I can't see anything wrong with that setup. As for:

Change my ethernet IP to be on the Fon’s range?? help!!

You would need to change whatever adapter is connected to the Fon (I presume ethernet) to have the same IP that you set in

uci set network.lan.gateway=172.20.0.1 < example ip
Link to comment
Share on other sites

Ahhhhh! now I see :)

Yes my fon is connected to my ethernet adapter so I would need to change it's Ip to 172.20.0.1 < example ip.... as it is on the lan gateway if I was proceeding using those examples.

Thank you very much Psychosis you have been a real help. I will post later and let you know how I get on.

;)

Link to comment
Share on other sites

:)

Hi psychosis! Just to let you know everything went to plan and installed as I thought it should.... but I still can't connect to the internet through the fon. However, I think I may have spotted the problem. When I enable ICS ,on the laptop, my ethernet nic (that the fon is on) gets assigned an ip that does not match the fon's range. I tried to manually configure the Ip on that nic to fall in with the fon's range and I lose the internet connection out from my laptop. I will experiment a little more tomorrow and tweak the fon a bit in hope that it will fix the problem.

Thanks again for all your help B)

Link to comment
Share on other sites

Hi again. B)

As soon as I enable ICS windows automatically assigns an IP to my ethernet interface.....I have no way of stopping this as there are no options to do so.If I edit my ethernet interface to be on the same Ip as the fon after Ics has assigned an IP to it I then lose connection between my laptop wireless interface and home AP (router). Is there anyway I can stop windows assigning an IP to my ethernet interface automatically? Running win xp sp3.

The only other option I can see at the moment is to configure my fon around the automatic Ip windows assigns to my etherenet interface.This Ip is not the same as my home router AP so no conflict should occur, I presume.It seems a round about way of fixing the problem and I'm not 100% sure it would work but I can't see why it would not.

please advise....thank you. :)

This is the configuration Idea I had for the fon....would it work?

uci set network.lan.ipaddr=192.168.0.2

uci set network.lan.gateway=192.168.0.1 < automatcally assigned IP by windows to ethernet interface

uci set network.lan.dns=192.168.1.1 < home router IP

uci commit network

then this in /etc/config/dhcp

list 'dhcp_option' '3,192.168.0.1'

list 'dhcp_option' '6,192.168.1.1'

Link to comment
Share on other sites

:rolleyes:

could'nt help myself......Let's go for it and see!!!!!

at last....at last contact with the mothership....lol. All connecting fine now :D

At least I have learnt a little along the way....slowly getting there. ;)

Thanks for all your help and patience again Psychosis....also my thanks to digininja. B)

Link to comment
Share on other sites

:( Alas my victory was short lived...lol.

Although my idea seemed sensible and kind of made sense,it only allows my home pc to connect through the fon.Any other devices that try to connect through the fon fail. I think my problem lies with DHCP settings as I am having problems activating this setting on the fon itself.....using webif to do this is somehow messing up access to my fon after trying to set DHCP.

Boooooooo!!!! :huh:

Link to comment
Share on other sites

I have tried and tried with this fon and got nowhere....DHCP will not enable on the fon through webif, all webif does is disables all connection to the fon. Ics will now not work at all (was working but only off home pc).I have tried a multitude of ip ranges and I have tried many ways on this forum to get ics up and running none of them any good. I have even tried through ubuntu all ending in the same result......nothing!!!!

Is this fon fooked? :unsure:

Link to comment
Share on other sites

I am not alone then! (thank god lol) Psychosis had explained to me earlier that when I use webif to enable DHCP on the fon that maybe a "mystery ip" had been assigned to it ,hence I could not connect to the fon afterwards. Where is this ip coming from??? I have disabled DHCP client in windows under services.msc....no joy. I have configured the fon around the automatic IP assigned to my ethernet nic by windows that the fon connects to....Ics worked for a while but only on my home pc no other devices would connect to the fon then it stopped working altogether.(you can not stop windows assiging this IP to your ethernet nic when ICS is enabled) I have tried turning off DHCP on my home router. I have tried countless times with webif always ends the same.....no contact with fon afterwards. I have reset and reflashed the fon starting again afresh ,about 12 times now ,and have spent many hours trying to figure this out. I have also used nmap and arp-a command to locate the fon's "mystery IP" ....It never shows up.

Sorry to warble on guy's but it is not through lack of effort that I am failing. :(

Thoughts for today.......Can DHCP be enabled on the fon through OpenWrt command line? (webif sucks)

Do you need DHCP server enabled on the router you are using for internet connection? (if DHCP was enabled on the fon)

Is there a way to stop windows assigning a fixed IP to my ethernet nic when enablingICS?

Today is another day and who knows!!! I shall not give in!!!! :D

Any input or ideas welcome :)

Link to comment
Share on other sites

I'm confused now....! static ip? My win xp will automatically set my ethernet nic to 192.168.0.1 when ICS is enabled,this cannot be changed. So I configured my fon to have an IP of 192.168.0.2...gateway 192.168.0.1 and lan dns of 192.168.1.1 (home router ip). So in webif I use static ip then not DHCP and a bridged connection and set at that? I read somewhere that DHCP must be enabled on the fon so was I wrong? :unsure:

Link to comment
Share on other sites

Thanks Psychosis! I have been driving myself nuts with this...lol. The only thing is I must configure the fon around the automatic Ip that windows assigns to my ethernet nic when ICS is enabled....I have researched it and this can NOT be changed. If you do manually reconfigure the ethernet nic away from this automatic IP to match one set on the fon the internet connection is lost.

:) will try again and see what happens....I'll post back later!

Link to comment
Share on other sites

:( back again! lol

I can now connect to the internet with my home pc through the fon but the only thing I can connect to is google...lol. Any other web sites I try to view start to do so and the load bar goes about half way up....then failure with nothing visible on screen. I have looked through webif gui and can see that in "system" a warning to install NTP client is visible. Don't know if that would make a difference but I can't install it via webif gui anyway. :blink:

Link to comment
Share on other sites

:( back again! lol

I can now connect to the internet with my home pc through the fon but the only thing I can connect to is google...lol. Any other web sites I try to view start to do so and the load bar goes about half way up....then failure with nothing visible on screen. I have looked through webif gui and can see that in "system" a warning to install NTP client is visible. Don't know if that would make a difference but I can't install it via webif gui anyway. :blink:

I have had a sim experience with 1/2 internet. have you killed iptables binary? i know it seems baffling so i am following threads as more people get to this stage. I am contemplating installing interceptor or at least daemon logger...who knows- i am looking for solutions...keep us updated as to what you find out

Link to comment
Share on other sites

Been at this most of the day again...... <_<

If I use the settings static ip and bridged connection in webif I can get " half-internet" and a connected client will show an IP and mac address in the jasager interface. (ip used 192.168.0.2)

If I use the settings DHCP and bridged connection in webif I can get "half internet" but a connected client only shows a mac address NOT any IP in the jasager interface. (ip used 192.168.0.250)

:)

However on a brighter note I mentioned earlier that when I used webif to change the DHCP and IP settings and applied them I lost access to the fon.

Do this to regain access:

plug the fon into your router and go to your router log in page....Browse "connected devices" and you will see the fon and the Ip it was assigned....use this ip to regain access to webif,jasager,putty etc.

:rolleyes:

I am now at a total loss as to why I can only get "half internet".....even after a fresh flashing??

:huh: oh woe is me....lol HELP!!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...