Jump to content

Ubuntu 9.10 and Cowpatty


H247
 Share

Recommended Posts

<_< Hello everyone, i have been trying over and over to install cowpatty under my Ubuntu OS. I have no luck and im getting frustrated :angry: can anyone help please??? "Ubuntu 9.10 trying to install Cowpatty"

Link to comment
Share on other sites

Download the source

tar -xvzf cowpatty-4.6.tgz

cd cowpatty-4.6

make

sudo make install

If you get an error the post it

ok i will try this when i get home :)

Link to comment
Share on other sites

Download the source

tar -xvzf cowpatty-4.6.tgz

cd cowpatty-4.6

make

sudo make install

If you get an error the post it

ok thanks allot i got it installed finally :rolleyes: . this is what i did.

first i extracted cowpatty-4.6.tgz to the desktop then i opened up my terminal and did the following>>>>>

**

root@H-247:~$ cd ~/Desktop

root@H-247:~/Desktop$ cd cowpatty-4.6

root@H-247:~/Desktop/cowpatty-4.6$ make

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o md5.o md5.c

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o sha1.o sha1.c

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o utils.o utils.c

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o cowpatty.o cowpatty.c

cowpatty.c: In function ‘main’:

cowpatty.c:1016: warning: dereferencing pointer ‘eapkeypacket’ does break strict-aliasing rules

cowpatty.c:1012: note: initialized from here

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o genpmk.o genpmk.c

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb cowpatty.c -o cowpatty utils.o md5.o sha1.o -lpcap -lcrypto

cowpatty.c: In function ‘main’:

cowpatty.c:1016: warning: dereferencing pointer ‘eapkeypacket’ does break strict-aliasing rules

cowpatty.c:1012: note: initialized from here

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb genpmk.c -o genpmk utils.o sha1.o -lpcap -lcrypto

root@H-247:~/Desktop/cowpatty-4.6$ make install

install -d /usr/local/bin

install -m 755 cowpatty genpmk /usr/local/bin

root@H-247:~/Desktop/cowpatty-4.6$

**

Link to comment
Share on other sites

  • 4 weeks later...

root@dmraq-laptop:~/Downloads/cowpatty-4.6# make

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o md5.o md5.c

md5.c:20:25: error: openssl/md5.h: No such file or directory

md5.c: In function ‘md5_mac’:

md5.c:28: error: ‘MD5_CTX’ undeclared (first use in this function)

md5.c:28: error: (Each undeclared identifier is reported only once

md5.c:28: error: for each function it appears in.)

md5.c:28: error: expected ‘;’ before ‘context’

md5.c:29: warning: implicit declaration of function ‘MD5_Init’

md5.c:29: error: ‘context’ undeclared (first use in this function)

md5.c:30: warning: implicit declaration of function ‘MD5_Update’

md5.c:33: warning: implicit declaration of function ‘MD5_Final’

md5.c: In function ‘hmac_md5_vector’:

md5.c:40: error: ‘MD5_CTX’ undeclared (first use in this function)

md5.c:40: error: expected ‘;’ before ‘context’

md5.c:48: error: ‘context’ undeclared (first use in this function)

make: *** [md5.o] Error 1

these the errors that I am getting when i try to install Cowpatty-4.6

Link to comment
Share on other sites

  • 5 months later...

i have the same errors when i'm trying install cowpatty

cc -pipe -Wall -DOPENSSL -O2 -g3 -ggdb -c -o md5.o md5.c

md5.c:20:25: error: openssl/md5.h: Aucun fichier ou dossier de ce type

md5.c: In function ‘md5_mac’:

md5.c:28: error: ‘MD5_CTX’ undeclared (first use in this function)

md5.c:28: error: (Each undeclared identifier is reported only once

md5.c:28: error: for each function it appears in.)

md5.c:28: error: expected ‘;’ before ‘context’

md5.c:29: warning: implicit declaration of function ‘MD5_Init’

md5.c:29: error: ‘context’ undeclared (first use in this function)

md5.c:30: warning: implicit declaration of function ‘MD5_Update’

md5.c:33: warning: implicit declaration of function ‘MD5_Final’

md5.c: In function ‘hmac_md5_vector’:

md5.c:40: error: ‘MD5_CTX’ undeclared (first use in this function)

md5.c:40: error: expected ‘;’ before ‘context’

md5.c:48: error: ‘context’ undeclared (first use in this function)

make: *** [md5.o] Erreur 1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...