Jump to content

Zipit Z2 wireless issues


d4z
 Share

Recommended Posts

I am having issues with using my Zipit's wifi.

The wifi was working after copying the gspi8686.bin and gspi8686_hlp.bin to /lib/firmware/libertas and rebooting, but for some reason refuses to work now.

Running ifconfig only shows the loopback, and ifconfig eth1 up gives the error "eth1: ERROR while getting interface flags: No such device"

I ran dmesg and got the following, which shows that there's something wrong with libertas.

I'm not all that sure what to do to fix this. If anyone could give me a hand, I would really appreciate it!

Output of dmesg:

Linux version 2.6.29

(aliosa27@the-oracle) (gcc

version 4.3.3 (GCC) ) #1 Sat Sep

12 13:15:44 CDT 2009 CPU:

XScale-PXA270 [69054117]

revision 7 (ARMv5TE),

cr=0000397f CPU: VIVT data

cache, VIVT instruction cache

Machine: Zipit Z2 Memory policy:

ECC disabled, Data cache

writeback On node 0 totalpages:

8192 free_area_init_node: node

0, pgdat c035e7ac, node_mem_map

c0397000

Normal zone: 64 pages used for

memmap

Normal zone: 0 pages reserved

Normal zone: 8128 pages, LIFO

batch:0 Run Mode clock:

208.00MHz (*16) Turbo Mode

clock: 312.00MHz (*1.5, active)

Memory clock: 104.00MHz (/2)

System bus clock: 104.00MHz

Built 1 zonelists in Zone order,

mobility grouping on. Total

pages: 8128 Kernel command line:

console=ttyS2,115200

root=/dev/mmcblk0p1 rootdelay=2

fbcon=rotate:3 debug PID hash

table entries: 128 (order: 7,

512 bytes) Console: colour dummy

device 80x30 Dentry cache hash

table entries: 4096 (order: 2,

16384 bytes) Inode-cache hash

table entries: 2048 (order: 1,

8192 bytes) Memory: 32MB = 32MB

total Memory: 28808KB available

(3108K code, 351K data, 176K

init) Calibrating delay loop...

311.29 BogoMIPS (lpj=1556480)

Mount-cache hash table entries:

512 CPU: Testing write buffer

coherency: ok net_namespace: 300

bytes NET: Registered protocol

family 16 bio: create slab

<bio-0> at 0 I2C: i2c-0: PXA I2C

adapter Switched to high

resolution mode on CPU 0 NET:

Registered protocol family 2 IP

route cache hash table entries:

1024 (order: 0, 4096 bytes) TCP

established hash table entries:

1024 (order: 1, 8192 bytes) TCP

bind hash table entries: 1024

(order: 0, 4096 bytes) TCP: Hash

tables configured (established

1024 bind 1024) TCP reno

registered NET: Registered

protocol family 1 PXA CPU 27x

max frequency not defined

(pxa27x_maxfreq), assuming

pxa271 with 416000kHz maxfreq

PXA CPU frequency change support

initialized audit: initializing

netlink socket (disabled)

type=2000 audit(0.330:1):

initialized VFS: Disk quotas

dquot_6.5.2 Dquot-cache hash

table entries: 1024 (order 0,

4096 bytes) JFFS2 version 2.2.

(NAND) © 2001-2006 Red Hat,

Inc. alg: No test for stdrng

(krng) io scheduler noop

registered io scheduler

anticipatory registered io

scheduler deadline registered io

scheduler cfq registered

(default) pxa2xx-fb pxa2xx-fb:

machine LCCR3 setting contains

illegal bits: 04300000 pxa2xx-fb

pxa2xx-fb: Double Pixel Data

(DPD) mode is only valid in

passive mono single panel mode

Console: switching to colour

frame buffer device 40x30

pxa2xx-uart.0: ttyS0 at MMIO

0x40100000 (irq = 22) is a

FFUART pxa2xx-uart.1: ttyS1 at

MMIO 0x40200000 (irq = 21) is a

BTUART pxa2xx-uart.2: ttyS2 at

MMIO 0x40700000 (irq = 20) is a

STUART console [ttyS2] enabled

brd: module loaded Probing

processor-flash at physical

address 0x00000000 (16-bit

bankwidth) processor-flash:

Found 1 x16 devices at 0x0 in

16-bit bank processor-flash:

Found an alias at 0x800000 for

the chip at 0x0 processor-flash:

Found an alias at 0x1000000 for

the chip at 0x0 processor-flash:

Found an alias at 0x1800000 for

the chip at 0x0 processor-flash:

Found an alias at 0x2000000 for

the chip at 0x0 processor-flash:

Found an alias at 0x2800000 for

the chip at 0x0 processor-flash:

Found an alias at 0x3000000 for

the chip at 0x0 processor-flash:

Found an alias at 0x3800000 for

the chip at 0x0

Intel/Sharp Extended Query

Table at 0x0039

Intel/Sharp Extended Query

Table at 0x0039

Intel/Sharp Extended Query

Table at 0x0039

Intel/Sharp Extended Query

Table at 0x0039

Intel/Sharp Extended Query

Table at 0x0039 Using

auto-unlock on power-up/resume

cfi_cmdset_0001: Erase suspend

on write enabled erase region 0:

offset=0x0,size=0x2000,blocks=8

erase region 1:

offset=0x10000,size=0x10000,blocks=127

processor-flash: 1 set(s) of 1

interleaved chips --> 16

partitions of 512 KiB RedBoot

partition parsing not available

cmdlinepart partition parsing

not available Creating 3 MTD

partitions on "processor-flash":

0x000000000000-0x000000010000 :

"Bootloader"

0x000000010000-0x000000240000 :

"Kernel"

0x000000240000-0x000000800000 :

"Filesystem" spi spi1.0: in

setup: DMA burst size reduced to

match bits_per_word mice: PS/2

mouse device common for all mice

input: pxa27x-keypad as

/devices/platform/pxa27x-keypad/input/input0

input: gpio-keys as

/devices/platform/gpio-keys.0/input/input1

pxa-rtc pxa-rtc: rtc core:

registered pxa-rtc as rtc0 i2c

/dev entries driver APM Battery

Driver SA1100/PXA2xx Watchdog

Timer: timer margin 60 sec

z2_mci_setpower: on

z2_mci_setpower: on Registered

led device: z2:green:mmc

Registered led device:

z2:green:charge TCP cubic

registered NET: Registered

protocol family 17 RPC:

Registered udp transport module.

RPC: Registered tcp transport

module. XScale iWMMXt

coprocessor detected. pxa-rtc

pxa-rtc: setting system clock to

2000-01-01 00:00:05 UTC

(946684805) Waiting 2sec before

mounting root device... mmc0:

SCR structure version 0 mmc0:

host does not support reading

read-only switch. assuming

write-enable. mmc0: new SD card

at address 1234 mmcblk0:

mmc0:1234 SA02G 1.83 GiB

mmcblk0: p1 p2 p3 mmcblk0: p2

size 391104 limited to end of

disk mmcblk0: p3 ignored, start

3907008 is behind the end of the

disk VFS: Mounted root (ext2

filesystem) on device 179:1.

Freeing init memory: 176K

pxa27x_udc: version 2008-04-18

lib80211: common routines for

IEEE802.11 drivers

lib80211_crypt: registered

algorithm 'NULL' libertas_spi:

Libertas SPI driver In z2 SPI

setup libertas: Can't read bus

mode register. libertas_spi:

probe of spi1.0 failed with

error -5 Swap area shorter than

signature indicates No device

for DAI WM8750 WM8750 Audio

Codec 0.12<6>asoc: WM8750 <->

pxa2xx-i2s mapping ok Swap area

shorter than signature indicates

libertas_spi: Libertas SPI

driver In z2 SPI setup libertas:

Can't read bus mode register.

libertas_spi: probe of spi1.0

failed with error -5

Link to comment
Share on other sites

  • 2 years later...

Seeing as how your post comes up in the google results, I thought I'd add how I fixed this. Make sure there is a swap partition bigger than 128MB on your card. I made a 512MB because I am using it as a (really slow) minecraft server. then, if you are running ubuntu...

#iwconfig eth0 essid your_id_here
#iwconfig eth0 key your_hex_key_here
#ifconfig eth0 down
#ifconfig eth0 up
#dhclient eth0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...