Jump to content

help with flashing fon+


Recommended Posts

First of all,as this is my first post ,hello everyone and thanx for having me here @ hak5. I am about to attempt flashing a uk fon+ for the first time with jasager and after some reading on the forum this is how I plan to proceed. I would be grateful if someone could just point out any errors that I may be about to make before I try this.I will try to include as much info as I can....

model:Fon 2201c-uk firmware:3.1.1 r1 (I believe listening on 0.0.0.0 I have read) using winxp os.

1. Acceess redboot via serial and set local ip 192.168.1.1..address mask 255.255.255.0...defaultserver 192.168.1.254

for this I am going to use putty and a max232 that I had for accessing modems with a slight change in rx,tx and vcc wires as the pin outs differ on my fon+ from the plug on max232. The vcc MUST also be connected if using a max232.

2. Power off fon and remove max232,then connect ethernet lead between pc and fon+. Using Fon flash (gargoyle with wpcap drivers installed) load digininja's jasager firmware .squashfs and .izma into correct boxes and select nic card.Press "flash router now" and power up the fon+ (takes 20 mins or so to flash)

3.When flashing is done,telnet to 192.168.1.1 using putty and type in "passwd" hit enter and then type the password of my choice and hit enter......type my chosen password again and hit enter.

4. SSH back in on 192.168.1.1 using putty and my chosen password set earlier.Here I need to install webif if I require it ,but have no idea how yet so I hope I can do this later on. Finally wireless must be enabled by typing- uci set wireless.wifi0.disabled=0 then hit enter followed by typing- uci commit wireless && wifi then hit enter then type reboot and hit enter.

Eventually I should get the hang of this early stage with the help of more experienced members I'm sure, so please don't throw too many eggs lol. :rolleyes:

Link to comment
Share on other sites

You install webif by copying the packages over then using opkg.

For enabling the wifi, I deliberately leave it off and let Jasager turn it on when you visit the site for the first time, means you aren't open to the world by accident when you first turn it on.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...