Jump to content

Jasager on the UK Fon+ in Windows XP

Recommended Posts

This is my attempt at a noob friendly guide to flashing your Fon+ with Jasager in Windows XP (this is also my first post). I have amalgamated aspects of DigiNinja's and Darren's guides to solve the problem of flashing the awkward UK Fon+ (check the model number FON2201C-UK); although following this guide should flash Fon+'s from around the world.

If you get stuck at any point I would recommend reading Darren's Hak5 step-by-step forum post (excellent show guys) or DigiNinja's guide to installing Jasager.

So here goes...

USB to Serial Cable

As you probably know the IP on the UK Fon+ is set to and therefore can only be flashed using a serial cable. Bad times :( . There is an excellent guide on fashioning your own cable posted by DigiNinja on his website. I bought a Kycera cable from eBay and soldered the connections to single pin computer cables from Maplins, much easier than I thought.

Connect to RedBoot

Now you need to connect to your Fon+ through Putty to something called RedBoot onboard the Fon+.

First you need to find the COM Windows XP assigns. Right-click on 'My Computer' and choose 'Manage'. Navigate to 'Device Manager' click on 'Ports (COM & LPT)', you should see your cable and the COM port it has been assigned..


Open Putty and ensure that your 'Serial' settings are set to 9600, 8 and 1. Be sure to set 'Flow Control' to 'None'! Click 'Open'.


Insert the power to your Fon+ and immediately press Ctrl + c to interrupt the device startup. You will notice that the IP for the device is set to Not for long.

Change the Fon+ IP

To change the IP enter the following into the RedBoot session you just opened, you will need to input anything in bold (<Return> means press the enter key):

RedBoot> fconfig

Run script at boot: true <Return>

Boot script:

Enter script, terminate with empty line

>> <Return>


Boot script timeout (1000ms resolution): 2 <Return>

Use BOOTP for network configuration: false <Return>

Gateway IP address: <Return>

Local IP address:

Local IP address mask:

Default server IP address:

Console baud rate: 9600 <Return>

GDB connection port: 9000 <Return>

Force console for special debug messages: false <Return>

Network debug at boot time: false <Return>

Update RedBoot non-volatile configuration - continue (y/n)? y

... Erase from 0xa87e0000-0xa87f0000: .

... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

RedBoot> reset

Now power off the Fon+. Connect Ethernet between your computer and the Fon+.

Flash UK Fon+ with Jasager Firmware

Jasager is now available as a complete firmware, just flash and go. The firmware includes all dependencies and opkg recognises that the Jasager package is installed.

Download the 'Jasager Firmware 1.0' from DigiNinja. Extract the .tar from the .bz2 file using 7-zip; then extract the resulting .squashfs and .lzma files from the .tar - again using 7-zip.

Now we are going to use Freifunk Ap51 EasyFlash (I downloaded ap51-flash-gui-1.0-42.exe) which make flashing the Fon+ super simple.

In the GUI under 'Rootfs' check 'Use external file' and browse to 'openwrt-atheros-root.squashfs' you just extracted. Under 'Kernel' check 'Use external file' and browse to 'openwrt-atheros-vmlinux.lzma'. Select your Ethernet interface from the 'Interface' drop-down.

Power on the Fon+ and immediately click 'Go' in EasyFlash. The flashing process takes almost 20 minutes.


Image from Darren's post.

Set Your Password in Telnet

Using Putty select Telnet and Telnet over to type passwd and set your password twice; I recommend ilovepineapples!


Go to your favourite browser and enter Enter root as the user and your password in the password field. Well done, you successfully flashed your UK Fon+ :lol: !

EDIT: I compiled my 'how to' after 12 hours of experimentation with several methods; if I have missed any steps or made a mistake please reply to this thread and I will make adjustments accordingly. Thanks.

Link to comment
Share on other sites

UPDATE: The instructions below will permit you to use the Fon+ in Windows. Alternatively, fire up a copy of Bactrack 4 Final and follow my noob friendly guide to internet connection sharing and sslstrip!

To enable internet connection sharing in Windows XP you will probably need to set the Fon+ to DHCP. To do so you will need to install the webif interface. Do not do this if you want to follow my Backtrack guide!

xenomorph150 has already detailed how to add webif in his excellent guide.

SSH over to your Fon+ using Putty and enter the following when you see OpenWrt:

echo "src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8.../packages" >> /etc/opkg.conf

opkg update

opkg remove -recursive luci-*

opkg update

opkg install webif


uci set wireless.wifi0.disabled=0

uci commit wireless && wifi


Check out xenomorph150's guide for more information, I can't recommend it enough!

Edited by veyron
Link to comment
Share on other sites

Can you use an Ethernet to serial cable instead? The ones you can use to connect to the console on Cisco switches?

no because those cisco cables are not ethernet cables (they are serial cables with RJ-45 ends) and the ethernet ports on the fon are ethernet ports, not serial ports (as console ports on cisco routers/switches are)

Link to comment
Share on other sites

  • 10 months later...

Good guide so far. For a total noob guide I'd add a bit to the putty.

When in Putty you need to go to session and change connection type to Serial.

I wonder why I wasn't getting anywhere :)


Now stuck with a black screen and green cursor. I'm doing this in Windows 7 64bit. I do crtl C as the Fon+ is booting up but nothing happens on screen, stays black with green cursor.

Someone made the serial cable for me and we assume it's right.


Any ideas?

Link to comment
Share on other sites

To test the serial cable short RX and TX and then type into your PuTTY window, if you see your text echo'd back then the cable is working.

The problem could be that you shouldn't connect the ground till after the device has powered up otherwise it won't boot. I leave it till I see the first character appear, a + I think, then add the ground.

Link to comment
Share on other sites

To test the serial cable short RX and TX and then type into your PuTTY window, if you see your text echo'd back then the cable is working.

The problem could be that you shouldn't connect the ground till after the device has powered up otherwise it won't boot. I leave it till I see the first character appear, a + I think, then add the ground.

Thanks. We checked your images again and realise the cable was either wired wrong or we were connected to the wrong pins.

We've tried again. Connected to what we believe to be correct but get nothing. I've seen around here somewhere but can't find the thread, something to do with if the cables are crossed wrongly, you'd get garbage on screen.

So we swapped the Rx and Tx around and then we get one character


Then I try CRTL+C and then I get a load of garbage on the screen. So I assume this means the cable is working but when we put the cable in correctly we get nothing.

Any ideas?

I'm taking photos as I go in the hope I can give something back. In a noob guide. I know there are a few, but would like to do one that has near enough has every step, step by step. I find doing this a quite interesting, seeing the cable being made and trying to understand the electronics side of it which goes over my head.

I'm liking this thread as it's similar and is based in Windows (never gotten along with Linux). Surpised this thread hasn't been stickied or linked to in the guide sections.

Link to comment
Share on other sites

Regarding the echo'd back. What actually do you see on screen? We tried to test the USB to Serial cable as well as we knew that was working. But we used Hyperterminal to test that. We weren't sure what we were looking for. However, we would connect to the COM port in HT and type a character. Would just display the character as you type it. We then noticed, when we then jumped the pins and as we'd type one character, that character would automatically get written again on screen. I assume this is the echo back behaviour we are looking for in Putty? As soon as we stopped jumping the pins nothing could even be written.

Link to comment
Share on other sites

When I use putty I have local echo turned off so if you type something nothing comes back. When you short RX and TX then you should see what you send out as it goes out the transmit (TX) side and straight back in the receive (RX) side.

Link to comment
Share on other sites

Tested new cable by jumping the pins. I get the echo back in Putty. I stick the cable into the Fon+ power off, still get the echo back. Power it on, get nothing just the orange light. Then wait for the green light, plug in the ground. Still nothing.

So put the RX to where the TX is suppose to go and powered on. Nothing but orange light. But then when green light comes on I plug in the ground and then just get garbage.

Any ideas?

Link to comment
Share on other sites

  • 5 months later...

No, you would still see redboot even if the firmware was bust

I'm on the same firmware and I'm having the same problem. if i wire the pins backward i get garbage but wired correctly i get no display in both linux and windows using on board and usb serial adapters. i can still access the device normally i just have no serial if i bridge Tx and Rx i get a echo back on me computer. any ideas thanks

Link to comment
Share on other sites

Well done if you've both managed to break redboot, that is something I've never managed.

Are you trying connecting the serial before boot or once booted? I've seen different results in both situations, sometimes one will work and the other not then for no reason all go back to working.

Link to comment
Share on other sites

I've tried both serial before boot and once booted, under Linux i can get it to output constant hex code but that's the best i can get :(

it is right the i am using a rs232 DB9 cable

2 RX (Receive Data)

3 TX (Transmit Data)

5 GND (Signal Ground)

or is there a need for a rs232 ttl

eg.MAX232CPE RS-232 Transmitter/Receiver

Edited by Jonny190
Link to comment
Share on other sites

The type of cable has a special name which I can't remember. All I know is that the one I recommend on my site works so I keep buying the same one when I need new ones.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...