Jump to content

Acer one D250 Help Backtrack 4!!!


oreoha
 Share

Recommended Posts

hi there i am confronted with a Big problem i would like to install backtrack 4 onto my new christmas present a new Acer aspire one D250 but come to find out that the computer is having difficulties hooking up to my home network (or any network for that matter) i can not hook up via Wifi or even straight up Ethernet! and if i can not hook up to the interwebs i don't want to install it :unsure:

if anyone has any suggestions please reply

Link to comment
Share on other sites

Is there a radio function key on the keyboard to enable/disable the wifi card. Should be somehting like little Fn button. Usually "Fn+2" enables/disables the card, or something to that effect.

As for wired connection, if using dhcp on your router, it should be as simple as typing dhclient eth0 and get an address from dhcp on the router/network you are on.

Link to comment
Share on other sites

From memory all network cards are disabled by default on backtrack 4. Been a while since I have used it. Digip's suggestion was my issue and after running dhclient before startx my networking issue went away.

http://backtrack4.blogspot.com/2009/02/bac...oo-release.html

It may also pay to see if you can set a static IP address and see if it still works.

ifconfig eth0 192.168.1.2

replace all ip addresses and subnetmasks to those that correspond to your network.

ifconfig eth0 192.168.1.2 netmask 255.255.255.0

To manually add a default gateway:

route add default gw 192.168.1.1 eth0

Of course you would replace the IP address with your default gateways, also the eth0 interface is not always needed!

To manually assign your DNS servers:

echo nameserver 192.168.1.1 > /etc/resolv.conf

Link to comment
Share on other sites

From memory all network cards are disabled by default on backtrack 4. Been a while since I have used it. Digip's suggestion was my issue and after running dhclient before startx my networking issue went away.

http://backtrack4.blogspot.com/2009/02/bac...oo-release.html

It may also pay to see if you can set a static IP address and see if it still works.

ifconfig eth0 192.168.1.2

replace all ip addresses and subnetmasks to those that correspond to your network.

ifconfig eth0 192.168.1.2 netmask 255.255.255.0

To manually add a default gateway:

route add default gw 192.168.1.1 eth0

Of course you would replace the IP address with your default gateways, also the eth0 interface is not always needed!

To manually assign your DNS servers:

echo nameserver 192.168.1.1 > /etc/resolv.conf

the errors i am getting are SIOCSIFADDER: permission denied

SIOCSIFFLAGS: permission denied

also i tried running dhclient before the startx command and all permissions are denied

if you have any other suggestions i would like you to reply

Link to comment
Share on other sites

THANK YOU ALL OF YOU FOR REPLYING

im alot closer to where i need to be

but i am not able to connect to the internet so if you guys or anyone else has any suggestions please im willing to try anything...

my state right now is i believe my Acer i sending and receiving packets now because the lights on the Ethernet jack are lighting up (not alot but enough to make me happy)...

like i said im getting closer i belive and would like people to reply with any ideas they have!

Link to comment
Share on other sites

Permission denied probably because you need to be root. You can use "sudo su" and change your user to root in a terminal, or just dont forget to use "sudo" first to prefix the commands.

Like:

sudo ifconfig eth0 up

sudo dhclient eth0

sudo shutdown -h now

etc...

Link to comment
Share on other sites

Permission denied probably because you need to be root. You can use "sudo su" and change your user to root in a terminal, or just dont forget to use "sudo" first to prefix the commands.

Like:

sudo ifconfig eth0 up

sudo dhclient eth0

sudo shutdown -h now

etc...

i got it to work

Link to comment
Share on other sites

Are you running it off a live disc, or installed to the HDD? If installed, try Opera instead of FF. Much faster browser for BT4 in my opinion. This also depends on your Internet speed to begin with, but nothing will be blazing fast on an Atom CPU with 1gig of ram.

Link to comment
Share on other sites

Back|track 4 is rather buggy atm.. dhclient as super user(su) is what you should be using.. But I would suggest using BT3 until BT4 final if you do not know what your are doing, I been having issues with the pre release when it comes to upgrading..

and remember!! Sudo !!

Link to comment
Share on other sites

Im using a nearly final version of BT4 (I assume, since I got it from Mati). It has nearly the latest MSF pre installed, and is only like 2 updates behind from what is out now. A lot of what I dont like, is the ubuntu side putting in default network card drivers for shit, that when you go and put the enhanced ones in for packet injection, etc, you get all kind sof conflicts and have to find the ubuntu pre installed version and rename or delete them to clear up the issues. Was casuing my wireless card to work intermittingly since modprobe loaded BOTH drivers for the card at the same time, was hell tyring to find all the paths to the drivers and places it was calling it from to disable all the links. Once I did that and ran updatedb problem went away.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...