Jump to content

i only have half internet on with Fon connected PC


carloss
 Share

Recommended Posts

Hey guys,

The connected Pc (win7) has internet, but only the messengers ICQ, MSN and Twitter (TweetDeck), even Steam is Working!

I can see my buddys, write messages resieve messages write tweets, but I cant visit homepages like hak5.org.

Anyone here who could help me plz? :D

I did everything like the tutorial sayd http://hak5.org/forums/index.php?showtopic=15200

And not for the first time ( i just reinstalled ubuntu 9.10 and installed Wireshark, aircrack-ng, and then i did that tutorial)

Iḿ not using sslstrip with it, but it makes no difference.

When i start sslstrip out of the pinapple.sh and say yes i want sslstrip then there is a window that pops up and immediatly closes again.

When i used it on a previeus install of ubuntu (not this one) there was a phyton window wich stayed open. Now it does not.

Thats what my install.sh gives me:

cp: Aufruf von stat für „./pineapple.sh“ nicht möglich: No such file or directory
Could not coppy to pineapple.sh to /usr/bin/pineapple.sh
This is problay a typo in this install script edit to make work

and my pineapple.sh:

malte@ubu:~$ sudo '/home/malte/pineapple-0.4/pineapple.sh' 
[sudo] password for malte: 
/usr/bin/python2.6
Python-2.6 is installed
/usr/lib/python2.6/dist-packages/twisted/im.py
Python Module Twisted is installed

sslstrip option is enabled




Please enter Internet facing interface
If left blank Internet facing Network Interface will be set to wlan0

Please enter Internet facing interface, i.e. wlan0: ra0

ra0       Link encap:Ethernet  Hardware Adresse 00:22:43:13:1a:c2  
          inet Adresse:192.168.2.126  Bcast:192.168.2.255  Maske:255.255.255.0
          inet6-Adresse: fe80::222:43ff:fe13:1ac2/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:16933 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6268 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:8024756 (8.0 MB)  TX bytes:889469 (889.4 KB)
          Interrupt:19 

Internet facing Network Interface set to ra0



Please enter Pineapple facing Network interface
If left blank Pineapple facing Network Interface will be set to eth0

Please enter Pineapple facing interface, i.e. eth0: 

Pineapple facing Network Interface set to eth0

Do you want to enable sslstrip? Y/N:n
sslstrip is disabled

eth0 is given the IP address of 10.110.0.1 & netmask 255.255.255.0

IP forwarding enabled!

All iptables chains and rules cleared. . . Setting new iptables rules

iptables configured...

Default route removed. . .
.1: Unknown host
Default route set to .1 through ra0

Plug in the Pineapple

whould be nice if someone could help!!! :)

Sorry for my bad english, im from germany :D

Edit¹:

And Gmail works also. but not in a normal browser, it works in Prism.

I can ping the Fon Router, My EEE Pc which is running ubuntu and shoulkd provide the internet, an i can ping my "normal" Router with wich my eee pc is connected via wlan and which is providing the internet for this house. ANd i can ping internet pages too.

So why cant my browser acces webpages? while im connected to the Fon with Jasager and OpenWrt with webif??? O_O

HELP

Link to comment
Share on other sites

Default route removed. . .

.1: Unknown host

Default route set to .1 through ra0

looks like something is going wrong with setting the default gateway.

Do a #route -n and tell me what your default gateway is set as...

also try route del default && route add default gateway GW_IP_ADDRESS

Link to comment
Share on other sites

route -n gives me that:

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
192.168.2.0     0.0.0.0         255.255.255.0   U     2      0        0 ra0
10.110.0.0      0.0.0.0         255.255.255.0   U     1      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 ra0
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 ra0

and the second one...what do i have to enter as GW-IP? The "normal" router which provides the internet?

Or something else? o_O I entered 192,168.2.1 and when i do that i losse internet connection and have to reconnect to the router.

And it sayd:

SIOCADDRT: Operation not permitted

I have no firewall aktive, not even installed.

Both firefox and Internet explorer have no proxis set.

Firefox reports when i try to connect to google.com that it couldnt connect to the server of google.com.

When i am Pinging Google it just pings the dns server from openDNS. Which is standard in my Win7.

But without openDNS It doesnt work any better. And the Ping reply sounds like "couldnt find the host of www.google.com.

Whould it realy help if i get lynx working under windows? :P i could try to get it working but not today anymore...im tyred as hell...ist 2.40 am here :D

Could it have to doo with some settings in the "webif" of the Fon Router?

Thanks for trying to help! :)

Link to comment
Share on other sites

what happens if you try to ping something on the net via IP rather than domain name, does that work? Try 8.8.8.8

IP is working.

I pinged 8.8.8.8 and my vServer which also answered.

But today nothing has internet connection.

Not even ICQ, Msn and Twitter. Yesterday they worked perfectly.

ICQ should connect to login.icq.com, msn to messenger.hotmail.com

the messenger now says partialy connected.

icq is not connected a second later msn is not connected, then both are not connected. And that is changing around.

Could that all have to do to something with dns? o_O

Link to comment
Share on other sites

Sounds like your dns is bust, if you can ping by IP then you can get out to the internet. Check the dns server IPs in windows and set them to something like opendns or google dns.

When i use open dns it is no different then with the standard dns which my isp provides.

It doesnt look like the Problem is on the windows side.

Something with the Fon? Or with linux?

Do i have to have something special installed?

in the tutorial for the internet connection was an iptables stop command at the end to stop it. but in that directory my ubuntu has no iptables...

To Kill all of this just Run these commands with Root privileges

CODE

iptables -X

iptables -F

/etc/init.d/iptables stop

Link to comment
Share on other sites

Can you run wireshark or tcpdump on each machine in the chain to see where the packets are going, that would be a good way to track it down.

have a look for the iptables start/stop script in /etc/rc.d instead.

i´ll try that later, first i have to got o work :P

I tryed the pinapple script with backtrack4pre and it worked i can surf on the windows mashine.

But why isnt it working with ubuntu?

Link to comment
Share on other sites

Me again...I thougt it was working with BT4pre.

Now it does not. Actualy its the same Problem. But now with BT4

Wireshark on the BT4 System gives me the http "requests" that my windows pc send. But the windows pc does not recieve anything. But Windows says it has an internetconnection. o_O

Link to comment
Share on other sites

No i finaly got it working! :D

Now the PCs which are connected to the Fon via jasager have intermnet, BUT with sslstrip its not working...

no internet nothing ( on the with fon connected pc).

and on the eee pc which is running sslstrip the "sslstrip python" window is not displayed at all.

Sometimes wehn i start the script it appears for a part of a second...

Could you help me? :D

Link to comment
Share on other sites

The problem with sslstrip not working is do to the fact that the install.sh errorred out and quit without installing anything. So ya, you can run pineappple.sh from the install folder itself but it is trying to call sslstrip from /usr/src/sslstrip-0.7

If you just move sslstrip-0.7 to /usr/src It will Still NOT work. Because you still need to

sudo chmod -R 777 /usr/src/sslstrip-0.7

Because the default log file is written in that folder.

-------

The problems you are having are do to the script being depending on the computer speaking English.

I'll explain.

Here is the line of code that is giving you the problem in pineapple.sh.

However, the install.sh problem may be a problem with something ells. I'll talk about that latter

# This sets up the Default Route
#
GW=`ifconfig $Wan | grep "inet addr:"| grep -v "127.0.0.1" | cut -d: -f2 | awk '{ print $1}' | cut -d. -f1,2,3`
GW=`echo $GW.1`

You see that line of code is all assuming that the ifconfig $Wan will report back in English. So, if it dose NOT have the line with the string "inet addr:" then grep will report nothing. Leaving $GW blank. Then when the next line

GW=`echo $GW.1`

is run ... $GW="" and then only the ".1" is assigned to $GW.

SO, when the comand that sets the route is called

route add default gw $GW $Wan

You get the error

.1: Unknown host
Default route set to .1 through ra0

AND that is why DNS is not working for your WiFi connected clients.

YOU COULD EDIT the script and change that line of code to this. It still mite not work though.

GW=`ifconfig $Wan | grep "inet Adresse:"| grep -v "127.0.0.1" | cut -d: -f2 | awk '{ print $1}' | cut -d. -f1,2,3`

--------

Also Note, That this line of code is dependent on the Internet facing NIC Already being connected to the Internet.

Otherwise this line of code will not set the proper Route.

I need to do some more checking here.

I also need to ad a block to make sure iptables is installed.

I could add in check to make it work in Germen if that modified line of code works for you.

------------------

Now the install.sh problem..

This line of code is not working on your Germen computer.

cp ./pineapple.sh $PINEAPPLE_INSTALL_DIR/pineapple.sh

You DID do this right?

tar pxzvf pineapple-0.4.tar.gz
cd pineapple-0.4
sudo install.sh

Dose this directory exist on your computer?

/usr/bin

You do have the cp command in Germen Right?

Dose the default exit code on a Germen Linux Box still 0

will English bash scripts Run on a Germen Linux Box ?

Link to comment
Share on other sites

The problem with sslstrip not working is do to the fact that the install.sh errorred out and quit without installing anything. So ya, you can run pineappple.sh from the install folder itself but it is trying to call sslstrip from /usr/src/sslstrip-0.7

If you just move sslstrip-0.7 to /usr/src It will Still NOT work. Because you still need to

sudo chmod -R 777 /usr/src/sslstrip-0.7

Because the default log file is written in that folder.

-------

The problems you are having are do to the script being depending on the computer speaking English.

I'll explain.

Here is the line of code that is giving you the problem in pineapple.sh.

However, the install.sh problem may be a problem with something ells. I'll talk about that latter

# This sets up the Default Route
#
GW=`ifconfig $Wan | grep "inet addr:"| grep -v "127.0.0.1" | cut -d: -f2 | awk '{ print $1}' | cut -d. -f1,2,3`
GW=`echo $GW.1`

You see that line of code is all assuming that the ifconfig $Wan will report back in English. So, if it dose NOT have the line with the string "inet addr:" then grep will report nothing. Leaving $GW blank. Then when the next line

GW=`echo $GW.1`

is run ... $GW="" and then only the ".1" is assigned to $GW.

SO, when the comand that sets the route is called

route add default gw $GW $Wan

You get the error

.1: Unknown host
Default route set to .1 through ra0

AND that is why DNS is not working for your WiFi connected clients.

YOU COULD EDIT the script and change that line of code to this. It still mite not work though.

GW=`ifconfig $Wan | grep "inet Adresse:"| grep -v "127.0.0.1" | cut -d: -f2 | awk '{ print $1}' | cut -d. -f1,2,3`

--------

Also Note, That this line of code is dependent on the Internet facing NIC Already being connected to the Internet.

Otherwise this line of code will not set the proper Route.

I need to do some more checking here.

I also need to ad a block to make sure iptables is installed.

I could add in check to make it work in Germen if that modified line of code works for you.

------------------

Now the install.sh problem..

This line of code is not working on your Germen computer.

cp ./pineapple.sh $PINEAPPLE_INSTALL_DIR/pineapple.sh

You DID do this right?

tar pxzvf pineapple-0.4.tar.gz
cd pineapple-0.4
sudo install.sh

Dose this directory exist on your computer?

/usr/bin

You do have the cp command in Germen Right?

Dose the default exit code on a Germen Linux Box still 0

will English bash scripts Run on a Germen Linux Box ?

It wasnt the first time i set up this configuration.

First Time i used ubuntu 9.10 german too.

Installed from the same cd image as this time.

And i executed the scripts for the pinapple and i was happy that everything worked perfetly. now it did not.

Thanks for the Tip with chmod :D

I totaly forgot about the "read and write rights".

Now it works. :D

Link to comment
Share on other sites

Another problem:

When i start the fon and start internet connection forwarding on my ubuntu 9.10 eee pc. Start the interface and karma on the fon.

Then my windows pc finds a wlan connection of an unencrypted router which is not active for weeks.

So far so good.

I try to connect to that Router sometimes the pc connects 5 seconds latzer it is connected and i ve got internet and the eee pc can see all the packets .

Mostly, when the Fon is up a few hours and the eee pc is still forwarding the internet.

And my PC tries to connect to that "Fake" Router. It mostly cant connect or has no networkaccess or no connectivity and of course no internet.

The first connect after i started the Fon and have set up the eee pcs forwarding works great #.

But later it doesnt work at all.

When everything worked great and i disconnected and then tryed to reconnect it gives my "no network acces" and things like that or it simply says couldnt connect.

Any Ideas? :D

Link to comment
Share on other sites

Glad to here it is working now.

Did that modified line of code make the script work in Germen?

Did you get the install.sh to work or what of the things I listed could be the problem with the install.sh running on a Germen Box?

You know I was thinking that because I didn't specify the character encoding could be the problem.

i.e. I use this line to check the return code of the last command run and if it is anything other then 0 it will remove all installed files and exit with a specified exit code.

if [ $? != 0 ]; then

This is saying. . .

"if"=IF "$?"=the exit code of the last run command "!="=is not equal to "0"=0 "then"=Then do this. . .

So, if the encoding if different then utf-8 it may not read the reported exit code correctly.

-------------

Try adding this line to the vary top of both the install.sh and pineapple.sh scripts.

# -*- coding: utf-8 -*-

Link to comment
Share on other sites

Another problem:

When i start the fon and start internet connection forwarding on my ubuntu 9.10 eee pc. Start the interface and karma on the fon.

Then my windows pc finds a wlan connection of an unencrypted router which is not active for weeks.

So far so good.

I try to connect to that Router sometimes the pc connects 5 seconds latzer it is connected and i ve got internet and the eee pc can see all the packets .

Mostly, when the Fon is up a few hours and the eee pc is still forwarding the internet.

And my PC tries to connect to that "Fake" Router. It mostly cant connect or has no networkaccess or no connectivity and of course no internet.

The first connect after i started the Fon and have set up the eee pcs forwarding works great #.

But later it doesnt work at all.

When everything worked great and i disconnected and then tryed to reconnect it gives my "no network acces" and things like that or it simply says couldnt connect.

Any Ideas? :D

I have found my Jasager-FON to be a little overwhelmed with all the stuff it has to do. CPU is always vary high and a lot of RAM is used just sitting there. This "Could" be a problem but digininja would know a lot more about that then me because he wrote Jasager.

Also, if you are using "NetworkManager" that "Could" be the problem too. NetworkManager seems to brake everything. Like it could be Re-setting the default route after a bit. I use WICD and never have problems with ettercap or anything with it. WICD is just a GUI front-end for the command line tools.

Link to comment
Share on other sites

Glad to here it is working now.

Did that modified line of code make the script work in Germen?

Did you get the install.sh to work or what of the things I listed could be the problem with the install.sh running on a Germen Box?

You know I was thinking that because I didn't specify the character encoding could be the problem.

i.e. I use this line to check the return code of the last command run and if it is anything other then 0 it will remove all installed files and exit with a specified exit code.

if [ $? != 0 ]; then

This is saying. . .

"if"=IF "$?"=the exit code of the last run command "!="=is not equal to "0"=0 "then"=Then do this. . .

So, if the encoding if different then utf-8 it may not read the reported exit code correctly.

-------------

Try adding this line to the vary top of both the install.sh and pineapple.sh scripts.

# -*- coding: utf-8 -*-

From what i know there is no difference fom the englsih Version.

Inside the Terminal most of it is stil in english, if not everything.

I think it woulod be a lil bit crazy if I had to use different scripts depending on the language of the os im running.

In fact the install script worked just fine on an "other" installation of Ubuntu9.10!!

On the same hardware and installed from the same source.

(i wanted to reorganize my hard drive, differnet partition sizes etc so i formated and installed ubuntu 9.10 again, then i updated installed VLC, Wireshark, aircrack and then the pinapple script.)

But this time it did not work! And i cant see why. o_O

So i had to move sslstrip manualy and chmod it. Now it works.

And the DNS thing...

I solved it with changing in the FONs "etc/config/dhcp"

config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h
      list 'dhcp_option'      '3,10.110.0.1'
      list 'dhcp_option'      '6,192.168.2.1'

192.168.2.1 is the normal router in this house.

And with that the internet works.

Of course it would be better if it would work over 10.110.0.1.

Im not sure if i understood everything you wrote correctly

and im prety shure my english is realy bad so u dont understand everything i want to tell you :P

But thanks for the help!!! :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...