Jump to content

Can't boot after CAMICIA (FON 2201)


bichumo
 Share

Recommended Posts

Hi,

1) I had dd-wrt installed in FON2201, later decided to go for openwrt and jasager

2) I have installed openwrt, everything was fine, just the redboot was disabled after installing openwrt

3) I wanted redboot to be enabled, so I have installed CAMICIA and issued reboot, by:

mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7

reboot...

After reboot when I do ping 192.168.1.1 it starts ping just for about 2sec (I think redboot time, but I can't connect in that time) and later when openwrt should boot, it doesn't boot after that command. How could I re-enable redboot or how can I boot again to openwrt?

I have also tried "redboot.pl" script to connect to redboot from my mac, but max what I get is this:

---

192.168.1.1 is alive

-> == Executing boot script in 1.330 seconds - enter ^C to abort

<- ^C

Trying 192.168.1.1...

---

Thank you for any suggestions.

Link to comment
Share on other sites

I don't know about the mtd method of flashing but if it comes up at 192.168.1.1 for a short time then it implies redboot is still working and enabled. I've seen some Fons with the redboot timeout set at 2 seconds. If the script is waiting 1.3 seconds before acting then it might be acting too slow to hit within the window, try fiddling with the scrip to drop the time it waits before it does its job.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...