Jump to content

External Hard drive copying file issue


shonen
 Share

Recommended Posts

Hey Guys,

I encounter a problem I haven't come across before and my google searching left me up the creek. I have a Western Digital 700 and something GB external HDD which is formatted in FAT32.

I was backing up some .iso's prior to an O.S nuking and whenever I tried to copy one particular .iso image which was 4.06 GB in size I received a dialog box basically saying I don't have enough space. 0_o Which is weird considering I have 600 GB of free space to play with on the bloody thing.

I am guessing this has something to do with the fat32 format but I am not 100% certain and was wondering if someone could shed some light on to this problem for me.

Thanks in advance guys.

Shonen

Link to comment
Share on other sites

The maximum filesize on FAT32 is 4GB.

Ahhh I thought it was something like that, DAMN. thanks for the clarification mate. I take it I wont have this issue with NTFS but if I do that it will cock things up with the permissions wouldn't it?

Link to comment
Share on other sites

Do a convert to NTFS and you should be fine to copy the files over. Open a command prompt and then type:

convert driveletter: /FS:NTFS  /NoSecurity

Driveletter: is obviously the letter of your removable drive. The nosecurity switch is so that when you move it from PC to PC, other people can read the drive, otherwise, they need to take ownership of the files and folders to read them. Also note, anyone using a FAT system, will not be able to read the NTFS disk afterwards, so if you still use win95/98 on any machines, you wont be able to read the disk.

Link to comment
Share on other sites

You can do that with thumb drives as well. I wouldnt call it security, but keeps the average person from being able to read it if they tried to copy anything from it without knowing to take ownership of the files first. Great for people with XP Home edition, since they will get an error when trying to mount the thumbdrive.

Link to comment
Share on other sites

Why can you convert with no security, but you can't format a drive as NTFS with no security?

A format wipes everything, so it essentially wouldn't matter what the security level is at that point, because you would lose all the data in the process of formatting. I beleive NTFS sets a SID based on the RID when doing an NTFS format, as where a convert, has options as to what SID owns the converted filesystem and objects, files and folders(Default being administrators and creator/owners only).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...