Jump to content

Jasager not giving an IP


Recommended Posts

Just thought I would share my fix/workaround for this:

After installing the Jasager Firmare from Digininja's site, installing X-Wrt (Webif) and starting Karma, wireless clients dont get an IP address. dnsmasq si running.

This is because (in my experience) ath0 is not bridged to the ethernet port.

To fix this, I simply issued brctl addif br-lan ath0 to add ath0 to br-lan.

This setting doesn't seem to stay between reboots of the Fon though.

Link to comment
Share on other sites

From reading the OpenWRT Kamikaze documentation, it looks like I need to put

option 'network' 'lan'

under the config for ath0 in /etc/config/wireless. Problem is, there's no entry there, so I need to click on the button in the Jasager interface to create and setup ath0, then add it to the bridge.

What should be added to /etc/config/wireless to create ath0? Currently it contains:

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'disabled' '1'
        option 'country' '0'
        option 'hwmode' '11bg'
        option 'channel' '0'
        option 'maxassoc' ''
        option 'distance' ''
        option 'diversity' '1'
        option 'txantenna' '0'
        option 'rxantenna' '0'
        option 'antenna' ''

Link to comment
Share on other sites

Adding it to the bridged lan fixed my IP assigning issue. Now i just need to figure out how to get the darn thing to use my wired connection on my backtrack 4 laptop as an internet source and forward it to the wireless connection on the backtrack 4 laptop that is connected to actual internet.

Link to comment
Share on other sites

Easy workaround:

edit the function create_interface in /karma/www/cgi-bin/functions.rb to read:

def create_interface()
# using ` rather than system as system outputs messages to screen
    system("wlanconfig ath0 create wlandev wifi0 wlanmode master 2>&1 > /dev/null")
    [b]system("sleep 1")
    system("brctl addif br-lan ath0 2>&1 > /dev/null")[/b]
    #`wlanconfig ath0 create wlandev wifi0 wlanmode master > /dev/null`
end

(didn't work without the sleep.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...