Jump to content

Jasager Firmware Wireless - Need Help


Recommended Posts

Ok, I'm going to break this down with as much information as I can and hopefully we can get this working.

Ordered my Fon2100 at the end of Nov 09

Followed Darren's guide to unlocking and I used the Jasager Firmware instead of directly following Darren's example.

I installed WebIf after the firmware was flashed.

Logged into the WebIf interface to set a static IP for the fon to use 192.168.1.169 with a gateway 192.168.1.2

----- Connect crossover cable to my laptop eth0 card and booted from DVD into BackTrack 4 -----

Set my eth0 to 192.168.1.2

configured files as follows:

/etc/dhcp3/dhcpd.conf

ddns-updates off;
option T150 code 150 = string;
deny client-updates;
one-lease-per-client false;
allow bootp;
ddns-update-style none;

option domain-name-servers 8.8.8.8, 8.8.4.4;

default-lease-time 600;
max-lease-time 7200;

authoritative;

subnet 192.168.1.0 netmask 255.255.255.0 {
    interface eth0;
    range 192.168.1.2 192.168.1.254;
    default-lease-time 600;
    max-lease-time 7200;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.1.255;
    option routers 192.168.1.2;
    option domain-name-servers 8.8.8.8, 8.8.4.4;
}

Connected my wlan0 to my 192.168.0.x wireless network

/etc/default/dhcp3-server

INTERFACES="eth0"

iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

echo 1 > /proc/sys/net/ipv4/ip_forward

/etc/init.d/dhcp3-server start

The DHCP server starts with no errors.

I login to the Jasager interface and turn on the ath0 and I blacklist my AP I am using for internet so I don't get bumped off. I turn on Karma and used another computer to connect to a network "test" wirelessly. It connects to the Jasager but in the status box it shows a date (which is wrong), MAC address, but no IP address. I check the DHCP leases on BackTrack and nothing has been added except my eth0 of 192.168.1.2 address.

When my second computer is connected to the Jasager, it says it has Limited Connectivity and has a 169.x.x.x IP address. So it wasn't asigned one.

Any insight would be great. I don' t know if it's an issue with using the 8.09 kamikaze with Jasager Firmware or if i need to install 7.09 like Darren's Tutorial. Or if I have to setup some sort of bridging or forwarding on the Fon itself?

Link to comment
Share on other sites

If you want the clients to get dhcp addresses and for them to show up in the Jasager interface you have to run the dhcp server on the fon. Running on on the laptop or any other machine on the network just won't work.

Link to comment
Share on other sites

If you want the clients to get dhcp addresses and for them to show up in the Jasager interface you have to run the dhcp server on the fon. Running on on the laptop or any other machine on the network just won't work.

Does your firmware turn on DHCP by default? Or is that something i need to do? I just followed Darren's Tutorial and use older kamikaze 7.09 and I have Jasager right now able to give out IP addresses. How do i accomplish this with updated kamikaze 8.09 like your firmware has? Still unable to get it to see my laptop as the source to the internet with 7.09.

--- Edit: I have it working now through the laptop, Just need to set my DNS correctly on the Fon (Don't know where to do that). But why doesn't it work like this when I try the firmware is my Q.

Link to comment
Share on other sites

My firmware doesn't do anything by default, that is by design.

The logic is is that if you want a service running then you should know what the service is, how it works, what its dangers are and why you are turning on. If things are on by default then you can end up running things you don't know and don't fully understand so can't correctly administer.

Most things that run on 7.09 should work ok on 8.09 and 8.09.X.

The setup you need to achieve is to have the Fon giving out IP addresses, to do this use the dhcp command that is mentioned in quite a few of the other threads. When you do that the fons arp table will be populated which is what Jasager uses to populate the IP list.

Link to comment
Share on other sites

So your clients associate but then can't get an IP through dhcp, is that right?

What happens if you give the client a static IP in the same subnet, can it then ping the AP and beyond?

Ok, got the SSH issue resolved. Turns out it was a basic thing i was in /root dir instead of /

So say I wanted the Fon to assign client IP's and to use my laptop as an internet source. I can setup the forwarding on the laptop no problem. My issue is with what I have to configure with the Fon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...