Jump to content

OpenWRT on a D-Link DIR-615


Kerberos
 Share

Recommended Posts

I just bought a D-Link DIR-615 router and was pleasantly surprised to see that OpenWRT apparently supports it [Supported Hardware -> D-Link]. However I am as of yet unable to figure out exactly how to get it on the router.

There's only a single .bin file under in /kamikaze/8.09.1/ar71xx/ (which from what I've read is where I should be looking). I tried uploading it to the router via the stock firmware's upload page in the web interface, but it says it isn't a valid firmware file or isn't meant for the device. I don't have a JTAG or any experience with using one so I'm REALLY hoping I can do this from the web interface and that I'm just missing something else.

I haven't tried compiling the firmware myself yet, but that's next on the list. I have a bad feeling that it won't work though. My luck with compiling things from source hasn't been that great lately :(. Does anyone see something I'm doing wrong? Anybody with some OpenWRT experience, can you point me in the right direction? I don't have a problem with the stock firmware. Compared to the router I've been running for the last ~5 years this new one is amazing, stock firmware and all. But I've always wanted a router with OpenWRT (or some other form of function-rich, open firmware) on it. Any ideas?

Link to comment
Share on other sites

You might have more luck with DD-WRT.

Thanks for the quick response :D. I was considering DD-WRT but I thought it wasn't free. I took a look and apparently it is (and looks fairly nice as well). Unfortunately, the DIR-615 is listed as WIP and no download is available (as far as I can find) for either it or the two TrentNet routers that share similar hardware. Am I missing something? :(

Link to comment
Share on other sites

It says "Working Kamikaze trunk", so if I have my terminology right, you would need to checkout the source from their repository and build it yourself.

Yeah that's what I figured. I'm building it right now. It says "working Kamikaze trunk 2009-01-15", which is january, so I figured that by now it would be working in the latest release. But I guess that isn't necessarily true. If this compiles nicely, we'll see if it installs :D.

EDIT: Nope, nothing. Took like 4 hours to compile and it still won't take it. Any ideas?

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 8 months later...

I know this is an old topic but I see no resolution so I will submit one.

I have been having this same issue. The solution is hold the reset button for about 45 sec. The power light will turn orange and start to flash. Set the ip of your machine in the range of 192.168.0.2-254. Open your browser(chrome and IE did not work I had to use firefox) and point it to 192.168.0.1 and upload your firmware. Enjoy

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...