Jump to content

Backtrack USB Failure


systemd0wn
 Share

Recommended Posts

I have a recently purchased USB thumb drive (SanDisk Cruzer 4GB) I have only used it a few times and decided it would be best served as a bootable persistent BackTrack 4 drive.

Well after running through a incredibly helpful guide I had the necessary partitions, grub, and file systems, everything I needed. HOWEVER, when I boot that usb drive it's hit or miss. The second boot got the OS loaded but when it came time to check to see if I could write a file to the FS (to be sure persistence was working) BackTrack came back with an error. I couldn't put my finger on it until I saw the thumb drive light was off. WTF? SO I rebooted, and while it was trying to load the OS i get a stream of USB errors (I/O if i recall).

My question to you is could this be a software issue (drivers for usb controller) or am I thinking to hard and it's something physical? (ie: bad usb drive or bad physical connection) I have noticed a bit of play when i connect it to the computer (ie: it wiggles back and forth a bit) but then I tried another usb drive and it's the same way. Perhaps I just never noticed this before because it wasn't an issue. I haven't used the drive enough to really be certain either way. Anyway experience issues like this?

thanks.

Link to comment
Share on other sites

Sounds like your usb reader might be bad or damaged, like ESD damage or something. If it gets the I/O errors on multiple thumb drives, then chances are its not the thumb drives.

Check yoru BIOS to make sure you have something like USB 2.0 enabled/disabled, or could even try disabling 2.0 support and fall back to prior revisions but sounds more hardware related.

You could also try booting a different machine off the BT thumbdrive to rule it out as the problem.

Link to comment
Share on other sites

I'm using a Dell Mini 12 (inspiron 1210), Bios: Phoenix SecureCore Version A02.

I purchased another USB drive so I will probably give that a try tomorrow if I'm not to busy (Security+ exam on Friday).

digip, good ideas. Unfortunately my other laptop is a bit dated so I can't boot of of USB. I'll steal a buddies or something. You also made me realize I hadn't tried the other side of the motherboard so thats the first thing i'll do.

Wow, kinda made me realize i didn't fully troubleshoot this before posting. Then again it was nice to have some ideas waiting for me while i was sitting on the floor of best buys isle searching FCC IDs on my iPhone. Ugh, it's such a pain to find the proper chipset...

Thanks.

edit: i also wanted to mention that even though I have changed my xorg.conf each time i boot off the drive and 'startx' it says no display available. then of course i have to manually reconfigure xorg and boot. Anyone else using a persistent usb drive?

Link to comment
Share on other sites

First off, thanks for everyones help thus far.

I'm still having issues with the xorg.conf being re-written every time i boot.

So... For instance.

1) boot thumb drive.

2) type 'startx'

3) fail

4) manually config xorg.conf and save

5) startx

6) x starts fine.

At this point i can double check xorg.conf and the changes i applied in step 4 are still there.

HOWEVER, if i reboot I have to go through the same steps i mentioned above... When I look in the '/etc/X11/' folder I see a ton of 'xorg.conf' files but they all have a date and time stamp at the end of the file name.

Ugh. It gets old editing the xorg.conf every time i want to boot backtrack. Anyone have ideas?

Link to comment
Share on other sites

Try "fixvesa" before "startx" and see if that helps. You might have to do it each time though. Doesn't sound like your drive is doing persistenet changes, and is only running in live mode.

Link to comment
Share on other sites

I think maybe you have a writable share, swap or home folders, but not total persistence mode or it would keep yoru changes to xorg.conf

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...