Jump to content

Noob Question: Backtrack networking and virtualbox


cw360
 Share

Recommended Posts

Yes I am new at this and this is probably a really simple question but its driving me nuts.

I am running Virtual box on a netbook (Window 7). I have installed Backtrack 4. It seems like BT4 is not seeing the built in network adapters, but because of my noobness I may be mistaken. At any rate, my BT VM is a deaf and mute boring lump. Please Help.

In the virtual box setting I have tried both nat and bridged (although again I may be doing something wrong).

network_settings.jpg

Can someone give me some guidance?

Link to comment
Share on other sites

While the host's network card is wifi, the guest sees it as a wired ethernet card (as with all virtualisation networking, the virtualised OS doesn't see exactly what's in the outside world most of the time, just that there is some kind of network).

The way to do it properly is to hook up a wireless card/stick via USB and attach it to the VM that way, then the guest OS can see the wifi card as what it is, not what it's told it is. YMMV with VirtualBox's USB support though, it's very tricky to make it work properly... while I am very much a VirtualBox fan, VMWare Player has much better USB support, and can now create new VMs, should be the the job.

Link to comment
Share on other sites

I always set the adapter type to "Intel PRO/1000 MT Desktop (8254OEM)" and have it set to "Bridged Adapter". It bridges with my wireless card flawlessly and the guest OS has a fully functioning wired connection (on eth0). As for what to try to get it working, A agree that you should try different adapter types. I think I've had to use one of the PCnet ones before on a different computer because the Intel one wouldn't work for some reason. I don't think I've ever had to change to NAT or any of the other options for "Attached to". Bridged Adapter should be fine.

If that doesn't work, then I'm not sure. It's always sort of just...worked for me. Sorry, I guess that's not much help :(.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...