Jump to content

Spoofed SSID not being broadcast??


Recommended Posts

Hello all,

I'm working on getting Jasager up and running on a Fon router to use it for a demo in my master's information security project. I have everything installed and it seems to be functioning. However, the laptops I have tested with only connect to the Jasager spoofed SSID when I have the option to connect to SSIDs that are not broadcasting enabled. Is this normal behavior or is there a setting the will change that behavior?

Thanks in advance guys

Link to comment
Share on other sites

It will work either way but possibly not as you are expecting.

Jasager sits on the Karma madwifi patches, what they do is accept probe requests for any ESSID, not just the one they know about. They don't send out beacons.

So, to connect, your target has to be probing for a network, this can be setup either by connecting to an AP then setting the network as auto-connect, or creating a new one and telling it that it doesn't broadcast.

Link to comment
Share on other sites

It will work either way but possibly not as you are expecting.

Jasager sits on the Karma madwifi patches, what they do is accept probe requests for any ESSID, not just the one they know about. They don't send out beacons.

So, to connect, your target has to be probing for a network, this can be setup either by connecting to an AP then setting the network as auto-connect, or creating a new one and telling it that it doesn't broadcast.

I kept testing and I couldn't get my Mac (10.6) or XP machine to connect to the Jasager'd FON using my home network's SSID. Even though they both automatically connect when in range. I made sure to power off my real router to make sure that Jasager would be the only one near by that it would be able to auto-connect to. I did a bit of digging and I found this:

http://www.home-network-help.com/wireless-client-update.html

According to that KB update it seems that, at least in windows, it doesn't send out probes for networks by default anymore. ie it will only try to connect to SSIDs that are being broadcast that it matches up with. Could this be the reason why? It seems it is but I don't want to assume since it was not mentioned anywhere in any of the tutorials, etc

Link to comment
Share on other sites

MS did a patch to disable auto-connect but it was optional as it would break too many systems if pushed out.

Just set one of them to auto-connect and see if it works, if not then something is wrong on the Jasager.

You have enabled Karma haven't you?

Did you install from the firmware or by hand?

Link to comment
Share on other sites

MS did a patch to disable auto-connect but it was optional as it would break too many systems if pushed out.

Just set one of them to auto-connect and see if it works, if not then something is wrong on the Jasager.

You have enabled Karma haven't you?

Did you install from the firmware or by hand?

Sorry I didn't respond earlier but I didn't get an email notification of your reply. I guess my systems I was testing with had the patch installed. It works only when I enable the option connect when not broadcasting. It all works, I guess for my demo I'll have to show it on a system that either doesn't have the patch installed or show the option to force connections when the SSID is not being broadcast.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...