Jump to content

Upside-Down-Ternet


Netshroud
 Share

Recommended Posts

the issue you may be seeing is that either

a.) the ports are not forwarded in your router

or

b.) Your ISP is blocking the commonly used ports for Telnet, HTTP, etc

When I ran a FTP server on my home connection I could not use 21 so I used a ridiculously high number like 9001.

I do not recommend you set DMZ for that computer's IP unless you just want to test it momentarily to see if your ISP blocks the port.

Link to comment
Share on other sites

I followed the HowTo on the Ubuntu Site, but I can't get the Upside-Down-Ternet working. I can telnet to the HTTP server locally. Squid and Apache are running, but I cannot connect to either Squid or Apache remotely.

If 'local' means at the terminal, it's probably because the default squid config will only accept connections from localhost. I forget the details of how to change this... but it's some where.

Link to comment
Share on other sites

  • 1 year later...

I have completed the How-To at https://help.ubuntu.com/community/Upside-Down-TernetHowTo on upside-down-trenet and can't get it to work.

Squid starts but will not serve pages. A port scan shows no squid port at 3128, Logs show The url_rewriter helpers are crashing too rapidly, need help!

If I remove line url_rewrite_program /usr/local/bin/flip.pl squid works fine and a port scan shows its running on 3128

I'm using Ubuntu and the same version of squid and apachie2 as the how-to

Any Ideals? has any one got this working?

Link to comment
Share on other sites

Out of curiosity, how did you set up squid?

As a transparent proxy, or as web cache proxy

If Squid is configured as a transparent proxy, you are not required to enter any proxy settings on your browser. However if you configured squid as a web cache, you will need to specify the port and the ip address of squid server, within your browser proxy settings.

If you wouldn't mind, are you able to provide a copy of your squid config file?

Link to comment
Share on other sites

Ive tried both transparent and web cache currently I have it working as a caching proxy and have the proxy info configured in the browser.

I fingered out the issue. It was the flip.pl script It simply does not work with the second elsif block. I found another version at http://compexperience.blogspot.com/2010/04/upside-down-images-prank.html

This one works for me! Thanks for your help

#!/usr/bin/perl

$|=1;

$count = 0;

$pid = $$;

while (<>) {

chomp $_;

if ($_ =~ /(.*\.jpg)/i) {

$url = $1;

system("/usr/bin/wget", "-q", "-O","/var/www/images/$pid-$count.jpg", "$url");

system("/usr/bin/mogrify", "-flip","/var/www/images/$pid-$count.jpg");

print "http://127.0.0.1/images/$pid-$count.jpg\n";

}

elsif ($_ =~ /(.*\.gif)/i) {

$url = $1;

system("/usr/bin/wget", "-q", "-O","/var/www/images/$pid-$count.gif", "$url");

system("/usr/bin/mogrify", "-flip","/var/www/images/$pid-$count.gif");

print "http://127.0.0.1/images/$pid-$count.gif\n";

}

else {

print "$_\n";;

}

$count++;

}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...