Jump to content

Help messed up grub


timmy
 Share

Recommended Posts

Well i was being a idot and i tried to install backtrack via this methold

http://forums.remote-exploit.org/backtrack...e-dvd-disk.html

My computer wouldn't boot up after i installed bt4 via unetbootin on my windows xp partition

Well in this tutorial i dont think that they had another partition running ubunto netbook remix

right now my netbook is getting grub error 17. Im a linux version and i havent got around to messing around with grub yet because of all my various projects. What i think is happening is that grub on my xp partion with bt4 files is confused with my UNR partition please help.

I think a possible solution is to boot via usb and delete some shit but i dont really know i also don't really want to install windows on my netbook seeing as i do not own a external DVD reader

thnx :lol:

Link to comment
Share on other sites

What happened was you never updated the grub on the backtrack partition. Whenever you install a O/S and try doing dual boots if always have to update the grub. You're best bet will be to boot into a live backtrack and run the following:

- fdisk /dev/sda

- Once you're in disk, enter e[x]tra/expert mode, [f]ix the partition order, then [w]rite the table and exit.

- You can verify that the partition table was indeed fixed by issuing an fdisk -l

Now if this doesn't work then again boot into a live backtrack and run the following:

cd /

mount -t ext3 /dev/sda1 /mnt

mount -t proc proc /mnt/proc

mount -t sysfs sys /mnt/sys

mount -o bind /dev /mnt/dev

chroot /mnt /bin/bash

Edit the: <vi or nano> /boot/grub/menu.lst

then type:

cd /

umount -a

exit

cd /

umount -a

reboot

IF ALL ELSE FAILS.... again boot into the live cd and type:

sudo grub

find /boot/grub/stage1

<locate your boot partition>

<Replace the (hd0,0) by your boot partition number>

setup (hd0)

quit

Hope this helps.

Link to comment
Share on other sites

Sorry for the double post

I tried the last method but it says that /boot/grub/stage1 does not exist

i can clearly see the stage1 for my xp partition

i just dont know but im positive that file does exist

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...