Jump to content

Where is Jasager & OpenWRT?


Recommended Posts

Hi all,

Noobish, yes, that's me. Got my commisioned Pineapple, set it up as shown here I got to the stage where I set up the DHCP to 192.168.0.250 & netmask to 225.225.225.0 I saved it, and turned off my Pineapple. Connected to my home network, and powered back on my little Pineapple.

That's as far as I got, I did it all as the tutorial said (I even renamed my network cards to be the same as the tutorial :rolleyes: ) but still, I can't find it.

I plugged the Pineapple into my modem and it works fine, but still, I can't find the Jasager or openWRT pages. Please help. I just got my Pineapple, and I'm desperate to get it going.

Thanks in Advance.

Link to comment
Share on other sites

I am actually in the same situation. I followed the steps up until there with the same issue. I tried a couple different laptops and wireless cards, without being able to connect to it anymore. Most see it for a second or two, then lose it. If I connect with by ethernet, the IPs I've tried don't work anymore.

I did have some issues before that step with my laptop seeing it some of the time.

Link to comment
Share on other sites

Sorry, my Pineapple is flashed (by Darren) with all the stuff it needs, and I was able to pull up the OpenWRT config page where I went to the "Network Configoration" page and set the DHCP to bridged as per the tutorial here and hit save, since doing that I can no longer access the OpenWRT page nor can I acess the Jasager page, (even with WiFi turned off, so I am only on LAN and even when connected wirelessly to my Pineapple)

Any ideas? Is this what you were having problems with corn1699?

Link to comment
Share on other sites

Turns out it comes up fine in IE but not Firefox.... Is it possible to do this in a Linux distro? I primarily use Ubuntu, and Windows for iTunes and one or two other things, but is there software out there to do this in Linux?

Link to comment
Share on other sites

Does FF in windows work at the same time IE does?

Sounds like a networking issue. Check your IP addresses/subnet masks.

All Jasager stuff works with linux as a client as I don't run any windows systems.

Link to comment
Share on other sites

I'll have to try IE too and see if that works for me. I bought one on the Hak5 site too, and everything was loaded when I got mine. I wasn't able to connect to it with wireless after I switched that. I was using an internal Intel card and external Linksys USB adapter instead of the cards used in the instructions, so I thought there may be something with that too.

Link to comment
Share on other sites

If I connect using ethernet, it can't see the 192.168.1.1 IP anymore. The wireless network is still coming up, but when I try to connect to it, Windows is telling me that it can't receive a response. Ubuntu gives up trying to connect to it.

Link to comment
Share on other sites

I can't connect with 192.168.0.250 either. I tried switching the role of my cards, connecting wired again, and then tried that with my eeepc. I tried seeing what was being transferred when I connected to it with wireshark, but I couldn't get anything on any of those IPs either. I am fairly new to networking. I have used wireshark and nmap a few times, but I couldn't seem to get anything I could find useful from them for this problem. Is there some way to find it? I don't think it is bricked because it seems to still be broadcasting, and I just changed it as described in the internet connection sharing instructions. Does anyone have any ideas?

Link to comment
Share on other sites

If you have asked the Fon to get its IP address through DHCP, are you running a DHCP server on the network somewhere so it can get an IP address? If not then it won't get an IP and you won't be able to connect to it.

Link to comment
Share on other sites

I belive the ICS (internet connection sharing) built into Windows runs its own DHCP server, so that shouldn't be the issue. I hate using Windows and would prefer to be using Ubuntu or Backtrack, can some one create a new thread on how to do this?

Link to comment
Share on other sites

If you have asked the Fon to get its IP address through DHCP, are you running a DHCP server on the network somewhere so it can get an IP address? If not then it won't get an IP and you won't be able to connect to it.

I think my wireless router is handling my DHCP. Do I need to connect the Fon to that with a cable to have it get an IP address then?

Link to comment
Share on other sites

I saw that tutorial, but I took it as connecting to a wireless network, then connecting to the Fon with another card and routing all the traffic connected to the Fon though your laptop. I don't even see ethernet mentioned on there...

Link to comment
Share on other sites

I think my wireless router is handling my DHCP. Do I need to connect the Fon to that with a cable to have it get an IP address then?

You need to have the Fon connected to the network in some way for it to get an IP, if not it just sits around shouting out "give me an IP". If you are expecting it to connect over wifi and get an IP are you sure you set it up correctly to make the connection?

There are two ways to give it an IP, either run a DHCP server on the machine you are connecting the Fon to or connect the fon directly to your wired network switch/router and have that give out IPs. I personally prefer to have the Fon on a static IP, that way it doesn't matter what I plug it into I always know where it is and don't have to mess around setting up a DHCP server.

Link to comment
Share on other sites

I didn't see the part about DHCP in that tutorial, so I wasn't really sure how it ended up working with the Fon. I'm guessing in that example it had something to do with the internet connection sharing options. With my Linksys adapter I only had about half the settings as were shown in the tutorial, and I don't think I had DHCP as an option.

Link to comment
Share on other sites

  • 4 months later...

I'm having the same problem with my Jasager, After i initially set it up i could connect to the Karma and OpenWRT web interfaces easily off of the Ip 192.168.1.1. Then I followed this thread on the hak5 forums and ever since then I cant access either the OpenWRT webif or the Karma webif. I can connect via the wireless connection and Ethernet but cannot access either webif

Link to comment
Share on other sites

Hey Digininja this was my question I had for you and I re flashed my fon so should just change the ip address to static instead of dhcp and just assign it an ip then it should work also how do I copy the http conf file fron the fon router and then replace it with http file in the etc par of the router thanks.

Link to comment
Share on other sites

Sounds like you both set your fon to get its IP through dhcp then didn't run a dhcp server on the machine that it was connected to. That will lock you out.

Razehell, not sure of your question, what file do you want to copy, where to, and why?

Link to comment
Share on other sites

well on the walk through to setting up jasager in step 17 you need to Copy the httpd.conf from the karma/etc folder to the root/etc folder and overwrite the existing one it will now prompt with UN/PWD for both jasager and webif. im not sure what the command to do this is or do i just drag and drop from within the webif interface I think I explained it right.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...