Jump to content

WebIF Install onto Fon2201 w/Jasager v2


Recommended Posts

Hey guys, started putting together my own pineapple awhile ago and got distracted by life... I'm back at it.

I flashed the Fon2201 properly with the Jasager v2 firmware. Have access to the Jasager webif at 192.168.1.1:1471.

However, to set up ICS properly (from what I can tell) I need access to the OpenWRT webif as well, and if I recall correctly Robin Wood(digininja) told me I had to install that seperately. Here is what I did and my results.

SCPd over haserl_0.8.0-2_mips.ipk AND webif_0.3-10_mips.ipk to /tmp/

opkg install both of them from root

Doesn't work so I cd to /tmp/

opkg install works. But here is the output:

root@OpenWrt:/tmp# opkg install haserl_0.8.0-2_mips.ipk
Installing haserl (0.8.0-2) to root...
Configuring haserl
root@OpenWrt:/tmp# opkg install webif_0.3-10_mips.ipk
Installing webif (0.3-10) to root...
Configuring webif
Linux OpenWrt 2.6.26.5 #20 Sun May 3 13:07:35 BST 2009 mips unknown
Linux OpenWrt 2.6.26.5 #20 Sun May 3 13:07:35 BST 2009 mips unknown
system type             : Atheros AR2315
cat: can't open '/etc/ipkg.conf': No such file or directory
Linux OpenWrt 2.6.26.5 #20 Sun May 3 13:07:35 BST 2009 mips unknown
//usr/lib/opkg/info/webif.postinst: line 228: ipkg: not found
/usr/lib/webif/webif-mklanglist.sh: line 5: ipkg: not found
/usr/lib/webif/webif-mkthemelist.sh: line 4: ipkg: not found
Committing new firmware id ...
Device: La Fonera (ACCTON MR3201A)
Committing new device id ...
SUCCESS! Webif^2 installation appears OK. Welcome to X-Wrt!
You may need to do a hard REFRESH to clear old CSS style from your browser.
Reinitializing httpd ...
root@OpenWrt:/tmp#

eeeeeeeewww, got a lot of ipkg not founds. But it did say SUCCESS so let's try it out.

I go on over to 192.168.1.1 and it shows me the login, and I login properly. Get punted to the pure black screen that says it is redirecting to the main page (attached a jpg with it in case I didn't describe it properly to prevent confusion).

post-11027-1245563515_thumb.jpg

Then it redirects me to a purely blank page.

Cleared my cache and everything (not sure exactly what it means by a hard REFRESH) and also reset the router. Same results.

Any ideas peoples? Anybody run into the same thing?

Link to comment
Share on other sites

Also have a secondary question:

Not sure how this changed, as I never had a problem with it before: flashing, fiddling around, reflashing.

Now that I've come back to this project I decided to start from scratch and possibly try the Piranha 2 alpha4 firmware... However I keep getting this:

"Telnet for Redboot not enabled."

whenever I use FonFlash or Freifunk.

I can SSH into the FON.

How do I disable SSH and reenable telnet instead?

Link to comment
Share on other sites

I ran into this myself, but then I remembered during one for the tutorials.. you had to copy the

original WebIf to another directory before installing Karma.

I think WebIf overwrites some of the Karma files during the install.

I installed the Piranha2 firmware it everything works great..

I have it installed on a 2100, with SD card installed.

I used the windows client to flash the firmware.

I need to figure out how to setup the firewall info now.

I can run karma, and Clients associate with it, but they have no internet access.

I'm really looking forward to getting ahold of a new FON 2, since they have Hamster/Ferret compiled for linux/mac

now. would be awsome to attach my aircard for internet access, and run everything on the little fon.

No need for another device, ( just browse to the Fon unit to access Hamster )

The unit can be totally wireless that way!

Sorry got a little off topic.

What client are you using to flash your fon? windows or linux?

and what files are you flashing?

Link to comment
Share on other sites

I used the windows client to flash the firmware.

......

What client are you using to flash your fon? windows or linux?

and what files are you flashing?

Using windows. Tried FonFlash and Freifunk's EasyFlash.

Tried reflashing with default FON firmware from the fon site (Loader, Image, image2) using FonFlash

Tried reflashing with Jasager v2, Piranha 2 alpha4 as well using both flashing utilties (FonFlash and Freifunk's EasyFlash).

Giving me the "Telnet for Redboot not enabled." error and refusing to flash, on all firmwares with both utilities.

I know SSH is enabled because I'm using it. But when you initially flash you have access to telnet into redboot, but then you enable ssh which causes telnet to be disabled. How do I disable SSH so that telnet is reenabled?

Not sure why it is suddenly giving me this error as I have flashed multiple times and never had to disable SSH and reenable telnet. Just my guess at a solution is all.

Link to comment
Share on other sites

I don't know why this is happening but to help you I'll point out that you have got two things sort of mixed up.

The redboot stuff is like the BIOS you get on a normal PC. That starts up and listens on an IP for a short period then transfers command to whatever OS you have installed.

You normally access redboot through either telnet port 9000 or through a cable. Having ssh running on the OS once it has booted has nothing to do with redboot and telnet.

My guess is that while doing some flashing you have somehow altered the IP address redboot is listening on. Get a ping going for 192.168.1.1 and 192.168.1.254 then power on the fon, see if you get any responses within the first few seconds, after that it is likely to be the OS replying. If you get a hit you've found your IP address, if no then try any others you may have set it to. If all that fails you may have to use a cable to access redboot.

Link to comment
Share on other sites

okay, unable to get a ping response from either of those.. I know it isn't bricked cause I can still access the Jasager webif (Just not the x-wrt webif), I just can't reflash it at all it seems, until I build myself a data cable.

Any ideas about why my cgi-bin/webif/info.sh is showing up as a blank screen?

Link to comment
Share on other sites

Something will have gone wrong during the install, hence the error messages. It may say ok but really it failed.

That's what I don't understand. ... Those errors don't make sense. Those files are THERE. Ugh.

Anyway, these are the only errors the webif opkg install throws (Besides mips unknown, which I'm pretty sure shows up in the step-by-step wiki too, so it shouldn't be a problem):

cat: can't open '/etc/ipkg.conf': No such file or directory
.....
//usr/lib/opkg/info/webif.postinst: line 228: ipkg: not found
/usr/lib/webif/webif-mklanglist.sh: line 5: ipkg: not found
/usr/lib/webif/webif-mkthemelist.sh: line 4: ipkg: not found

So I only need ipkg.conf, webif.postinst, webif-mklanglist.sh, webif-mkthemelist.sh.

root@OpenWrt:/# ls /etc/ipkg.conf
/etc/ipkg.conf

root@OpenWrt:/# ls //usr/lib/opkg/info/webif.postinst
//usr/lib/opkg/info/webif.postinst

root@OpenWrt:/# ls /usr/lib/webif/webif-*
/usr/lib/webif/webif-mklanglist.sh   /usr/lib/webif/webif-mkthemelist.sh

root@OpenWrt:/#

So all the files are there... I don't understand what is going on...

So I don't understand why it isn't working. All the files that it throws errors over do exist, and are where they say they are.

Link to comment
Share on other sites

Okay okay okay!

Got the X-WRT webif UP and RUNNING!

Pretty graphs and everything!

I issued an "opkg -recursive remove haserl" in order to completely uninstall haserl and the current webif

I then found more up to date packages online than the ones that were linked to in the step-by-step wiki.

The ones in the package are haserl_0.8.0-2_mips.ipk, and webif_0.3-10_mips.ipk

The packages I downloaded:

haserl_0.9.24-1_mips.ipk

http://downloads.x-wrt.org/xwrt/kamikaze/8...9.24-1_mips.ipk

webif_0.3-4709_mips.ipk

http://downloads.x-wrt.org/xwrt/kamikaze/8...3-4709_mips.ipk

Downloaded those, and opkg installed.

Threw one error:

Installing webif (0.3-4709) to root...
Configuring webif
Collected errors:
 * Could not obtain administrative lock
Committing new firmware id ...
Device: Generic
Committing new device id ...
SUCCESS! Webif^2 installation appears OK. Welcome to X-Wrt!

Was concerned with that, but went ahead and popped on over to 192.168.1.1:1471 to check out the Jasager to make sure that still worked (Didn't want to break the one webif that was working for me, hah) and then hopped over to 192.168.1.1 to check out the X-WRT webif. Oh MY GOODNESS!

It worked! But it was minimal and didn't look very pretty, so I downloaded webif-theme-xwrt_0.3-4709_all.ipk, which is located here: http://downloads.x-wrt.org/xwrt/kamikaze/8....3-4709_all.ipk

Installed that, and voila! nice and pretty and have access to both interfaces!

HOWEVER:

I did all this through ethernet instead of wifi. Rebooted after that. Still worked via LAN, but I cannot access the pages via WiFi.

Any idea how I correct that little problem? (VERY little problem when compared to the hassle I've been given so far, haha)

Link to comment
Share on other sites

A lesson to everyone here, always go for the latest version wherever possible. The ones in the wiki are probably for OpenWRT 7.09 not 8.09 which is what would be causing the problems.

Link to comment
Share on other sites

I dont really see why this is so special...

If there are XP drivers for a certain device youll find them online, dont you?

Besides, there seem to be no .inf files in this driver.cab directory so windows finds no drivers at all.

Or am I doing anything wrong?

Link to comment
Share on other sites

  • 2 months later...

Whenever possible try to work with the package management system on whatever system you're working on not against it. You might even go so far as to add the xwrt repo to the /etc/opkg.conf (i think that's where those live). that way you can just use "opkg update && opkg install <package name>" to get what you want and it won't cause crazy errors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...