Jump to content

Vista Wireless Problem


davil
 Share

Recommended Posts

Yeah I know vista sucks!!! :-D

I'm having a really annoying problem with a new PC I installed for a small business.

Basically, it's a wifi connection that keeps dropping (Vista). I've been doing ping tests to the DSL router and to a local university out on the interweb and they both time out when the drop happens.

It's an Acer PC (Vista Home Premium, Phenom Quad core >2GHz, 2GB, 320GB HDD and I can't remember the spec in any more detail at the moment).

And the wireless adapter is a Belkin F507050, Version =[v4003 uk]. This is a USB Wireless G adapter

It's Atheros based if that's of any help.

It's a hotel and the connection is unsecured as they don't want to worry about giving out WEP / WPA keys etc.

Please don't give me a lecture about security / sniffing / whatever - I've tried to tell them but they're the client and whatever they say goes.

I've setup a static IP address on the adapter (192.168.1.10) with a standard class C subnet (255.255.255.0) - just like the rest of the network. The default gateway (ADSL router) is 192.168.1.1

And for DNS, it's using OPENDNS. Any laptops etc that I have tried on the wireless get 100% uptime so I'm pretty sure it's not the Access points or the DSL router or the ISP.

I tried disabling IPv6, BOTH Link-Layer Topology Discovery Protocols,even QoS (clutching at straws)

None of these things made a difference.

The 4 Access points are TP-LINK TL-WA501G

http://www.tp-link.com/products/product_des.asp?id=36

They all have the same SSID + Channel and seem to work fine with other machines.

I don't know if this is any use, but I did a 'netsh wlan show interfaces'

Name                 : Wireless Network Connection
   Description          : Belkin Wireless G USB Network Adapter
   GUID                 : 3fc5d979-deleted for security reasons
   Physical Address     : 00:1c:df:deleted for security reasons
   State                : connected
   SSID                 : deleted for security reasons
   BSSID                : 00:23:cd:deleted for security reasons
   Network Type         : Infrastructure
   Radio Type           : 802.11g
   Authentication       : Open
   Cipher               : None
   Connection Mode      : Profile
   Channel              : 11 (I have also tried 6)
   Receive Rate (Mbps)  : 54
   Transmit Rate (Mbps) : 54
   Signal               : 80%
   Profile              : deleted for security reasons

I'm not in that building at the moment but I did do a 'netsh wlan show drivers' and forgot to email it to myself.

I did however notice that the driver was in C:\windows\oem so I think it's using Microsoft WHQL drivers or whatever u call them.

When installing, I did put the disk in but I think there were only XP drivers on that disk anyway so when I hit automatic install,

vista did whatever (it doesn't tell you) and it looked to install fine. Had a look on belkin.com and couldn't find vista drivers for this bit of kit.

But it's hardly a driver issue ? is it ?

Anyhow,

Maybe somebody has had a similar problem.

Any help is very much appreciated.

P.S. If it was me, I'd just buy XP Pro on ebay (as I did for my own machine)

Link to comment
Share on other sites

Have you tested any other machines from the same identical location as the Vista machine? I know you said other machines work fine, but from where. Sounds like something is interfering with the signal if you are connected but get dropped. Might be weak power of the device in the machine you are having problems with. Could be a number of things, like other radio interference. You can try setting the speed slower. Slower speeds can reach further distances. Maybe you are just on the cusp of too far away for that card(don't know your setup or distance, obstructions in the way so I am just guessing for things here). Does the router have G set as the only protocol, or does it share B and G. If its doing both B and G, cards set for G only will have issues and will also see slower speeds because the router has to negotiate for the slower protocol. Anytime a B user logs on to the router everyone with a G connection will have to renegotiate(if set to G only) and will most likely get dropped in the process. If the router is set to G only, then the only thing I can see is a distance/antenna/power or obstruction issue. I don't know that it is strictly a Vista issue in this case.

If its a faulty driver, you can try windows update, or just go to the manufacturers site and see if there is a newer driver. Might be a known bug or a fix for the problem.

Link to comment
Share on other sites

if your card is version 4 its Zydas1211 chipset. atheros aquired zydas and renamed it ar5007UG. so i would first download the 5007ug drivers from atheros and install them to your adapter. you might also want to check the vista autotuning mode. you can disable it from the cmd line with

netsh interface tcp set global autotuninglevel=disabled

and renable it with

netsh interface tcp set global autotuninglevel=normal

restart your machine after you change the autotuning setting

Link to comment
Share on other sites

I'm pretty sure that you should have the routers set to the same SSID & encryption settings (even if that does mean 'none') but you should have them on different channels.

I think that you will find this is your problem. Set them to different channels, like 1, 6 and 11, set the fourth to one of those but use the one that it cant see, so if the fourth AP can see 1 and 6 but 11 is too far away, then set it to 11.

Here's a link that I found after typing this, I think it backs up what I'm saying: http://www.geekzone.co.nz/inquisitor/2996

Link to comment
Share on other sites

Extended service areas are common for wifi routers. You generally want an overlap range of about 10-15 percent so that users can roam and stay connected without connections dropping connections. Using the same ssid is fine, just put each router on its own channel. If the routers are too far apart and the device connecting tries to roam to the other router witht he same ssid, but it is just out of range, your connections will drop more. Having themm too close together can also be a problem as you don't maximize your cell coverage and people would overload one device since they would pick the one that they see first with the fasest connection closest to them, and they would all be sharing the bandwidth on that one router, and again, if its doing B+G autonegotiations, someone set strictly to G will get disconnected anytime an 802.11b user logs on. No one should really be using b these days though, as it just kills the network speeds and causes problems with users who have their card set just to g.

Another thing you can do is look into your wireless adapters settings. In the screen where you would update the drivers for it and roll them back, there is a tab advanced. You can tweak settings in there to modify to yoru needs, like set to b+g or G only, aggressive roaming and so on. Depedning on the card, you might have better results changing some of these and just test trial and error what works best for the card and your network.

Link to comment
Share on other sites

Thanks for all your help guys. However it still isn't working for me.

I've changed the channels on all 4 routers. 1,6,11 and 1 again

The two with channel 1 are opposite ends of the building and their signal areas don't overlap.

I've been doing some testing on the vista machine and it mostly seems to drop when I do something on the LAN, web and email is fine.... how I've been testing it is to go to \\nameofserver - which is a PC on the LAN with a printer attached, it's ok when I 'run' to that location. but when I click open or connect on the printer it usually drops then. a simple disconnect and reconnect works fine but it shouldn't really go down because of this ?

I've turned off the windows 'firewall' and for some strange reason now rather than it going down altogether when I click on the printer, the continuous ping test I'm running to an internet server only times out once.

So I thought I had it sorted but it still seems to be going when I'm not around and I'm pretty sure it's not something the user is doing.

Could it be disconnecting after a few minutes of non-activity ??

Link to comment
Share on other sites

What version of Vista is it? 32 or 64-bit? I've came across many many issues recently with Vista 64-bit I'm talking brand new pc's right out of the box having packet loss. Doesn't seem to matter desktop, lap-top, wired or wireless. I kinda just scanned through this thread, but try a ping test in safe mode with networking. I've had instances where connectivity was fine in safe mode and instances where they didn't.

Also as digip mentioned if you have another lap-top try putting it in the same area or a friends and see what happens. If you can't test with another pc in this same location a liveCD would be a great tool to test with as well.

Link to comment
Share on other sites

Hi. Thanks for that. Pretty sure it's 32-bit version but I'll check. Also I will test a liveCD ( great idea by the way)

also I've tested my own laptop in that area more than once but I will re-test to see what's up. I just find it strange that it only goes when u do anything on LAN, and internet stuff is fine... but the next step is defo Live CD. only problem is that the adapter is USB but fedora / ubuntu or something will probly pick it up fine. I'll give it a go. Thanks again.

Link to comment
Share on other sites

Hi. Thanks for that. Pretty sure it's 32-bit version but I'll check. Also I will test a liveCD ( great idea by the way)

also I've tested my own laptop in that area more than once but I will re-test to see what's up. I just find it strange that it only goes when u do anything on LAN, and internet stuff is fine... but the next step is defo Live CD. only problem is that the adapter is USB but fedora / ubuntu or something will probly pick it up fine. I'll give it a go. Thanks again.

I think there in lies some issues, might be the USB adapter, but also, what network is Vista trying to connect to locally?

Are these Windows workstations, server 2003 machines, xp machines, linux samba shares?

I had trouble connecting to a Vista machine from XP using file and printer sharing over the lan. I think that in this case, maybe it is a Vista issue for home networking, but if only for local lan issue, as you say the internet side works, something in Vista might not be configure properly for local shares. Also, the printer driver might not be the proper one for Vista, vs the XP machines, and that most definately could cause some issues, but more than likely, the output would print jumbled or incorrectly but still send data to the printer without disconnecting you.

You seem to be getting disconected when trying to print, so I would start by trouble shooting the printer drivers for Vista, make sure they are for signed Vista and not XP. Then work out possible configuration settings that may not be set properly on Vista for home networking or look to see if there is updates for home networking problems for Vista like peer to peer networking, and lastly, make sure the USB network adapter has the latest drivers for Vista. If there are only XP drivers for the adapter, then its a crap shoot as to when they will work, because there is no garuntee they will work 100% with Vista unless they are signed drivers for Vista. Check with the Network adapters site.

Link to comment
Share on other sites

You have a very valid point about the drivers alright. I took a look at that but wasn't too sure. since it does print perfectly now and again. However, I will get the vista drivers for the vista machine. All the other machines on the network are indeed XP Pro. I have a few things to try next time I make it into the building. I'll keep you posted asap

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...