Jump to content

Need help with the last mile


Recommended Posts

Hey everybody. First I just wanted to say that the info in this forum is awesome and I've been lurking all day, trying to get my pineapple up and running. The posts here have been invaluable in getting things going.

Having said that, I do need some help... I was able to flash my Fon (2100) to get openwrt and Jasager both installed on it. I'm able to access both interfaces through the web and everything appears to be working. However, when I access the Jasager interface, I do not see anybody listed in the connected clients. I live in an area with a TON of apartment buildings (I think I can see around 30 ssids right now), so there should be some traffic. On top of that, I've been trying to use a second laptop as my "Mark" but haven't actually gotten it to connect. As a matter of fact, my log hardly generates any entries at all. The only time I get them is if I switch to "whitelist" mode, I get a bunch of messages saying that all of these ssids around me are rejected because they are not on the whitelist. But if I switch to blacklist mode (with an empty list) I get no traffic at all. It's very frustrating.

I should also say that I was able to see all of this with a setup similar to what was shown on episode 4x12. I had Windows XP running, and my iPhone tethered via PdaNet. This connection was shared with my wired ethernet port which was connected to my Fon. If I connected to my Fon's wireless network, I was able to browse the web so I know that the connection bridging was working correctly. I just was not getting any clients to connect to Jasager.

One other problem I'm having might help shed light onto the situation. I tried just simplifying the setup and having the Fon only plugged into power (without all of the connection bridging nonsense). When I do this and connect to the wireless network, I get a self-assigned 169. address and so I'm unable to connect to the web interfaces at all to see what is going on.

I know, "wall of text crits you for 100,000. you die" =P Sorry for the long post, but if anybody can figure out what I'm doing incorrectly or if I'm completely misunderstanding something let me know. And thanks again for all of the information that you all have already posted!

Link to comment
Share on other sites

If you are getting the white list messages then it should all be working, all the patches are in place.

Having loads of other machines around isn't a guarantee of connections. Machines will connect to the strongest signal and if they are at home with their own networks then they won't move to yours.

Try ssh'ing to the fon and putting an ssid on ath0 and see if you can then connect to that.

Link to comment
Share on other sites

Thanks for the quick reply.

I used your advice from a different thread and ran the following commands:

wlanconfig ath0 create wlandev wifi0 wlanmode ap

iwpriv ath0 karma 1

iwconfig ath0 essid jasager channel 6

ifconfig ath0 10.1.1.1 up

I then took my iPhone over and tried to authenticate to the jasager network. Here is the output I got:

Jan 1 00:15:07 (none) user.warn kernel: KARMA: Node [00:21:e9:90:21:08] associating to ssid ["jasager"]

Jan 1 00:15:07 (none) daemon.info hostapd: ath0: STA 00:21:e9:90:21:08 IEEE 802.11: associated

Jan 1 00:15:10 (none) daemon.info hostapd: ath0: STA 00:21:e9:90:21:08 IEEE 802.11: deauthenticated due to local deauth request

Jan 1 00:15:10 (none) daemon.info hostapd: ath0: STA 00:21:e9:90:21:08 IEEE 802.11: disassociated

A second attempt later after a reboot gave me this output:

Jan 1 00:04:31 (none) user.warn kernel: KARMA: Node [00:21:e9:90:21:08] associating to ssid ["jasager"]

Jan 1 00:05:00 (none) user.warn kernel: KARMA: Node [00:21:e9:90:21:08] associating to ssid ["jasager"]

Jan 1 00:05:05 (none) user.warn kernel: KARMA: Node [00:21:e9:90:21:08] associating to ssid ["jasager"]

Jan 1 00:05:16 (none) user.warn kernel: KARMA: Node [00:21:e9:90:21:08] associating to ssid ["jasager"]

EDIT: Okay update. I set everything up like I described above where I shared my internet connection from my iPhone with my wired ethernet port. From there I was able to connect to the SSID that the Fon puts out on another machine and that seemed to work. I got a MAC address and "associating to SSID" messages in Jasager. I was even able to use ferret and hamster to do a bit of session jacking while I was messing around with it.

The one thing I cannot seem to get working though, is actually getting a machine to associate with the Fon instead of an intended access point. I've tried making a machine try to connect to access points that I know are not in range, but none of that traffic shows up at all in Jasager. As with before, if I switch it to "Whitelist" mode, I still get a bunch of "not found in whitelist so rejecting" messages, but if I add a network to the whitelist and try again, I get no action at all.

Link to comment
Share on other sites

I don't know what your problem is but it looks like Jasager is working fine. The fact that the client reassociates every few seconds implies that the client isn't happy with the AP for some reason so it drops the connection then probes, finds it again and then reconnects.

If you know kismet fire that up and sniff the traffic while all this is going on, see who is creating what traffic and who is creating the disassociation stuff. You would also see karma replying to the probe requests if it was working ok in black list mode.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...