Jump to content

How to make trojan


5465353535453435
 Share

Recommended Posts

digip don't you just love that, we have a guy in our course who is in the same sort of boat as you (Has been working at an ISP for 9 years and comp hardware prior for 10 all self taught, yet no certs) Its actually handy having people like this in class because they are quick to point out how little is actually used in the real world and how little you know without all that experience.

On the upside you won't have to worry about being one of those paper CCNA's, going by mates who working the industry there are plenty of them out there. I love the stories I get told like this one for example. I handed this new guy a MITRJ connector and he had no idea where to plug the damn thing in, fucking paper CCNA"s using packet tracer. =P

but meh I am not even at the paper CCNA level yet so I can't exactly talk. ^_^

MT-RJ? Fiber cable? I don't exactly work with the equipment(yet) but if someone hande dme the cable, it only fits in one type of jack. If the hardware had the port, I'm pretty sure I would figure that out pretty quick. If it snot RJ-45, Coax, Rj-LL, or DB-9 based, there aren't many options left. Fiber Optic's are about the last thing, unless you use old school stuff like at my work, where we have mega large bus and tag cables and still use some coax for some dumb terminals. Most stuff we use at work is now Fiber and Gigabit Ethernet.

The class I am taking has racks and racks of Cisco equipment, and we will have open labs to come in and work with all the hardware, so that is another reason I want the class vs brain dumps from a book. Im goign to get hands on in this class and that is what I really need. I can always read a book and spit out what I read, but like you said, if I never touch the hardware, I'm not going to be of much use to an employer. That is also why I can't wait to get the routers my co-worker is throwing away. I'll have a chance to play with all the hardware and cables at home on my own time and at my own pace.

Link to comment
Share on other sites

but meh I am not even at the paper CCNA level yet so I can't exactly talk. happy.gif

join the club :P

About the packet tracer ccna's yah there is one in my class, her name is amanda, always makes good grades on the exams (though I unfortunately not always, but sometimes I boot up hard and destroy everyone on them :D) But check this out. Someone swapped a straight-through for a crossover on her lab while she wasnt looking.... took her 4 days to figure it out....

@digip - You have to have hands on with cisco equipment to get your shit down, or else you'll be stuck in the water in some things. ya know it's funny really cause if you looked @ my test scores, you would think I am a slacker and a half but get me in front of the hardware and it's a totally different story all-together.

BTW, those cisco tests are FUCKING HARD!!!!! They trick you in every single question, and it's always multiple choice. not fun.

<---OOOH SNAP! 666 POSTS! w00t!

Link to comment
Share on other sites

lol changing the cabling was a little mean but fuck was it funny.

ZOMG you have girls in your class? The closest thing I have are a few guys with man b00bs, so not fucking fun! I demand some eye candy.

I did something stupid the other day in class that I will share, however my own stupidity was over shadowed by my teachers comment in correcting my networking problem.

Our teacher chucked a LAN up on the board and our job was to move devices in this topology to make things more centralized and practical, once done we had to configure it in packet tracer (x1 router x1 switch x1 hub x8 PC's, x3 servers x1 wireless access point x2 wireless clients) . Anyways I did the topology shit with no issue and used the auto cabling option due to being lazy, I set my addressing and enabled a bunch of services on the three servers. With that all done it was time to ping across the network which I segmented up using two different IP classes which resulted in fail. I double checked my address to see if I cocked it up and everything was fine. So I issued another ping which again resulted in fail *insert fucking packet tracer in here.

My teacher over heard my little verbal out burst and asked what the problem is and took a look at my router. his reply was, Um obviously its not going to work seeing as you haven't issued a routing protocol you fool. I was like WTF? You only need a routing protocol if x2 or more routers are being used (which was debated heavily by myself and other students). Anyways I took another look at that router and it turns out I cocked up IP addresses on the fast Ethernet interface's (I applied them the wrong way around for the two networks). Damn I do some stupid shit. =P

Link to comment
Share on other sites

hub x8

BAD BAD SHONEN!! AND TEACHER! collisions r bad mmkay!

used the auto cabling option due to being lazy

BAD BAD SHONEN!!

BTW, you do not actually have to have routing protocols running if you have static routes!

R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0 <fo the default route

R1(config)#ip route 192.168.1.0 255.255.255.252 s0/0/0 <for the serial wan links

R1(config)#ip route 192.168.2.0 255.255.255.0 fa0/0 <for your given network

BTW! Take a gander @ my test score on the cisco test today! (disregard the rest of the texts tho :P)

ciscogrades.jpg

w00t!

Link to comment
Share on other sites

sitting my lcpi 1& 2 soon :) remember every dam command is the hard part sheesh lol

Link to comment
Share on other sites

lol I concur with you on the use of hubs but what can ya do when you don't get to hand pick your devices. Oddly enough after the teacher viewed my topogy he suggested to connect the wireless AP to the hub instead of the switch. I was like =0 are you for really? thats a security issue, hubs forward packets on all ports and you are just asking for someone to run a packet snifffer! *shakes head*

Ah thanks for the info hex, routing protocols and static routes have never been explained to us. We just blidly enter commands into a router not knowing what half of em do. So jah lots of side reading from my ICND book when I have the time. mmmm I should really get off my ass and download the CBT nuggets CCNA shit.

Not to bad on the cisco test scores, I did one of them a last year for a laugh and scored %55, which was surprising since I knew nothing about cisco and only knew some bare basic's.

Link to comment
Share on other sites

well, it depends on what cisco class your taking. there's ccna discovery and ccna exploration. They both are considered to end up being with the same knowledge, but exploration is WAY harder than discovery (and guess which one im in...) but the upside is that it makes you learn more.

shonen, you kno i got lots of material on cisco if you need

phuk it... time for a tutorial.

User Exec mode: basicly the lowest administrative mode you can use on a cisco router. Actually it's not administrative at all. All you can execute is things such as ping, show (tell ya more about that in a minute) and look at different things.

Here is the Example of a user exec prompt:

R1>

Privileged Exec Mode: This mode is where you can do things like look at the routing table and topology tables, etc. and issue debug commands, reload the router or erase the firmware, startup-config, or running-config.

Example of Privileged exec mode prompt:

R1#

Global Config mode: This is the big daddy. If you are in this mode, it either means your the executive administrator at your place of work, or this is your own cisco router you bought second hand... either that or your pulling something pretty illegal :P You can enable, or disable routing protocols in this mode, setup ip addresses for interfaces, setup static routes, the whole bit.

Example of global config mode:

R1(config)#

Some commands to ponder:

user exec mode... havent used anything in user exec exect exit (to log off the router), and enable (to log into privileged exec mode)

privileged exec mode:

show ip interface -this will give you full info on what interfaces are doing, weather they are up (enabled) or down (disabled),what protocols they are using, and what their ip addresses are. also if you add brief to the end it will give you an easy to read summary.

copy -this command is used primarily to do things such as copy your running-config to the startup-config so you dont loose your settings when you restart your router/switch.

ex: copy running-config startup-config

debug - this is an awesome command that will tell you what is going on in certain things in the router.

Ex: debug ip rip -shows in real time what routing table updates are coming in and going through the interfaces setup with rip.

erase -this is used... well you know... to erase stuff...

ex: erase startup-config -erases your startup-config from flash. Fun to do on your neighbors router when he isnt looking :P (dont forget to turn the router off and turn it back on real quick!)

Global config commands:

interface -in any ccna class you'll be using this constantly. This basicly puts you in the prompt to setup any interfaces on the router

ex: interface serial 0/0/0 -puts you in serial interface prompt. From here you can give an ip address to the interface, give the interface a description, and other fun stuff.

line -use this to configure vitrual terminal lines, or the regular console line (the terminal plug on the router)

ex. line console 0 (this puts you in config mode for the terminal plug on the router)

ex. line vty 0 4 (this puts you in config mode for the virtual terminal lines, and it will set all properties for lines 0 through 4.. alternately, it depends on what router your working on as to how many lines the router actually has)

ip -this command does tons of stuff.

ex: ip route 0.0.0.0 0.0.0.0 s0/0/0 -this command sets up a static default route, where if there are no network matches in the routing table, then it gets sent out serial interface 0/0/0)

router -used to do things such as configure a protocol

ex. router rip -puts you in the prompt to setup the rip protocol on a given network directly connected to the router.

banner motd & -lets you set a banner when someone tries to initially login to the router. you type what you want, then type the & and press enter to exit the banner setup.

Example of setting up a router...

A quick and dirty example of what you will do most of the time when setting up a router:

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#conf term

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#no ip domain-lookup

Router(config)#line console 0

Router(config)#enable secret class

Router(config-line)#password cisco

Router(config-line)#login

Router(config-line)#logging synchronous

Router(config-line)#exit

Router(config)#line vty 0 4

Router(config-line)#password cisco

Router(config-line)#login

Router(config-line)#exi

Router(config)#banner motd &

Enter TEXT message. End with the character '&'.

**************************************************************

*!!!!!AUTHORIZED ACCESS ONLY! INTRUDER WILL BE BUTTRAPED!!!!!*

**************************************************************

&

Router(config)#int s0/0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#ver 2

Router(config-router)#network 192.168.1.0

Router(config-router)#exit

Router(config)#exi

%SYS-5-CONFIG_I: Configured from console by console

Router(config)#ip route 192.168.2.0 255.255.255.0 fa0/0

Router(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Router#sho ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

Router#copy run start

Link to comment
Share on other sites

Thats a really good crash course in router setup and commands. I am gonna copy and past this into my cheat shit list for future reference.

I am down with the basic shit, like setting up VLAN's, interface's and all the show commands (didn't now about show brief though) but I cant for the life of me remember setting up static routes, EIGRP, RIP OSPF and access lists. Bad memory and not enough repetition.

Do you always use the full syntax or was that just for making the tutorial ease to follow?

In any case thanks again for the refresher on some the stuff and I learned a couple of handy things. XD

Link to comment
Share on other sites

Do you always use the full syntax or was that just for making the tutorial ease to follow?

In any case thanks again for the refresher on some the stuff and I learned a couple of handy things. XD

thanks man. Yes I only used full syntax for making it easier to follow.

here's a short idea of how it looks when i really do it

en

conf t

ints0/0/0

ro ri

pas

sho ip ro

no ip domain-lo

mo ba &

cop r s

era s

etc.etc.etc.

hell i have to think about it when trying to remember the full syntax... but you really do need to know the full syntax, because it depends on what ver. of IOS your using depends on how short the syntax can be.

Link to comment
Share on other sites

oddly enough I understood all the short hand, weird thing is when I need it I can't recall fuck all. =P

Yeah that is true about the IOS versions and sadly most of the shit we use are on 2500's which have IOS 12.1 I believe. 2500's lick balls and I much rather use the 1800's in the other room that I never have classes in. =P I personally stick to entering in a few letters and hitting the tab key or rely on my good friend the question mark.

Hey have you guys done TFTP servers and putting encryption on your equipment? we just started the encryption shit last week but due to the shitty-ness of 2500's we are pretty much limited to tacacs (or how ever you spell it).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...