Jump to content

FTP sever setup


darkwolf
 Share

Recommended Posts

I am tryin to configure my computer so that I can use my ftp server so that i can let a few people download some stuff from my computer without the hassles of upload limits etc on the free sites. I have run into a problem though nobody can access my server. I left the port as the default for ease of setup but when I have my ports scanned (from outside my network) and all the ports are showin up as "stealth" not "open" or "closed." I have looked on the firewall setup on the router and it has options for allowing outbound ftp server traffic (as well as web server etc) but nobody can establish a connection to any of the ports from the outside. I have just about lost my mind tryin to figure this out. I'm beginnin to think id be better of if my computer was in the DMZ.

Anyway, enough ramblin, if anyone can help me or at least give me some suggestions I would be eternally thankful.

BTW the router/firewall is a pos 2wire from att/bellsouth.

Link to comment
Share on other sites

you need to forward ports 20 and 21 from your router to your computer.

http://portforward.com/

So if your computer is 192.168.1.2

from your router you'd get to port forwarding, and forward port 20 to 192.168.1.2 and do the same thing with port 21.

Secondly you also need an FTP server if you aren't already running one.

http://filezilla-project.org/

Link to comment
Share on other sites

I can't use pfconfig cause "I'm a Mac," not a pc. Being that I am on a mac I already have an FTP server and it's running and as far as i can tell functioning properly.

I have access to the firewall config settings and there is nothing about port forwarding however in the advanced settings I see a window that shows a bunch of check boxes for different options i attached a screenshot so that you can see what I see. I hope it helps.

settingszm3.png

Link to comment
Share on other sites

You will need to map the IP to your computer. You don't do that at your screen. I know, I've had to do it with these lousy routers. It is somewhere under firewall settings.

Look at this screenshot. http://bucket.ontometrics.com/images/2wire-firewall.png

I think you click on the link that says Edit firewall settings.

Ok, I managed to find the window to change the settings to allow incomin ftp. I have been here before and clicked the wrong computer last time. That explains some of the trouble but now shows me that there was more wrong than I originally thought. I found out now that the user account setup is much harder than I would think. I added a user and set it up for shares only like what I read to do when googling this issue. When the remote user tried to login usin the name and pass I provided they got an error message saying that they do not have the rights to acces my FTP server.

Would it be better to just setup a FTP server on linux box and be done with it? I'm curious cause this looks like a wast of time at this point.

And BTW the router is pass protected, you'd be an idiot not to have that done first thing after setup. lol

Link to comment
Share on other sites

And BTW the router is pass protected, you'd be an idiot not to have that done first thing after setup. lol

You'd be surprised...

I hate 2wire products. Had the unfortuanate task of having to set one up for my friend. I'd throw on dd-wrt if you can. I'm a little confused by what you mean setting up shares/user accounts on the router. You do it on the ftp server itself.

Link to comment
Share on other sites

You'd be surprised...

I hate 2wire products. Had the unfortuanate task of having to set one up for my friend. I'd throw on dd-wrt if you can. I'm a little confused by what you mean setting up shares/user accounts on the router. You do it on the ftp server itself.

I was half asleep when i typed that in. lol I gues it shows. I was setting up the user account on the ftp server not the router :)

I would love to give one of the -wrt's but this router isn't mine so thats out of the question. Maybe some other time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...