Jump to content

Can't bring Up Karma


Recommended Posts

I have got Jasager up and running on my fon+ (2201) after much suffering and misery lol :P

The problem I'm having now is that i can't get Karma to start up using the Jasager web page it keeps returning "Karma has been taken down"

I follow a few guides and chopped and changed between a few , so i probably have forgotten some thing somewhere along the line.

Any help would be great, btw is there a command to start it manually ?

Link to comment
Share on other sites

first off, check you patched the madwifi drivers. Run dmesg and look for a mention of digininja and karma, if you don't get them then you missed a step.

If you get them then you can use karma_cli from the command line to do manually take karma up and down. Or you can do it even lower and just run iwpriv karma 1 to turn it on.

Link to comment
Share on other sites

Maybe a copy of /var/log/messages

Not sure if Jasager has it's own log file though.

Link to comment
Share on other sites

Okies thanks for the reply, it seems i did something wrong alright i cant find your name in the output of dmesg.

I get the following when i try and re install the mad wifi drivers

root@OpenWrt:/# opkg install http://www.digininja.org/files/jasager-madwifi_1.ipk

Downloading http://www.digininja.org/files/jasager-madwifi_1.ipk

Connecting to www.digininja.org (78.136.54.17:80)

jasager-madwifi_1.ip 100% |**********************************************************| 257k 00:00:00 ETA

Multiple packages (kmod-madwifi and kmod-madwifi) providing same name marked HOLD or PREFER. Using latest.

Package kmod-madwifi (2.6.26.5+r3314-atheros-1) installed in root is up to date.

root@OpenWrt:/#

I'm using 2.6 OpenWrt hence the opkg.

i get the following with karma_cli

root@OpenWrt:/# karma_cli -s on

Turning Karma On

Invalid command : karma

root@OpenWrt:/#

iwpriv karma 1 returns:

root@OpenWrt:/# iwpriv karma 1

karma no private ioctls.

root@OpenWrt:/#

PLuNK no logs there the var directory is linked to /tmp

Link to comment
Share on other sites

You have to reboot or manually remove the modules and reinstall them for the changes to take affect.

I'm also not sure from your output whether the package installed or not, it isn't clear (not your fault opkg fault). Does opkg have a way to force the install?

Link to comment
Share on other sites

I think I found the problem.

I get the following when trying to reinstall the mad wifi package

* ERROR: Cannot satisfy the following dependencies for kmod-madwifi:

* kernel (=2.6.21.5-atheros-1) *

my Kernel is 2.6.26.5 , don't know how it successfully installed the first time

Link to comment
Share on other sites

Well I'm trying this again, this time following Chris Oliver's blog and using gargoyle

But I'm stuck with the mad wifi drivers again.

I get the following when i try and install the package

root@OpenWrt:~# ipkg install http://www.digininja.org/files/jasager-madwifi_1.ipk

Downloading http://www.digininja.org/files/jasager-madwifi_1.ipk

Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...

Nothing to be done

Done.

Collected errors:

Package kmod-madwifi md5sum mismatch. Either the ipkg or the package index are corrupt. Try 'ipkg update'.

I have tried ipkg update it didnt do any good :(

anyone got any indeas ?

LOL ignore about i should learn to RTFM :P

Link to comment
Share on other sites

I think you may be able to do it with a force, try -f or --force I think. If not, there is a file in /etc with all the md5s in it, you can either remove the md5 for that package or update it with the new one. I've got the filename somewhere if you can't find it but would have to dig it out.

Link to comment
Share on other sites

\o/ finally got it working

The fixed to the md5 thing was in the blog guide:

Now its time to install Jasager. If you attempt to do this without modification, you will hit a roadblock. The package jasager-madwifi_1.ipk will fail to install due to an issue with the md5sum. You need to open up /usr/lib/ipkg/lists/ and remove the entries for kmod-madwifi from any of the files that contain an entry for it. I used WinSCP to edit it
should have rtfm >_>

Thanks for your help digininja

I got the following when installing jasager but i dont think it effected anything:

/karma/bin/create_option_list.rb:16: undefined method `elements' for nil:NilClass (NoMethodError)

from /karma/bin/create_option_list.rb:11:in `each'

from /karma/bin/create_option_list.rb:11

Install finished. Please reboot to ensure all drivers and demons are loaded correctly

Done.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...