Jump to content

Internet sharing in local network


H@L0_F00
 Share

Recommended Posts

ok so I recently setup Ubuntu on an old desktop. I want to (somehow) connect to the internet through my laptop.

here's the setup:

Laptop:-----Dell Latitude D620

OS:---------Win XP sp 2

nic1a:--------Intel® PRO/Wireless 3945ABG

nic2a:--------Broadcom NetXtreme 57xx Gigabit Controller

Desktop:--old dumb Compaq lol

OS:--------Ubuntu 8.1

nic1b:-------Linksys 10/100 Ethernet

nic2b:-------Original Compaq 10/100 Ethernet

Laptop: nic1a------wireless------> router-----ethernet-----> Internet

Desktop: nic1b-----ethernet------> nic1a ---^^^^^^^^-------> Internet

I've tried many setups to no avail and was wondering if you guys could help.

any help and comments will be greatly appreciated and thanks in advance :)

Link to comment
Share on other sites

On laptop 1, did you enable ICS and "allow conenctions to the internet through this computer" on both wireless nics? It under the advanced tab under each network connections settings. It only shows up when both nics are in use. (If one of the nic's is turned off the option is not there to set permissions)

Link to comment
Share on other sites

which software firewall(s) are you using on your dell laptop? also make sure when you setup ICS that you wait to connect the client computer (which in this case would be your desktop) until after you have already configured all the ICS settings. otherwise it wont get the correct IP address from the DHCP service on your laptop. might try repairing the connections to flush the current ip addys.

Link to comment
Share on other sites

i enabled ICS on the wireless but when I try to enable it on the ethernet nic the ICS area isn't visible even after a connection is established :huh:

and i already stopped Zone Alarm so thats not the problem <_<

ok you cant enable ICS on both of them. you have to enable ICS on the network card that is connected to the internet so in this case would be your wireless card. then you have to choose which connection you want to share it to, that would be your local area connection which is your ethernet connection. you also need to select which services network users will be able to use from your wireless card settings, this means that when you connect your desktop it will be able to use those services, such as DHCP, http, etc etc. check your windows firewall too make sure thats not fucking up your connection. also you can leave zonealarm enabled you just have to go into the advanced firewall configs and set it to "THIS COMPUTER IS AN ICS/NAT GATEWAY" it should have the ip addy automatically set to 192.168.0.1 if not you will have to fill it in yourself. also set the connection to trusted zone. and you should be in business.

Link to comment
Share on other sites

how would i choose which connection i want to share it to and which services to enable?

the router sets ips from 192.168.2.2-255 so would i have to set up the laptops ethernet nic ip to static that is valid on the router? and would i have to do the same with the desktop?

Link to comment
Share on other sites

Couldn't you just setup a SSH tunnel?

I SSH to a outside Shell account for web traffic.

Link to comment
Share on other sites

how would i choose which connection i want to share it to and which services to enable?

the router sets ips from 192.168.2.2-255 so would i have to set up the laptops ethernet nic ip to static that is valid on the router? and would i have to do the same with the desktop?

no see you dont have to tell your router anything about your ethernet NIC, windows should automatically set an ip for your ethernet NIC once you share the wireless cards internet connection to it. so basically your etherenet NIC becomes a gateway router of it own with its own ip address. for example your wireless card may have an ip addy of 192.168.2.4 thats assigned from your wireless router, then your etherenet card will have lets say an ip of 192.168.0.1, and it will assign another ip address to whatever device you connect to it. so if yo uconnect your desktop it will probably get an ip issued to it that would look something like 192.168.0.45 or whatever. you can statically set these but its easier to set dhcp and let windows do it for you.

Link to comment
Share on other sites

hmmmm thanks but how would i choose which connection i want to share it with and which services to enable?

and do i need a patch cable or regular ethernet?

ok so when you get to the sharing tab of your wireless connection you may or may not see a drop down box asking you which connection to share it to. if you only have your wireless card and your ethernet card installed then it will automatically share it to your ethernet card. it only has the dropdown box asking you which connection to share it to if you have 3 or more NIC's installed on your computer.

so under the sharing tab of your wireless card it should look something like this

shareing.jpg

you can click the settings tab on that window to enable/disable/add/edit services you want your desktop to be able to use. and that window should look something like this

services.jpg

again make sure that your desktop isnt connected while youre doing this. after everything is setup restart your windows box. then try connection your wireless card to your wireless router, once you have an internet connection then hookup your desktop to your ethernet card of your laptop.

Link to comment
Share on other sites

never mind i got it working. the ethernet nic on laptop was set to static ip and so was nic of desktop

thanks for your help guys!! ;)

awesome stuff sorry my last post was a little late there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...