Jump to content

Ics help


paul
 Share

Recommended Posts

hi

first off i just re flashed my fon and installed jasager 2.1 every thing went great although the wan led didnt work but i found the command to fix that.

alright so after watching episode 412 i though i would give sidejacking a try. everything went great until i tryed to connect to the internet on the mark.

setup

i am using my laptop connected with my wireless card to my home network and then wired to my fon

both connections are setup to obtain ip and i enabled the ICS on the wireless

iam also using tftpd but i am not absolutely sure how to set that up. but this is what it is

ip pool starting 192.168.1.100

pool size 251

DNS 192.168.10.1 (got from ipconfig of my wireless card

default 192.168.101

mask 255.255.255.0

using this setup i can get a mark connected but it cant get internet on it

any suggestions would be appreciated just as long as you dont call me a noob too much :rolleyes:

ps i cant wait to get this working out in the field already have my battery pack and usb done :lol: also played around at a hotel but no internet traffic

Link to comment
Share on other sites

I too am having trouble getting what Darren did to work. Maybe Darren could give us a little bit more written tutorial on how he did it, wouldn't have to be to fancy. I have even tried the other ICS tutorial that is on here, but everytime I set my Fon to 192.168.0.250 I can no longer access it at all.

Also, when I can get it connected, the IP address I am getting that is showing up on the "Mark" is from the Fon, not from the tftpd server, yet the tftpd server is setting an IP address for the "Mark" and the Fon is set to static?

Link to comment
Share on other sites

I'm using tftpd32 to handle my dhcp needs in windows. I understand that others have gotten DHCP working on the fon itself correctly but I have not. I explain this technique in 412, please reference that episode.

Machines connecting to my Fonera (running Jasager) are getting IP addresses from the NIC I have connected to the Fonera.

From what I've understood from this article about ICS with Windows XP, when you enable ICS, a DHCP server is automagically put into play.

"Internet Connection Sharing (ICS) automates the IP numbering task for the ICS clients on your network with the Dynamic Host Configuration Protocol (DHCP) service. The DHCP service enables the ICS host computer to assign IP addresses to its clients automatically. By default, when ICS is installed, the DHCP service begins supplying addresses to computers on the network."

"As part of the process of enabling ICS, the network adapter for the internal network on the host computer is set to a fixed IP address of 192.168.0.1 and a special DHCP server is enabled on that connection."

-..."using this setup i can get a mark connected but it cant get internet on it"

@paul:

As far as not being able to supply "the mark" with a connection to the Internet, you might have to plug some DNS server information into the NIC that gets supplied the address 192.168.0.1 on your laptop, once you enable ICS on the other NIC.

Be well

Link to comment
Share on other sites

Well I did a little troubleshooting and discovered i had two firewalls.. forgot about the anti-virus. I tried again and this time the tftpd32 was having problems with the DHCP because DHCP was already on for ICS. I tried to turn it off but couldn't. It gave a port in use or something like that error don't remember. So gave up on tftpd32 and went back to the guide "_ics_mit_der_jasager.doc" that was on the forum, don't remember who wrote it but credit given. This time I got it working although when "marks" connect to Jasager their IP's don't show in the Jasager page (:1471). I started Hamster and it showed the IP's. Everything seemed to work but the portscan script.. o well

Thanks guys for all the help!!

Link to comment
Share on other sites

  • 3 weeks later...

I think i may need some help also..

Ive got my fon connected to my laptop which has a wireless card which is connecting to my main router/internet

The wireless card to internet is ICS'd its ip is 192.168.2.10

the wired ethernet adapter to the fon is 10.10.10.123

the fon is 10.10.10.1

I set the fon's gateway to 10.10.10.123 in its webif (it is in static IP mode.. is that not correct?)

It seems to be working somewhat... I can ssh to the fon and ping websites and they respond, and can ping ips on my 192.168.2. network and they also respond.. can even wget websites and it is downloaded correctly.

I think my problem is with the tftpd dhcp server stuff. It assigns them an ip on the range of 192.168.2.20 and up fine

I have the 'DNS' and 'gateway' in tftpd dhcpd server settings set as 192.168.2.10 (the ICS'd wireless which goes to internet) (I think thats what im supposed to set it to??)

But when i try to connect to the fon (testing using my NintendoDS) .. it assigns the ip and all that.. but internet doesnt seem to work (even though i can ping off the fon)

Any suggestions?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...