Jump to content

Cant get Karma to turn On. Please help.


Recommended Posts

My betting is you didn't install the madwifi drivers. What happens if you ssh to the fon and do an iwconfig? do you see ath0? if you do, do a dmesg|grep -i karma and see if you get anything back.

If you don't see ath0 then you've no madwifi drivers installed, if you don't see karma returned then you haven't patched the drivers, or you haven't rebooted since doing it.

Link to comment
Share on other sites

Thanks for reply.

The steps I was following was from http://hak5.org/forums/index.php?showtopic=9908

Everything installs fine with the exception of "jasager-madwifi_1.ipk"

1) When I try to install "jasager-madwifi_1.ipk" i get the following...

root@OpenWrt:/tmp# opkg install jasager-madwifi_1.ipk

Multiple packages (kmod-madwifi and kmod-madwifi) providing same name marked HOLD or PREFER. Using latest.

Not downgrading package kmod-madwifi on root from 2.6.26.7+r3314-atheros-1 to 2.6.21.5+r2568-20070710-atheros-2.

When I ssh into the fon and do a "iwconfig" I get the following...

lo no wireless extensions.

etho no wireless extensions.

eth0.0 no wireless extensions.

eth0.1 no wireless extensions.

br-lan no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID: lo no wireless extensions"OpenWrt" Nickname:""

Mode:Master Frequency:2.412 GHz Access Point: ..

etc.etc.etc.

etc.etc.etc.

etc.etc.etc.

When I do a "dmesg|grep -i karma" => I get nothing back

I tried reflashing, rebooting, everything i can think of with no luck. When I open a browser and go to 192.168.1.1 I cannot get Karma to turn On. "Karma is currently: Off"

Link to comment
Share on other sites

Thanks for reply.

The steps I was following was from http://hak5.org/forums/index.php?showtopic=9908

Everything installs fine with the exception of "jasager-madwifi_1.ipk"

Well, thats your problem then.

1) When I try to install "jasager-madwifi_1.ipk" i get the following...

root@OpenWrt:/tmp# opkg install jasager-madwifi_1.ipk

Multiple packages (kmod-madwifi and kmod-madwifi) providing same name marked HOLD or PREFER. Using latest.

Not downgrading package kmod-madwifi on root from 2.6.26.7+r3314-atheros-1 to 2.6.21.5+r2568-20070710-atheros-2.

When I ssh into the fon and do a "iwconfig" I get the following...

lo no wireless extensions.

etho no wireless extensions.

eth0.0 no wireless extensions.

eth0.1 no wireless extensions.

br-lan no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID: lo no wireless extensions"OpenWrt" Nickname:""

Mode:Master Frequency:2.412 GHz Access Point: ..

etc.etc.etc.

etc.etc.etc.

etc.etc.etc.

When I do a "dmesg|grep -i karma" => I get nothing back

I tried reflashing, rebooting, everything i can think of with no luck. When I open a browser and go to 192.168.1.1 I cannot get Karma to turn On. "Karma is currently: Off"

Seeing as you haven't installed the karma'ed madwifi drivers you don't have karma. Remove the installed madwifi package then try installing my version again. You will need a reboot after the install. Check the install worked by the dmesg command above.

Link to comment
Share on other sites

  • 1 year later...

so i removed kmod-madwifi

and now i get this?

root@OpenWrt:/tmp# opkg install jasager-madwifi_1.ipk

Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...

Collected errors:

* ERROR: Cannot satisfy the following dependencies for kmod-madwifi:

* kernel (=2.6.21.5-atheros-1) *

root@OpenWrt:/tmp#

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...