Jump to content

Notes for Jasager on Fon+ 2201


Rob
 Share

Recommended Posts

Hardware: La Fonera+ - Fon2201 with 1.1.0 r2 firmware

Skip straight to step Step 11: Flash FON's firmware.

install gargoyle w/ freifunk (ap51-flash-gui.exe)

http://gargoyle-router.com/

gargoyle_1.0.0_beta2-fonplus-2.6-root.squashfs

gargoyle_1.0.0_beta2-fonplus-2.6-vmlinux.lzma

connect pc to lan interface, plug in wan port... needed by ipkg

installing packages:

note: if ipkg errors, rename /usr/lib/ipkg/status temporarily & install others with -nodeps

ssh to fon

root@OpenWrt:~# rm /usr/bin/haserl

root@OpenWrt:~# ipkg install ./haserl_0.8.0-2_mips.ipk

root@OpenWrt:~# ipkg install -nodeps ./webif_0.3-10_mips.ipk

root@OpenWrt:/etc/init.d# ./httpd_gargoyle stop

root@OpenWrt:/etc/init.d# ./httpd start

got to: http://192.168.1.1/cgi-bin/webif/info.sh

webif interface is up...

disable gargoyle interface on startup and enable webif interface:

root@OpenWrt:/etc/init.d# ./httpd_gargoyle disable

root@OpenWrt:/etc/init.d# ./httpd enable

reboot - webif is running on port 80...

Install Jasager:

root@OpenWrt:~# ipkg install ./libruby_1.8.6-p36-1_mips.ipk

root@OpenWrt:~# ipkg install ./ruby_1.8.6-p36-1_mips.ipk

root@OpenWrt:~# ipkg install ./jasager-madwifi_1.ipk

root@OpenWrt:~# ipkg install -nodeps ./jasager_1.2.ipk

reboot

skip step 19 – do not move /karma/www files – instead use:

http://192.168.1.1:1471/ to access Jasager

Fon+ has 3 interfaces lan, wan wifi – by default wifi interface is not configured

root@OpenWrt:~# uci set network.wifi.ifname=ath0

root@OpenWrt:~# uci set network.wifi.proto=static

root@OpenWrt:~# uci set network.wifi.ipaddr=192.168.66.1

root@OpenWrt:~# uci set network.wifi.netmask=255.255.255.0

root@OpenWrt:~# uci set network.wifi.dns=192.168.66.1

root@OpenWrt:~# uci set dhcp.cfg0875fa=dhcp

root@OpenWrt:~# uci set dhcp.cfg0875fa.start=2

root@OpenWrt:~# uci set dhcp.cfg0875fa.limit=250

root@OpenWrt:~# uci set dhcp.cfg0875fa.leasetime=60m

root@OpenWrt:~# uci set dhcp.cfg0875fa.ignore=0

root@OpenWrt:~# uci set dhcp.cfg0875fa.interface=wifi

root@OpenWrt:~# uci commit

reboot - wireless users get dhcp address

Add firewall rules for wifi interface:

modify /etc/init.d/firewall - added:

config_get WIFI wifi ifname

iptables -A FORWARD -i $WIFI -o $WIFI -j ACCEPT

[ -z "$WAN" ] || iptables -A FORWARD -i $WIFI -o $WAN -j ACCEPT

If you want lan and wifi interfaces to communicate, add:

iptables -A FORWARD -i $WIFI -o $LAN -j ACCEPT

iptables -A FORWARD -i $LAN -o $WIFI -j ACCEPT

reboot - wireless users get dhcp & have internet access...

Start karma automatically with blacklisted ssid’s:

modify /etc/init.d/karma_ui – added to end of start section:

wlanconfig ath0 create wlandev wifi0 wlanmode master &

ifconfig ath0 192.168.66.1 up &

iwpriv ath0 addkarmassid default &

iwpriv ath0 addkarmassid linksys &

iwpriv ath0 karma 1 &

reboot - Jasager works without user intervention....

Thanks to Darren and digininja for making this possible!

Link to comment
Share on other sites

  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

I'm running into the following problem;

root@OpenWrt:~# ipkg install ./jasager-madwifi_1.ipk
Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...
Nothing to be done
Done.
Collected errors:
Package kmod-madwifi md5sum mismatch. Either the ipkg or the package index are corrupt. Try 'ipkg update'.

Any clues?

Link to comment
Share on other sites

I'm running into the following problem;

root@OpenWrt:~# ipkg install ./jasager-madwifi_1.ipk
Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...
Nothing to be done
Done.
Collected errors:
Package kmod-madwifi md5sum mismatch. Either the ipkg or the package index are corrupt. Try 'ipkg update'.

Any clues?

I got an error like this installing haserl on my first attempt. In that case, running ipkg install haserl gave me a url to download a file of slightly different size. I'd recommend downloading jasager-madwifi again to make sure the file is not corrupt. If that doesn't work, rename /usr/lib/ipkg/status temporarily and try to install again.

Link to comment
Share on other sites

Did everything in the steps above. When I get to uci set network.wifi.ifname=ath0 I receive an error message:

uci: Entry not found

and I used uci show to see everything listed. There is no wifi section under the netwok config. I do, however, have a config named wireless - here are the network and wireless options copied from uci show:

network.eth0=switch

network.eth0.vlan0=1 2 3 4 5*

network.eth0.vlan1=0 5

network.loopback=interface

network.loopback.ifname=lo

network.loopback.proto=static

network.loopback.ipaddr=127.0.0.1

network.loopback.netmask=255.0.0.0

network.lan=interface

network.lan.type=bridge

network.lan.ifname=eth0.0 ath0

network.lan.proto=static

network.lan.ipaddr=192.168.1.1

network.lan.netmask=255.255.255.0

network.wan=interface

network.wan.ifname=eth0.1

network.wan.proto=dhcp

~~~~~~~~~~~~~~~~

wireless.wifi0=wifi-device

wireless.wifi0.type=atheros

wireless.wifi0.channel=auto

wireless.wifi0.disabled=0

wireless.cfg0372e0=wifi-iface

wireless.cfg0372e0.device=wifi0

wireless.cfg0372e0.network=lan

wireless.cfg0372e0.mode=ap

wireless.cfg0372e0.ssid=OpenWrt

wireless.cfg0372e0.encryption=none

On the laptop I am using to test, I see the set name for the SSID as well as an unsecured version of my home wireless network on the same channel as OPENWRT (ssid). When I force the connection to the OPENWRT (ssid), there is no internet available. Is it my understanding that the internet should be available, and how does the router handle that? Is that part of the configuration I am unable to complete? I did complete the vi of the firewall below the uci commands, but I would think not having a network option title wifi would be an issue with that part working... I am a N00B, so please be gentle....

Link to comment
Share on other sites

Did everything in the steps above. When I get to uci set network.wifi.ifname=ath0 I receive an error message:

uci: Entry not found

and I used uci show to see everything listed. There is no wifi section under the netwok config. I do, however, have a config named wireless - here are the network and wireless options copied from uci show:

network.eth0=switch

network.eth0.vlan0=1 2 3 4 5*

network.eth0.vlan1=0 5

network.loopback=interface

network.loopback.ifname=lo

network.loopback.proto=static

network.loopback.ipaddr=127.0.0.1

network.loopback.netmask=255.0.0.0

network.lan=interface

network.lan.type=bridge

network.lan.ifname=eth0.0 ath0

network.lan.proto=static

network.lan.ipaddr=192.168.1.1

network.lan.netmask=255.255.255.0

network.wan=interface

network.wan.ifname=eth0.1

network.wan.proto=dhcp

~~~~~~~~~~~~~~~~

wireless.wifi0=wifi-device

wireless.wifi0.type=atheros

wireless.wifi0.channel=auto

wireless.wifi0.disabled=0

wireless.cfg0372e0=wifi-iface

wireless.cfg0372e0.device=wifi0

wireless.cfg0372e0.network=lan

wireless.cfg0372e0.mode=ap

wireless.cfg0372e0.ssid=OpenWrt

wireless.cfg0372e0.encryption=none

On the laptop I am using to test, I see the set name for the SSID as well as an unsecured version of my home wireless network on the same channel as OPENWRT (ssid). When I force the connection to the OPENWRT (ssid), there is no internet available. Is it my understanding that the internet should be available, and how does the router handle that? Is that part of the configuration I am unable to complete? I did complete the vi of the firewall below the uci commands, but I would think not having a network option title wifi would be an issue with that part working... I am a N00B, so please be gentle....

Nevermind - I figured it out - you have to do the following first:

uci set network.wifi=interface

then you can add all the options...

Link to comment
Share on other sites

Ah poopy. It's not bricked yet!

So I tried using Kamikaze 7.09 with ap-51 gui. I thought that'd be easy then the old method I used to get dd-wrt on it. I was wrong. It looked like everything went ok with loading the rootfs and kernel and the ap51 program said it reset the router but I got nothing. Well almost nothing. I've got a Redboot prompt so I've got a way out.

I'm wondering if anybody's gotten here and then what they did?

I'm thinking I'm going to need to do the following to get it up and going again.

RedBoot> fconfig -l -n
boot_script: true
boot_script_data:
.. fis load -b 0x80100000 loader
..  go 0x80100000

boot_script_timeout: 2
bootp: false
bootp_my_gateway_ip: 0.0.0.0
bootp_my_ip: 192.168.1.1
bootp_my_ip_mask: 255.255.255.0
bootp_server_ip: 192.168.1.254
console_baud_rate: 9600
gdb_port: 9000
info_console_force: false
net_debug: false

RedBoot> fconfig
Run script at boot: true
Boot script:
.. fis load -b 0x80100000 loader
..  go 0x80100000
Enter script, terminate with empty line
>> fis load -l vmlinux.bin.l7
>> exec
>>
Boot script timeout (1000ms resolution): 10
Use BOOTP for network configuration: false
Gateway IP address:
Local IP address: 192.168.10.10
Local IP address mask: 255.255.255.0
Default server IP address: 192.168.10.1
Console baud rate: 9600
GDB connection port: 9000
Force console for special debug messages: false
Network debug at boot time: false
Update RedBoot non-volatile configuration - continue (y/n)?y

What do you think?

Link to comment
Share on other sites

From everything I've read and tried the standard openwrt doesn't work on the Fon+ because of an issue with it getting confused with the network cards and so not starting the network up correctly. I haven't got a usb cable yet so I can't confirm that I see the same as you but I tried every method I could find to flash with kamikaze and they all ended up with an unresponsive brick.

Link to comment
Share on other sites

<edit>

Ok, I'm back to DD-wrt v24 with working LAN/WAN and wifi.

So, what's stopping me from implementing this in DD-wrt? I didn't see where that question got fully answered. I'm willing do to some grunt work with cross-compiling, etc but I'd like your input on the probability of getting this to work.

Link to comment
Share on other sites

Nothing is stopping you, go for it.

I've never installed ddwrt so I don't know what you'd need to do, I'm not even sure if it is binary compatible with openwrt. If it is then you could take the tarballs, extract them on your pc then work out where to put them on the ddwrt.

In the end, it is all linux and my stuff is just an application that sits on top of it so it should run fine.

Link to comment
Share on other sites

  • 3 weeks later...

I get a few errors

1.

root@OpenWrt:~# uci commit wireless &amp;&amp; wifi
uci: Entry not found
uci: Entry not found

2.

root@OpenWrt:~# ipkg install -nodeps ./webif_0.3-10_mips.ipk
Installing webif (0.3-10) to root...
xsystem: ERROR: fork failed before execution: `/tmp/ipkg-Tk3Nno/webif-dwtNGJ/preinst install'
preinst script returned status -1
An error ocurred, return value: 1.
Collected errors:
Aborting installation of webif

Renaming status does nothing.

Any ideas. I can't get any further then that. i ignored #1 and moved on but alas nothing works...

Link to comment
Share on other sites

Try to create as much room as possible. So only having the webif package file in /tmp and not all the other packages.

Not sure if it really helps, but you could try killing services you don't need. Stuff like:

- cron

- httpd

- uhdhcpd

- syslogd

- bwmon

Link to comment
Share on other sites

I'm running into the following problem;

root@OpenWrt:~# ipkg install ./jasager-madwifi_1.ipk
Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...
Nothing to be done
Done.
Collected errors:
Package kmod-madwifi md5sum mismatch. Either the ipkg or the package index are corrupt. Try 'ipkg update'.

Any clues?

Did anyone find a workaround for this? I'm running Gargoyle and it has patched madwifi drivers in order to give ethernet support. DD-WRT had no support for them and Gargoyle's were patched from OpenWrt. Is this what is causing the issue? Anything we can do to fix?

Link to comment
Share on other sites

That would be the files in /usr/lib/ipkg/lists/

Iirc it was in both 'packages' and 'release' and not 'X-Wrt' Those were retrieved / created during the install of webif.

Easiest fix is to just delete all entries about kmod-madwifi in those files and try to install the jasager patched madwifi package again.

Link to comment
Share on other sites

That would be the files in /usr/lib/ipkg/lists/

Iirc it was in both 'packages' and 'release' and not 'X-Wrt' Those were retrieved / created during the install of webif.

Easiest fix is to just delete all entries about kmod-madwifi in those files and try to install the jasager patched madwifi package again.

Thanks guys, I'll try that and post back if something goes wrong.

Link to comment
Share on other sites

Everything worked great. I wrote a full tutorial for the Fon+ because every tutorial i found was half complete. You can check it out here and let me know if i missed anything. If it works out nicely, I will edit the wiki accordingly so that it is much easier to follow.

Tutorial: http://excid3.betaserver.org/projects/open...n-the-fon-plus/

Link to comment
Share on other sites

do you have disable the gargoyle interface for jasager to work?

Not for sure, I do know that Gargoyle uses a different web server compared to what Jasager needs so that you do need to enable httpd. They both run on port 80 so im assuming you would need to disable it to get it to work properly.

Link to comment
Share on other sites

well since you have to install the other webserver and then have it running for Jasager to use it, the default administration web interfaces may have some issues, that was what i was trying to say. Both Gargoyle and X-wrt will be running on port 80 if you have both enabled. You can easily go change the config files for the X-wrt interface and have it set to another port through the config files im sure, just don't know which one. I'll have to check on it after finals are over.

Link to comment
Share on other sites

OK some things should be noted:

1)YOU NEED INTERNET ACCESS TO INSTALL WEBIF...

Once you get the f'er flashed with gargoyle go into the settings and set the wireless to AP+client input the SSID you wish for it to connect to including the channel and select bridge wan to lan and change the IP of the fon to something other then 1.1. (i used 2.1 cause my router is 1.1). now switch over to the wan port and restart the router and you now have web access and webif will have no issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...