Jump to content

i feel like this is a retarded question


RogueHart
 Share

Recommended Posts

how can i turn off the automatic lock on vista? it doesnt recognize playing in a ps1 emulator with a game pad as actually using the comp so ever few minutes it locks which stops the game and irritates the hell out of me. it seems like something obvious to me but i cant find where i turn this feature off without taking off the password

Link to comment
Share on other sites

how can i turn off the automatic lock on vista? it doesnt recognize playing in a ps1 emulator with a game pad as actually using the comp so ever few minutes it locks which stops the game and irritates the hell out of me. it seems like something obvious to me but i cant find where i turn this feature off without taking off the password

Disable screen saver and monitor power off?

Link to comment
Share on other sites

how can i turn off the automatic lock on vista? it doesnt recognize playing in a ps1 emulator with a game pad as actually using the comp so ever few minutes it locks which stops the game and irritates the hell out of me. it seems like something obvious to me but i cant find where i turn this feature off without taking off the password

Same answer as above but if you are unsure as to how its done -

Start Menu > Control Panel > Power Options

Which ever plan you are using click "change plan settings"

Set Turn off display to "never"

Set Put Computer to sleep to "never"

As for turning your screensaver off right click the desktop click personalize then "screensaver" then set to "none"

Link to comment
Share on other sites

Same answer as above but if you are unsure as to how its done -

Start Menu > Control Panel > Power Options

Which ever plan you are using click "change plan settings"

Set Turn off display to "never"

Set Put Computer to sleep to "never"

As for turning your screensaver off right click the desktop click personalize then "screensaver" then set to "none"

did both before i posted. it doesnt goto screensaver. it just goes back to the login.

Link to comment
Share on other sites

did both before i posted. it doesnt goto screensaver. it just goes back to the login.

Well I think I have a solution for you, although its a little unorthodox I think it will work!

Basically the idea is this. Every few minutes an app I made uses SendInput to simulate you pressing a key on your keyboard. This should keep Vista from locking you out. Since the gamepad button pressing doesn't register as keys being pressed. But your keyboard does!

So all you need to do is provide the key you want pressed, currently (a-z) only... and how many minutes between pressing the key.

Both parameters are optional but if they aren't provided the default values are used. default character is a, default time is 3 minutes...

So how long about does it take for it to lock you out? if 5 minutes I would do 4, etc... What is a key that is unused by your game? pick one that is unused so that the key being pressed every few minutes does not effect your gameplay.

So say your 'A' key is being used for a button in the game you won't want to use that. There are several ways of passing my app parameters. But here's probably the easiest one that you'll want to use.

Usage: GameHelper [-c character] [-m minutes]

Create a batch file (.bat/.cmd) in the same folder as "GameHelper.exe"

it should contain something like this:

GameHelper -c h -m 4

where "h" is the character it will type every "4" minutes!

change it to a character unused and a time which it will type the character before you get locked out!

As a test you could open up notepad and run Game Helper with -m 0 and character doesn't matter

Then set notepad as your active window, if you see the character constantly being written into the notepad window you can know that it will work! (I've only tested this on XP, not Vista)

Source Code And Binary: (the executable is in the release folder)

http://popeax.com/download/apps/GameHelper.zip

[GameHelper.cpp]

#include "GameHelper.h"

char characterx = 'a'; // default character
int minutesx = 3;       // default minutes

int main(int NumParams, char* Params[])
{
    system("color 0A");
    SetConsoleTitleA("Game Helper! - Made For RogueHart");
    printf("Annoyed with Vista locking you out of your game every few minutes?\n");
    printf("Well thats why Game Helper is here to help you get your game on and keep it on!\n");
    printf("Here's how to use:\n");
    printf("GameHelper [-c character] [-m minutes]\n");
    printf("ex. GameHelper -c r -m 4");
    printf("\nWhere as 'R' will be the key pressed every '4' minutes :P");

    for(int i = 1; i < NumParams; i++)
    {
        if(strcmp(Params[i], "-c") == 0)
        {
            characterx = *Params[i+1];
        }
        if(strcmp(Params[i], "-m") == 0)
        {
            minutesx = atoi(Params[i+1]);
        }
    }

    for(;; Sleep(10))
    {
        ticks++;
        if(ticks == 100)
        {
            ticks = 0;
            seconds++;
        }
        if(seconds == 60)
        {
            seconds = 0;
            minutes++;
        }
        if(minutes == minutesx)
        {
            minutes = 0;
            SendKey((UCHAR)VkKeyScanA(characterx));
        }
    }

    return 0;
}

void SendKey(BYTE vKey)
{
    INPUT* Input = new INPUT;

    ZeroMemory(Input, sizeof(Input));
    Input->type = INPUT_KEYBOARD;
    Input->ki.dwFlags = KEYEVENTF_EXTENDEDKEY;
    Input->ki.wVk = vKey;
    SendInput(1, Input, sizeof(INPUT));

    delete Input;
}

Its worth a shot :)

Link to comment
Share on other sites

You sure it's the login screen and not the locked screen? They are very similar on Vista.

im fairly sure its the locked screen. although its identical to the login screen i get when i start up vista. i just want to extend the time or preferably remove it so i can play on an emulator.

Link to comment
Share on other sites

A question for you would be, is the screensaver coming on when this happens?

if so you can:

Right-click the desktop, click Personalize

Click Screen Saver

Untick box "On resume, display Welcome screen", click OK

no i never use a screen saver

Link to comment
Share on other sites

Why don't you disable the whole lock screen function, I think that would work.

open regedit, go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

Search for the key :

DisableLockWorkstation change its value to 1.

IF this key does not exist, then create it use the type REG_DWORD

Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...