Jump to content

Followed the ICS guide - now I can't connect to Jasager


Recommended Posts

I followed the posted directions to setting up ICS and selected instead to have the IP as 10.0.2.250. I did the save and apply changes and now I can't connect to the Fon via ethernet. I do not get an IP address. If I connect wirelessly I get 192.168.0.1 as my IP on my notebook but still can not connect to 10.0.2.250.

I've tried going through wireless and ethernet using a browser and putty and have had no luck connecting. Not sure what my options are at this point. Am I screwed? Can I get into the Fon via the wireless connection somehow? It no longer gives out an DHCP address when I connect via ethernet.

Please help, everything was working perfectly until I somehow screwed up the ICS guide.

Link to comment
Share on other sites

I followed the posted directions to setting up ICS and selected instead to have the IP as 10.0.2.250. I did the save and apply changes and now I can't connect to the Fon via ethernet. I do not get an IP address. If I connect wirelessly I get 192.168.0.1 as my IP on my notebook but still can not connect to 10.0.2.250.

I've tried going through wireless and ethernet using a browser and putty and have had no luck connecting. Not sure what my options are at this point. Am I screwed? Can I get into the Fon via the wireless connection somehow? It no longer gives out an DHCP address when I connect via ethernet.

Please help, everything was working perfectly until I somehow screwed up the ICS guide.

You can try to hook up the fon and your computer via ethernet cable to a router that has DHCP. It should issue the fon a IP and then you can log in.

If that doesn't work, you can go back to step 11 in the Jasager wiki install guide and re-flash the fon and follow the rest of the guide to get you back up and running.

I had to do it twice after trying ICS also. :)

Link to comment
Share on other sites

Wow, you're awesome. I guess I would of thought that the 10.0.2.250 addy I gave it would of meant it wouldn't pick up a DHCP address but I did what you said and went to my DHCP list on my server and sure enough it picked one up. Logged right in.

Thanks!!!!

Link to comment
Share on other sites

Since this is the same issue I am now having instead of starting a new thread I will try to post here and see if anyone reply if not I will start a thread...

I was also messing around with ICS and I tried to change the device from static to dhcp and back as suggested in one of the posting, but when I changed it to dhcp and apply changes it droped both wifi and Lan(crossover cable) connection.

I tried to connect it to my LAN checked my dhcp but nothing....Is there a way to get back in, I backuped up the flash and config before I start if there is a way to reflash it can I use that bakup?

Link to comment
Share on other sites

I've done a similar set up and I got the fon to see the internet, but for some reason clients on the network cannot access the internet. I have a static IP on the fon as 192.168.1.1 and my windows box is sharing my ethernet on 192.168.1.2. I set up opendns servers and can ping websites from the fon so I know it's working. You can almost always ping from the client machine as well, but they sometimes time out and are generally 400+ms. I do nslookup on the clients as well and that times out too. Anyone know what could be wrong?

Link to comment
Share on other sites

I've done a similar set up and I got the fon to see the internet, but for some reason clients on the network cannot access the internet. I have a static IP on the fon as 192.168.1.1 and my windows box is sharing my ethernet on 192.168.1.2. I set up opendns servers and can ping websites from the fon so I know it's working. You can almost always ping from the client machine as well, but they sometimes time out and are generally 400+ms. I do nslookup on the clients as well and that times out too. Anyone know what could be wrong?

Do you have a gateway setup on the fon to point towards the eth port on your laptop?

this is how i have mine setup

http://iyeman.net/jasager/webifnetworkconfig.jpg

The 1.247 is the ip of the interface on my laptop and the dns server is that of my isp.

EDIT- I noticed the wiki is saying to config the fon to use dhcp not sure why as a static IP in my opinion is better.

Link to comment
Share on other sites

Do you have a gateway setup on the fon to point towards the eth port on your laptop?

this is how i have mine setup

http://iyeman.net/jasager/webifnetworkconfig.jpg

The 1.247 is the ip of the interface on my laptop and the dns server is that of my isp.

EDIT- I noticed the wiki is saying to config the fon to use dhcp not sure why as a static IP in my opinion is better.

That's what I have as well. I have a few more dns servers, but that's about it. The weird thing is, I tested it with my eee pc with linux, my friends mac, and another friends windows laptop. Only the windows laptop was having trouble connecting. The laptop that is sharing the connection is windows.

EDIT: Now all computers seem to be getting decent ping times, but the windows machine still times out when trying access say google.com in a webbrowser.

Link to comment
Share on other sites

That's what I have as well. I have a few more dns servers, but that's about it. The weird thing is, I tested it with my eee pc with linux, my friends mac, and another friends windows laptop. Only the windows laptop was having trouble connecting. The laptop that is sharing the connection is windows.

EDIT: Now all computers seem to be getting decent ping times, but the windows machine still times out when trying access say google.com in a webbrowser.

will it ping google.com?

Link to comment
Share on other sites

will it ping google.com?

Yes, it pings it just fine. I tried a traceroute and it keep hanging up on the second hop, but then just moves on to the next hop and eventually reaches google.

I'm not at it right now, but from what I remember it says the fon's ip, then times out and then jumps to the dns server I told it to use and continues on it's way.

Link to comment
Share on other sites

Well after entering DNS addresses, I'm able to connect to the FON and then to the internet via ICS on my Laptop.

The FON is connected to my Ethernet port and my wireless is connected to my wireless router.

I had to connect to the OpenWrt SSID with a test computer to connect to the FON. Is that correct? I would think you wouldn't need to join OpenWrt and it would automatically connect you to the FON and the FON would pretend it's your AP that you normally connect to.

Also once connected to the FON with the test computer, I log into Jasager using the computer that is hooked up via ethernet to the FON and don't see any connected clients.

Am I suppose to blacklist OpenWrt? Is my FON broken or not working correctly?

It seems as though the logs aren't working now.

EDIT: I rebooted the FON and now the log is working again. I'm still kinda lost though.

Any thoughts?

Link to comment
Share on other sites

This is how my ICS is setup on my MBP.

Also when setting up ICS, on the built in ethernet port on my MBP, after turning on ICS on the wireless adapter that is connected to my wireless network, I left the settings as is without entering a gateway or any DNS servers.

The IP was set to 192.168.0.1.

So my settings look like this on the adapter that is hooked up to the FON.

post-11332-1224813338_thumb.jpg

On the FON network settings, I set the IP to 192.168.0.250 and choose static. I also added a Gateway and DNS server of 192.168.0.1 which is the IP of the adapter that is connected to the FON's ethernet port.

post-11332-1224813655_thumb.jpg

So far it looks as though everything is working. I can access the internet when connected to the OpenWrt SSID on the FON. I also choose this setup because if I go out to a public AP, I shouldn't have to change any settings.

Now the question I have is, should I blacklist the OpenWrt SSID? And why and what does that do?

Thanks.

Link to comment
Share on other sites

I had to connect to the OpenWrt SSID with a test computer to connect to the FON. Is that correct? I would think you wouldn't need to join OpenWrt and it would automatically connect you to the FON and the FON would pretend it's your AP that you normally connect to.

Have you already turned Karma on via the web interface? (as far as i can tell it has to be manually turned on each time the fon is powered on. And if karma is on and running has your test computer ever been to a open(no security) network and saved it with the option to automatically connect the next time its within range?

Link to comment
Share on other sites

Have you already turned Karma on via the web interface? (as far as i can tell it has to be manually turned on each time the fon is powered on. And if karma is on and running has your test computer ever been to a open(no security) network and saved it with the option to automatically connect the next time its within range?

Yes, I turned on Karma. It turns off if you reboot, or unplug the router.

That's what I was going to ask next...

Does Jasager Karma only work on wireless networks that have no security enabled?

At home I use a WPA2 protected wireless, and I unplugged the Access Point to simulate it not there.

So now I guess that is why I didn't see Karma mimic my secured WPA2 AP?

Also, does Karma work only with Windows computers? As I've been not sure to test it with OSX, XP, or Linux.

Link to comment
Share on other sites

Yes, I turned on Karma. It turns off if you reboot, or unplug the router.

That's what I was going to ask next...

Does Jasager Karma only work on wireless networks that have no security enabled?

At home I use a WPA2 protected wireless, and I unplugged the Access Point to simulate it not there.

So now I guess that is why I didn't see Karma mimic my secured WPA2 AP?

Also, does Karma work only with Windows computers? As I've been not sure to test it with OSX, XP, or Linux.

only works on open networks. i believe it works on any device that you can save a network and have it auto connect to when its in range.

Link to comment
Share on other sites

This is a traceroute from a windows laptop connected to the fon. It still makes it, but it freezes on that second step and I think it is stopping everything from connecting. 192.168.1.1 is the fon, and 172.21.40.1 is, I think, the gateway for the computer that the fon is connected to.

C:\Documents and Settings\test>tracert google.com

Tracing route to google.com [72.14.207.99]
over a maximum of 30 hops:

  1     3 ms     1 ms     2 ms  192.168.1.1
  2     *        *        *     Request timed out.
  3     4 ms     1 ms     1 ms  172.21.40.1
  4     5 ms     2 ms     2 ms  phila-gw-F-0-1-100mb.voicenet.net [207.103.158.8
1]
  5     6 ms     4 ms     4 ms  runway-f-4-1-1-hsrp2.voicenet.net [207.103.5.165
]
  6     6 ms     5 ms     6 ms  ge2-5.br01.phl02.pccwbtn.net [63.218.31.21]
  7    11 ms    10 ms     9 ms  74.125.49.77
  8    74 ms    11 ms    10 ms  216.239.48.112
  9    44 ms    44 ms    36 ms  209.85.248.217
 10    39 ms    39 ms    38 ms  72.14.233.113
 11    41 ms    38 ms    36 ms  66.249.94.90
 12    38 ms    40 ms    54 ms  72.14.236.134
 13    39 ms    36 ms    38 ms  eh-in-f99.google.com [72.14.207.99]

Trace complete.

Link to comment
Share on other sites

This is a traceroute from a windows laptop connected to the fon. It still makes it, but it freezes on that second step and I think it is stopping everything from connecting. 192.168.1.1 is the fon, and 172.21.40.1 is, I think, the gateway for the computer that the fon is connected to.

C:\Documents and Settings\test>tracert google.com

Tracing route to google.com [72.14.207.99]
over a maximum of 30 hops:

  1     3 ms     1 ms     2 ms  192.168.1.1
  2     *        *        *     Request timed out.
  3     4 ms     1 ms     1 ms  172.21.40.1
  4     5 ms     2 ms     2 ms  phila-gw-F-0-1-100mb.voicenet.net [207.103.158.8
1]
  5     6 ms     4 ms     4 ms  runway-f-4-1-1-hsrp2.voicenet.net [207.103.5.165
]
  6     6 ms     5 ms     6 ms  ge2-5.br01.phl02.pccwbtn.net [63.218.31.21]
  7    11 ms    10 ms     9 ms  74.125.49.77
  8    74 ms    11 ms    10 ms  216.239.48.112
  9    44 ms    44 ms    36 ms  209.85.248.217
 10    39 ms    39 ms    38 ms  72.14.233.113
 11    41 ms    38 ms    36 ms  66.249.94.90
 12    38 ms    40 ms    54 ms  72.14.236.134
 13    39 ms    36 ms    38 ms  eh-in-f99.google.com [72.14.207.99]

Trace complete.

Try setting the gateway and DNS on the FON to the IP of the adapter that is connected to the FON.

That's what I had to do to get it to work. Look at my pictures above.

Link to comment
Share on other sites

Try setting the gateway and DNS on the FON to the IP of the adapter that is connected to the FON.

That's what I had to do to get it to work. Look at my pictures above.

Still doesn't do anything. I set the fon's only dns to be 192.168.1.2, my computer, and it still times out on the second hop and continues its way to google

Edit: Heres a picture of how it's set up

post-11200-1224889728_thumb.jpg

Link to comment
Share on other sites

Still doesn't do anything. I set the fon's only dns to be 192.168.1.2, my computer, and it still times out on the second hop and continues its way to google

Edit: Heres a picture of how it's set up

post-11200-1224889728_thumb.jpg

my guess would be a firewall application running on the windows machine. The fact that it can ping all the way to google indicates you have internet connectivity.

Link to comment
Share on other sites

The only firewall that's running is Windows Firewall. And strangely enough that was it. I turned off windows firewall and it let me online. Now the question is why, and will this limit me from using jasager on potential windows clients

Link to comment
Share on other sites

The only firewall that's running is Windows Firewall. And strangely enough that was it. I turned off windows firewall and it let me online. Now the question is why, and will this limit me from using jasager on potential windows clients

windows firewall=POS im sure most newbs that goto coffee shops dont have any kind of firewall running :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...