Jump to content

Search the Community

Showing results for tags 'socket'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 1 result

  1. Hi all, I'm pulling my hair out to get this working, it's probably something obvious im missing.. So i could use some extra eyes! I'm trying to send data from the urlsnarf infusion to an application running on the host machine. The application is made in Open Frameworks and listens to udp data on port 11999. I've copied and altered the urlsnarf infusion to properly work besides the original without conflicting. Now where i'm getting stuck at is creating the connection. $socket = stream_socket_server("udp://172.16.42.42:11999", $errno, $errstr); if (!$socket) { echo "Goddamn no socket! at $connection $errno, $errstr \n"; } else { echo "Socket created $connection \n"; } stream_socket_sendto($socket, $input); The error i get is the following: $errorno = 0 and $errstr = Cannot assign requested address I tried multiple addresses to send the data to, but every adres i try get's the same error. What i tried is 172.16.42.42, 10.211.55.2 (the ip of network interface 1 of my virtual machine), 10.37.129.2 (interface 2). I have the application running inside the virtual machine (Ubuntu) my Pineapple get's it's internet from the virtual machine. Many thanks!
×
×
  • Create New...