Jump to content

Search the Community

Showing results for tags 'port forwarding'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • New USB Rubber Ducky
    • WiFi Pineapple
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
    • WiFi Coconut
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • Legacy Devices
    • Classic USB Rubber Ducky
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL







Enter a five letter word.

Found 3 results

  1. Good day guys, I received my lan turtle a few weeks ago. It's been working great. I've had it setup to digitalocean box with Autossh Today I wanted to switch it over to my home office and have it autossh to a VM I'm probably missing something very basic. I've looked over the video Darren as done at for prescient shell and autossh Ok setup working backward. Kali Light (VM) - XenServer - Untangle router/firewall - Modem - Outside I have Untangle port forwarding to XXXX to Kali light to port 22 I'm able to make a SSH connection using XXXX from the outside fine. I've set up keys fine. But when logged into Kali Light and I try to loop back to the turtle by doing a ssh root@localhost -p 2222 I get an error Connect to host localhost port 2222: connection refused. Am I missing something very basic? it's usually the case lol... Thanks
  2. Gr33tingz E@rthl!ngz! am disgraced... I was so stocked on becoming a daily poster on here but due to some issues (like work... blah) ive neglected my newly found family... i know you missed me ... *criquets* anywhoo!! So! Im inquiring on different methodologies a haxorz can use use once gained access to a persons netwrok and this into their router configurations. I beleive myself to be very proficient in the arts of googlefoo, but I must be searching the wrong terms because well... have no idea what I should be looking for .... heres my modest set up. Ive set up a VPC connected to a router i no longer use (linksus WRT31Nv1). My current goal and quandry is how could I set up forwarding option s on my AP so I can pentets hacks.... 1) what would be the advantages of accesing a APs router config? 2) how can one use this to ones hack-advatange? I dont need to be spoon fed, i strive for seeking knowledge on my own but and point to the right direction would be awesome! -ScriptSo
  3. So after a week of everything I could possibly try I've come to the forums to discuss my Autossh Relay connection problem. I'm trying to reproduce Daren's relay server and Chriswat's tutorial and manage the gui remotely. Contents: MkV Virtual Ubuntu Server LTS 12.04 External Box Ubuntu Server LTS 12.04 Windows Putty Ubuntu 13.10 Virtual Phone Hotspot for External IP for MkV Ports: VM Ubuntu Server -p 7000 External Box Ubuntu Server -p 50456 MkV 1471:localhost:1471 First I have a Ubuntu Server 12.04 LTS box setup at work as a file server but it also has openssh-server installed. Then I setup port forwarding on the router and modem for 50456 to internal 22. I've tested this from hom and I can ssh just fine. I generated my public key for my MkV through putty and then ssh through the external IP to the port 50456 and it is now connected. root@Pineapple:~# ssh -p 50456 root@externalip I copied the pinapple public key to the authorized_keys for the server. I added the "AllowTcpForwarding yes" and "GatewayPorts yes" lines to the sshd_config, "service ssh restart". Then I logout. I do "ssh -p 50456 root@externalip -i /etc/dropbear/id_rsa" but for some reason I still have to enter the password. I don't know if I have to install dropbear on this particular server. But then I move on to installing my virtual ubuntu server. I do all the previous steps but this time I use 7000 as the forwarding external port and port 22 as the internal. I also have a ddns provided by asus as I have the Asus N66U router. "ssh -p 7000 root@externalip -i /etc/dropbear/id_rsa" This time I did not need to enter the password and now have an ssh connection from my pineapple to the server. I exit the ssh session. I then go to my web gui on the MkV then to the AutoSSH config and put in Host: root@externalip(VM) (I've also tried adding -p 7000) Port: 4567 Listen Port: 1471 I exit the configuration page and click connect for AutoSSH. Then I setup my phone for Mobile Hotspot and connect my MkV in client mode to my phone. I disconnect my ethernet cable connected to the MkV. I wait a few minutes for my pineapple to make a connection via AutoSSH. Next I power up my ubuntu 13.10 VM and make an SSH connection to my relay server "ssh -p 7000 root@externalip". I pull up a browser and type in externalip:4567. This does not work so I then try externalip:1471. This still doesn't work. I've tried to nail this down to a science before I posted on the forums about this. Please help. Thanks.
  • Create New...