Jump to content

Search the Community

Showing results for tags 'karma wlan0 wlan1'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL







Enter a five letter word.

Found 1 result

  1. Just got a mark 4 from Spain on ebay last week. Using it with the alfa awus036h. After plugging in the alfa, karma won't run. Long story short, karma needs the built-in wifi to be radio0 and wlan0 because of the scripts, and apparently that is the chip it has to run on. But after plugging in the alfa, the built-in radio0 is now wlan1 and karma wont start. I found this code below in /etc/init.d/boot. it looks like it creates a list of devices, I figured we need the alfa chip to always load after the atheros built-in chip (so it will aways be wlan1), so change the order in the list. In directory /etc/modules.d/ there is a list of drivers, change the name of the alfa driver from 26-rtl8187 to 29-rtl8187 and it moves down the list, after the atheros, Thats it! Very well tested and I'm quite proud of my early contributions here. To share internet through your alfa, make it client mode with the network manager infusion, and use the internet connection sharing tab in the manager to share wlan1 to wlan0. load_modules /etc/modules.d/* # allow wifi modules time to settle sleep 1 /sbin/wifi detect > /tmp/wireless.tmp [ -s /tmp/wireless.tmp ] && { cat /tmp/wireless.tmp >> /etc/config/wireless } rm -f /tmp/wireless.tmp for newbies, Other things I've learned, reaver infusion does work fine in 2.8.1. Just needs a good signal. After scan ap, and before attack, disable the wlan1, but not the mon0. Karma works too, it took a while to get associations though without doing any deauths, which I have not tried yet. Having so much fun I bought the new nano and it's shipped too!
  • Create New...