Jump to content

Search the Community

Showing results for tags 'bb.sh'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • WiFi Pineapple
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapple University
    • WiFi Pineapples Mark I, II, III
  • Hak5 Gear
    • Hak5 Cloud C²
    • Bash Bunny
    • Packet Squirrel
    • LAN Turtle
    • USB Rubber Ducky
    • Plunder Bug
  • Hak5 Shows
    • Hak5
    • HakTip
    • Metasploit Minute
    • Threatwire
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 4 results

  1. Hi Been around the forum and can't find any answer. Trying to get the bash bunny online using the bb.sh sharing script. I managed to get access to the bunny thru SSH, but it seams like, that the wlan0 interface shuts down and the new USB Ethernet eth1 takes over. What do I miss here? My Process Guided setup ---------------------- Step 1 of 3: Select Default Gateway Default gateway reported as 192.168.1.1 Use the above reported default gateway? [Y/n]? y Step 2 of 3: Select Internet Interface Internet interface reported as wlan0 Use the above reported Internet interface? [Y/n]? y Step 3 of 3: Select Bash Bunny Interface Please connect the Bash Bunny to this computer. ................[Checking] Detected Bash Bunny on interface eth1 Use the above detected Bash Bunny interface? [Y/n]? y Settings saved. Saved Settings: Share Internet connection from wlan0 to Bash Bunny at eth1 through default gateway 192.168.1.1 SSH Connection ---------------------------- $ssh root@172.16.64.1 root@172.16.64.1's password: _____ _____ _____ _____ _____ _____ _____ _____ __ __ (\___/) | __ || _ || __|| | | | __ || | || | || | || | | (='.'=) | __ -|| ||__ || | | __ -|| | || | | || | | ||_ _| (")_(") |_____||__|__||_____||__|__| |_____||_____||_|___||_|___| |_| Bash Bunny by Hak5 USB Attack/Automation Platform Last login: Sat Aug 26 00:09:43 2017 from 172.16.64.10 root@bunny:~# apt-get update 0% [Connecting to httpredir.debian.org]^C root@bunny:~# iptables --------------- Chain INPUT (policy ACCEPT) target prot opt source destination Chain FORWARD (policy ACCEPT) target prot opt source destination Chain OUTPUT (policy ACCEPT) target prot opt source destination ifconfig -------------- eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 172.16.64.10 netmask 255.255.255.0 broadcast 172.16.64.255 wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 192.168.1.131 netmask 255.255.255.0 broadcast 192.168.1.255 Best Regards Claus
  2. I have tried to run the bb.sh and it wont read the bash bunny, it opens up as a usb storage device even after letting it reset itself. no matter whether the switch is in arm, payload 1 or 2 it only seems to read as a usb storage device. I have let it reset itself twice and every time its the same thing. when i run the bb.sh it gets to the insert bash bunny and once i insert it the bb is green then flashes blue continuously and shows up as storage but the bb.sh script just keeps waiting for it to be inserted. any help would be much appreciated as i haven't ever been able to get it set up since i received it and i am lost as how to fix this. thanks.
  3. I'm on openSUSE Tumbleweed. The problem is that guided setup finishes fine, but "Connect" just stays at "detecting". I cannot ssh into 172.16.64.64 or 172.16.64.1 Edit: I _can_ ping 172.16.64.64 but I cannot connect to the internet with the bunny plugged in so I'm guessing internet is not quite shared yet. After guided setup, I have this in my bb.sh: bbver=1 sbunnynmask=255.255.255.0 sbunnynet=172.16.64.0/24 sbunnylan=enp0s20f0u6c2 sbunnywan=wlp4s0 sbunnygw=192.168.43.1 sbunnyhostip=172.16.64.64 sbunnyip=172.16.64.1 sfirsttime=0 The results of running "ip addr" is the following: _before_ plugging in the bunny: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: wlp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000 link/ether e4:a7:a0:25:8f:dc brd ff:ff:ff:ff:ff:ff inet 192.168.43.20/24 brd 192.168.43.255 scope global dynamic wlp4s0 valid_lft 2866sec preferred_lft 2866sec inet6 fe80::96ba:2993:def5:6187/64 scope link valid_lft forever preferred_lft forever 3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000 link/ether c8:5b:76:4d:d2:22 brd ff:ff:ff:ff:ff:ff inet 172.16.64.64/24 brd 172.16.64.255 scope global enp0s31f6 valid_lft forever preferred_lft forever _after_ plugging in the bunny: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: wlp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000 link/ether e4:a7:a0:25:8f:dc brd ff:ff:ff:ff:ff:ff inet 192.168.43.20/24 brd 192.168.43.255 scope global dynamic wlp4s0 valid_lft 2824sec preferred_lft 2824sec inet6 fe80::96ba:2993:def5:6187/64 scope link valid_lft forever preferred_lft forever 3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000 link/ether c8:5b:76:4d:d2:22 brd ff:ff:ff:ff:ff:ff inet 172.16.64.64/24 brd 172.16.64.255 scope global enp0s31f6 valid_lft forever preferred_lft forever 28: enp0s20f0u6c2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000 link/ether 00:11:22:33:44:55 brd ff:ff:ff:ff:ff:ff inet 172.16.64.64/24 brd 172.16.64.255 scope global enp0s20f0u6c2 valid_lft forever preferred_lft forever inet6 fe80::6450:292d:7ae8:4335/64 scope link valid_lft forever preferred_lft forever
  4. When using mode C with bb.sh I get the following error: SIOCDELRT: No such process
×
×
  • Create New...