Jump to content

Search the Community

Showing results for tags 'Virtual Hosting on Debian'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 1 result

  1. Issue with virtual hosting on port 80. This is a KVM Debian Squeeze 6.X box if that make a diff. and it is NAME Based hosting not I.P. Issue is with the hosts overlapping and the first site is taking precedence. This would usually be caused by needing a VirtualHost directive (which is there). I have been on this issue for around 4 hours now. My google foo is top notch.. but everything I have read points to the httpd.conf file which I actually wrote and debugged, (bc deb's was empty) but Debian does not even use this file, I have the apache2.conf pointing to ports.conf which I created rather than httpd.conf. I also have all the sites-enabled configs set.... But I can use either, both, etc. if needed, (which I have tried). When I do use the httpd.conf file I have created, I then get the return Address already in use: make_sock: could not bind to address. I have set port to *:80 and also tried 127.0.0.1 vice versa and every other config you can think of. I have created a virtual.conf file as well to see if that would fix.. just caused apache2 to dump and not start... so basically back to square one... Funny thing is this box was working on Thursday and many months prior... not exactly sure what happened... Any help is much appreciated... This is my config file.. named 000-default located in the /etc/apache2/sites-enabled/ # # Use name-based virtual hosting. # NameVIrtualHost 127.0.0.1 <---- I have used this, the ip of server, as well as *:80, etc.. various others... <VirtualHost www.example site.com> ServerAdmin webmaster@example site.com ServerName http://ip of server/ DocumentRoot /var/www/www.example site.com <Directory /> Options FollowSymLinks AllowOverride All </Directory> <Directory /var/www/> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all </Directory> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory "/usr/lib/cgi-bin"> AllowOverride All Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory> ErrorLog ${APACHE_LOG_DIR}/error.log # Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost> And here is the actual virtual site config... # # www.example site.com (/etc/apache2/sites-available/www.example site.com) # <VirtualHost www.example site.com> ServerAdmin webmaster@www.example site.com ServerName http://ip of server/ ServerAlias www.example site.com # Indexes + Directory Root. DirectoryIndex index.html DocumentRoot /var/www/www.example site.com # CGI Directory ScriptAlias /cgi-bin/ /var/www/www.example site.com/cgi-bin/ <Location /cgi-bin> Options +ExecCGI </Location> # Logfiles ErrorLog /var/www/www.example site.com/logs/error.log CustomLog /var/www/www.example site.com/logs/access.log combined </VirtualHost> Which all look fine to me..... here is my /etc/hosts... 127.0.0.1 localhost 127.0.0.1 assisted-living-facility.com 127.0.0.1 retirementcommunitiesinflorida.com 127.0.0.1 pridemania.com 108.166.179.126 debian.mcalester.net debian # The following lines are desirable for IPv6 capable hosts ::1 ip6-localhost ip6-loopback fe00::0 ip6-localnet ff00::0 ip6-mcastprefix ff02::1 ip6-allnodes ff02::2 ip6-allrouters My ports.conf file is below..... # If you just change the port or add more ports here, you will likely also # have to change the VirtualHost statement in # /etc/apache2/sites-enabled/000/default # This is also true if you have upgraded from before 2.2.9-3 (i.e. from # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and # README.Debian.gz NameVirtualHost 127.0.0.1 Listen *:80 #<IfModule mod_ssl.c> # If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to <VirtualHost *:443> # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. # Listen 443 #</IfModule> #<IfModule mod_gnutls.c> # Listen 443 #</IfModule> I have just taken out the 443 for diag. purposes... everything is on 80.. Like I said before box was working on my first config just fine for many months... the box powered down thursday and now the issue... maybe a glitch in the matrix?
×
×
  • Create New...